BootCamp "Hack" for USB does not work on Mavericks

Discussion in 'Windows, Linux & Others on the Mac' started by xIlluzionx, Oct 28, 2013.

  1. xIlluzionx macrumors newbie

    Joined:
    Oct 6, 2011
    #1
    I'm looking for a new solution in order to make a Windows bootable USB on OS 10.9 from an older mac that "technically" does not support creating a Windows USB.

    For 10.6 thru 10.8 I was able to go into the package contents of the BootCamp Utility and modify the Info.plist to allow an older Mac to show the "Create a Windows USB" option. However, with OSX Mavericks I am unable to make any change to the Info.plist without getting a nasty error message each time I launch. It seems that Apple has digitally signed the application this time and that is what is causing the issues.

    I tried googling all over and could not find a single solution. Any tips, tricks, or help would be greatly appreciated.

    Thank you.
     
  2. alcarazr macrumors newbie

    Joined:
    Dec 24, 2009
    Location:
    Santander, Spain
    #2
    Codesigning

    I found this link that may help you. Apparently, all you need to do after editing the Info.plist file is to run in terminal the command (with sudo):

    codesign -fs - /Applications/Utilities/Boot\ Camp\ Assistant.app

    Then you will be able to get Boot Camp Assistant to run and create the bootable USB.

    I am trying it right now.

    Best regards,

    Rodrigo
     
  3. xIlluzionx thread starter macrumors newbie

    Joined:
    Oct 6, 2011
    #3
    Excellent! I am work right now but will try this when I get home. If you can let me know before then, I would really appreciate it.

    Thank you.

     
  4. alcarazr macrumors newbie

    Joined:
    Dec 24, 2009
    Location:
    Santander, Spain
    #4
    It worked!

    I can confirm that it works. I have installed Windows 7 on my Macbook Pro Mid 2009 with a broken superdrive. Very happy :D.

    Cheers!

     
  5. xIlluzionx thread starter macrumors newbie

    Joined:
    Oct 6, 2011
    #5
    Thank you!
     
  6. nebirous macrumors newbie

    Joined:
    Oct 29, 2013
    #6
    Hi, I just tried it but the terminal sais "Permission denied" What permissions should I modify? Thanks :)
     
  7. xIlluzionx thread starter macrumors newbie

    Joined:
    Oct 6, 2011
    #7
    Run the command as "sudo"

    Check out my video tutorial on YouTube: "Create a Windows 8 USB Installer on 10.9 Using BootCamp"
     
  8. nebirous macrumors newbie

    Joined:
    Oct 29, 2013
    #8
    It worked! But when I try to run my USB... "No bootable device" :( Does anybody have a solution for this?

    PS.: I'm in an iMac mid 2010.
     
  9. xIlluzionx thread starter macrumors newbie

    Joined:
    Oct 6, 2011
    #9
    Try again, try a different USB
     
  10. Justin Stuart, Nov 6, 2013
    Last edited: Nov 6, 2013

    Justin Stuart macrumors newbie

    Joined:
    Mar 12, 2013
    #10
    @XIlluzionx

    Thank you for the video.

    It was just what I was looking for.
     
  11. SeanEE89 macrumors regular

    Joined:
    Feb 15, 2008
    Location:
    VA, United States
    #11
    Not sure why but this just isn't working for me. What changes did people make to the info file? I've tried a couple things and nothing is working. Bootcamp is still failing on me... :confused:
     
  12. V a d macrumors newbie

    Joined:
    May 17, 2011
    #12
    Fix for windows not installing in bootcamp

    I think I know what your issue is. Try using a separate usb stick for installing the BootCamp drivers. In other words, when using setting up your BootCamp, uncheck the option to download the latest BootCamp drives (you can do this later with a separate usb stick).

    When you actually go to install Windows, only plug in the WININSTALL usb stick (and disconnect all the other usb sticks). The install utility should now launch properly without failing like before.

    After it finishes installing, turn on Windows, log in, eject your WININSTALL usb stick, and reconnect the stick with your BootCamp drivers.

    To install the drivers, open the usb stick and go to BootCamp>setup.

    And enjoy :)
    Hope this helps : )


     
  13. Constar94 macrumors newbie

    Joined:
    Jan 10, 2014
    #13
    Followed all instructions "No bootable device"

    :( Been trying this for the last month following various tutorials I can get bootcamp to setup a USB 'wininstall' I have only got the ISO files in the USB, nothing else, but when I go to boot from the USB either manually or through bootcamp restarting my iMac I just get the message in top left saying no bootable device :/ I have tried holding option on startup and the only images that appear are my macintosh HD and recovery HD... Please help!
     
  14. saturnotaku macrumors 68000

    Joined:
    Mar 4, 2013
    #14
    Use or replace (if broken) your optical drive if your Mac is so equipped.
     
  15. Constar94 macrumors newbie

    Joined:
    Jan 10, 2014
    #15
    Broken SuperDrive... :(

    This is what I'm trying get I get around, using a USB or other means to install windows rather than pay a stupid amount to get a new SuperDrive :/ using the terminal commands to allow a USB boot device in bootcamp I can do but "no boot device" error still shows when trying to boot from the USB.. It's a real pain, I've tried everything p, I don't know where I'm going wrong.
     
  16. Don2047 macrumors newbie

    Joined:
    Jan 19, 2014
    #16
    USB Bootcamp Hack

    Have you ever tried replacing a superdrive in an iMac 21/27? It's a nightmare.....especially getting the new drive
     
  17. VI™ macrumors 6502a

    Joined:
    Aug 27, 2010
    Location:
    Shepherdsturd, WV
    #17
    How are you booting in to the Windows install? With my new rMBP, it would do the same unless I allowed OS X to reboot via doing the bootcamp assistant by setting up the partition. If I tried to reboot myself and manually select the Windows ISO thumb drive, it would boot in to the install, but not see the thumb drive.
     
  18. Crunch macrumors 6502

    Crunch

    Joined:
    Jun 26, 2008
    Location:
    L.A.
    #18
    I have the same problem with the "No boot drive found" after it partitions and attempts to install, after rebooting. The reboot is forced, too, as opposed to earlier when you could "Install later". Another option gone.

    I've tried to ONLY make a Windows bootable USB drive, but with the latest BootCamp software that comes as part of 10.9.1, I cannot uncheck the "Download latest drivers" part.

    This is on my Late-2013 iMac, which DID work with OS X 10.9.0 before, even with FileVault 2 enabled for the OS X partition.

    However, after re-installing OS X with a freshly made and bootable USB installer (10.9.1), I haven't been able to install Windows. I've only used Win 7 64-bit so far. I might try Windows 8/8.1, but this is something that used to work and broke, so I have no reason to believe that another version would make a difference.

    I might try 10.9.2 beta 2, although I was trying to avoid the delta betas. :-(
     
  19. jenzjen macrumors 68000

    Joined:
    Aug 20, 2010
    #19
    IIRC you can uncheck the download latest drivers if you only select create the USB. If you have install windows checked, it automatically forces you to download the latest drivers.
     
  20. Crunch macrumors 6502

    Crunch

    Joined:
    Jun 26, 2008
    Location:
    L.A.
    #20
    No, I don't think so, but it's a moot point, at least for me. (plus, it shouldn't matter the whole uncheck thing, and, as it turns out, it does. ;-) )

    I decided to reset the NVRAM (or PRAM, whatever) and that seemed do to the trick. I also remembered to ONLY have the ONE Windows USB flash drive inserted. By the way, I used the same (and really fast) USB 3 drive in one of my iMac's USB 3 ports, so no blaming things on USB 3, please!

    To do reset NVRAM/PRAM (or SMC, depending on which Mac you have), but most newer models work with shutting your Mac OFF (simply restarting did not work; there, I tried. lol). Make sure you know where the option/command/P, and R keys are on your keyboard because now, whenever you're ready, turn it back on, but IMMEDIATELY hold ALL FOUR keys down for the duration of the reset (10-15 secs.) When the Mac reboots (after the 10-15 secs.), let go of the keys, and should be all set. It sometimes changes a few settings, but that's all easily re-configued in System Preferences.

    Hope this helps! ;-)
     

Share This Page