Bootcamp Issues - 2012 iMac

Discussion in 'OS X Mountain Lion (10.8)' started by Rockondevil, Dec 23, 2012.

  1. Rockondevil, Dec 23, 2012
    Last edited: Dec 23, 2012

    Rockondevil macrumors member

    Aug 25, 2012
    So I've been searching sites for days looking for a solution but yet to find one.

    When I partition the drive with the bootcamp application it restarts and goes to a black screen. The only way to get away from this black screen is to restart and hold option. After holding control my Mac HD and Windows installer USB are the only two things there. If I click on the windows USB it goes back to the black screen.

    Any help is appreciated because this is currently the most infuriating thing I have ever done.

    For the record I am on a 2012 iMac with OS X 10.8.2 with a 1TB Fusion drive.

    Oh and I called Apple but they did not give me any fix and tried to pass the problem onto my Windows disc, which is a legit copy of Windows 7 I had on my previous PC.
  2. Brian Y macrumors 68040

    Oct 21, 2012
  3. Rockondevil thread starter macrumors member

    Aug 25, 2012
    Nope opted for the 1TB fusion because of that very reason.
  4. bigdan43 macrumors newbie

    Dec 27, 2012
    I have the same problem, 27" imac 2012 with i5 with 1TB fusion drive, I start the bootcamp install from bootcamp assistant, it partitions, restarts then I get a blank black screen sometimes with a flashing cursor at top left while it attempts to boot into the win 7 home premium x64 cd. I spend a couple hours last night no luck, I tried calling apple support but the 2nd level tech didn't know anything about bootcamp (he actually asked me if I was using a mac version of windows 7).

    He then referred me to microsoft for troubleshooting even though the dvd boots fine on my pc.

    The two techs I spoke to were also unaware of the 3tb drive bootcamp issue...
  5. Sassers macrumors member

    Dec 10, 2012
    I had the same problem when I tried to set up bootcamp. This is my first Mac and I really wanted to have the windows option for a few programs, but I finally gave up. I also run into a black screen with the message "No boot device available. Please insert a bootable drive and press any key to continue." when I restart my Mac, even after eliminating the bootcamp partition and ejecting the SuperDrive. The only way I can get back into it is to hold the option key when starting to get to the Macintosh HD screen so now I'm very hesitant to ever turn my computer off. I've talked to apple support, but haven't had any luck with them.

    My iMac has a 1tb fusion drive, and my cd is a windows 7 64 bit and worked fine on my previous windows PC.
  6. thirdeyeopen666 macrumors 6502


    Sep 16, 2007
    Sounds like a video driver issue. I had the same problems on my 2009 iMac when it first came out.


    and if that doesn't work:
  7. Rockondevil, Dec 27, 2012
    Last edited: Dec 27, 2012

    Rockondevil thread starter macrumors member

    Aug 25, 2012
    Have already tried those before. I know it seems like a video driver issue but you can't actually install the drivers until after Windows has the basics on. So really it's a OSX problem and it is kind of ridiculous that Apple doesn't fix the problem.
    Why keep it if it doesn't work...

    After my phone convo the guy just said good luck because he had no idea.

    Would be interesting to find somebody who has actually done it on a 2012 iMac.

    So far I've tried a few different .iso files of the Windows 7 disk because the Apple operator tried to blame the problem on that and well it hasn't worked either.
  8. e4xit macrumors newbie

    Dec 24, 2012
    Does your installer USB definitely have the 'boot' flag checked?
  9. bigdan43 macrumors newbie

    Dec 27, 2012
    I fixed my issue, I had a win 7 home premium disc iso, I found a iso which includes sp1 and it booted fine. My issue was the version of the iso I got.

Share This Page