Bootcamp issues installing Windoes 7 on iMac 27" (early 2013 model)

Discussion in 'Windows, Linux & Others on the Mac' started by mariah.blob, Aug 21, 2013.

  1. mariah.blob, Aug 21, 2013
    Last edited: Aug 21, 2013

    mariah.blob macrumors newbie

    Joined:
    Aug 21, 2013
    #1
    Hi guys,

    Firstly I am brand new to the MacRumors forum and am not entirely sure if I am posting in the right section. If I'm not, I heartily apologise.

    I bought an iMac 27" last week and am now trying to partition the hard drive via BootCamp with a copy of Windows Home Premium 7.

    Everything worked fine turning a USB into my Windows drive, as the new iMacs don't have a built in optical drive. Once i got to the installation of Windows, however, I got to choose the language preferences but then had the error message "No device drivers were found. Make sure that the installation media contains the correct drivers." I could browse through the available drivers, which were 'Bootcamp', 'Boot' and then my Windows driver. I tried all three drivers without any result, besides the same error message.

    I then quit the installation which restarted my iMac. It automatically started the Windows installation again, however this time I am stuck with a black screen and the error message, 'No detectable device - insert boot disk and press any key.' I know that I can restart my iMac and go straight back into OSX by holding alt-opt while it boots. I have done so much internet trawling to find a solution, with no luck - what I want, is to be able to finish installing Windows 7 on my Mac, not just to get out of the installation and go back to OSX.

    One suggestion I found was that the USB wasn't being recognised cause its in a USB 3.0 port, and it only works with USB 2.0 ports. Fine, however I don't have any USB 2.0 ports on my iMac that I'm aware of (please correct me if I'm wrong). Again, I don't have an optical drive to try the process again with a burnt Windows 7 disk. :confused:

    Does any body have ANY suggestions, or know any way of making this work? I will forever send you telepathic wishes of longevity and worldly riches for helping me figure this out.
     
  2. magrathea! macrumors newbie

    Joined:
    Aug 21, 2013
    #2
    i'm having the same problem... help some newbies out?
     
  3. xcodeSyn macrumors 6502a

    Joined:
    Nov 25, 2012
    #3
    Not sure this would help but this issue seemed to happen to the late 2012 and newer Mac models without the optical drive, and this link from Apple Support addresses this "no drivers" issue. Also this post seems to deal with the same issue using a little different approach. Hopefully they could help you solve your problems. Good luck.
     
  4. MGus macrumors newbie

    Joined:
    Oct 8, 2013
    #4
    I have exactly the same problem on my iMac... only mine is 21.5" and has built in optical drive. But the issues are the same ("No device drivers were found. Make sure that the installation media contains the correct drivers.")

    Could you fix it? If so, how? I'm so stuck right now, after two days trying to make it work. Followed every step (Boot Camp and Apple guides, etc.)

    Thanks for any/every help!
     

Share This Page