Bootcamp Killed my OSX HDD?

Discussion in 'Windows, Linux & Others on the Mac' started by djhspawn, Nov 5, 2007.

  1. djhspawn macrumors member

    Joined:
    Sep 15, 2006
    #1
    Last night I decided to re-install windows using the bootcamp that came with my 10.5. The first thing I noticed was that it was allowing me to start the windows install without making a drivers disc. This was defiantly different from before. I then installed windows onto the same HDD that I have installed windows on before. This is a HDD that only has windows on it, I have another HDD that is for OSX. The windows install went through without a hitch, but once I was booted to windows I saw that I still needed to install drivers. I tried to boot back to OSX so I could make a drivers disc, but it seemed that my mac pro was not seeing my HDD with OSX on it now. I then removed all HDDs except the HDD with OSX. I then was given a screen on boot up that said, "This is not a bootable device."

    What happened to my OSX HDD? I have never had an issue like this in the past with installing widows using bootcamp. Any ideas?
     
  2. rainforest1155 macrumors newbie

    Joined:
    Oct 9, 2007
    #2
    Ouch, I don't know what happened to your OSX, but I can feel your pain! You could try booting with your OSX disc and see what disc utility has to say about your OSX drive. Maybe you can fix the problem by simply installing OSX again to make the drive bootable if the partition is still in tact otherwise.

    To help you with your original problem: Leopard should all ready contain the Windows drivers on the install disc. So boot up Windows and put your Leopard disc in and you should be able to install the drivers.
    I haven't tried that so far, but I intend to do so when I get my Leopard tomorrow.

    Good luck in getting your OSX back,
    Sebastian
     
  3. phuong macrumors 6502a

    Joined:
    Aug 16, 2006
    #3
    if the osx hdd was untouched, there shouldn't be any problem with it.
    are you sure you didnt delete or format it during windows install.
     
  4. rainforest1155 macrumors newbie

    Joined:
    Oct 9, 2007
    #4
    Are you sure that you used WinXP SP2? A Windows CD without SP2 can do bad things to your Mac.

    Sebastian
     
  5. solvs macrumors 603

    solvs

    Joined:
    Jun 25, 2002
    Location:
    LaLaLand, CA
    #5
    Hold down option when you boot and you should see an option to choose that hd with OS X installed. If it doesn't, boot from the disk. Go into disk utilities and see if you can repair it. If not, try to do an upgrade from the disk. See if it kept anything. Other than that, I don't know what to tell you.
     
  6. phuong macrumors 6502a

    Joined:
    Aug 16, 2006
    #6
    either way, important data should still be there. diskrescueII can do miracle. last week i lost 500GB worth of data, and i was able to recover them all.
     
  7. Wanderer macrumors member

    Joined:
    Jun 29, 2007
    #7

    Mine did the same thing. Exactlly the same way. I re-installed OSX and everything looked alright, until I reinstalled XP and it did it again. I am preparing the drive for a clean install now. I did an upgrade to OSX 10.5 and maybe a clean install will fix it.

    Lewis
     
  8. aaronw1986 macrumors 68030

    Joined:
    Oct 31, 2006
    #8
    Mine did this with Tiger. Just hold option when you boot and choose OS X...then change the default startup drive to OS X, everything should be fine.
     

Share This Page