Bootcamp no longer works...

Discussion in 'Windows, Linux & Others on the Mac' started by mrcr3nk, Nov 22, 2011.

  1. mrcr3nk macrumors newbie

    Joined:
    Nov 21, 2011
    #1
    I received the "files cannot be moved" error on my MBP. I have used iDefrag on the volume in target disk mode yet I still received the error.

    I took a last resort and wiped all partitions and even tried fsck before that. I restore my Time Machine to a new OSX Lion install and still receive the same error. I could only partition my MBP in target disk mode, if I tried to do it on the MBP in Recovery mode, it will tell me I couldn't unmount the disk.

    Running iDefrag, I noticed that at the end of the volume are a few blocks with a Volume header. No matter how much I erase or defray those blocks seem to be unmovable.

    Should i contact Apple Care for a Harddisk replacement?
     
  2. johnhurley macrumors 6502a

    johnhurley

    Joined:
    Aug 29, 2011
    #2
    What did you do exactly between the time that it was working and when it stopped working?

    What do you mean by you received a files cannot be moved message? I have no idea what that means how about some screen shots so other people might be able to help you out more?

    Give us specific details about your machine that you are running ( hardware details ) and software configuration details.

    Most of the time bootcamp problems result from people unfortunately shooting themselves in the foot and blowing off a couple of toes. Changes in partitioning seem to be the most prevalent or running tricky software that makes changes to disk setup. ( Not sure what iDefrag is but most people find no need to defragment a mac file system ).
     
  3. mrcr3nk thread starter macrumors newbie

    Joined:
    Nov 21, 2011
    #3
    I'm using a MBP 15" (Late 2011). I've read that it's a common error once you remove Bootcamp to get the message "Could not partition disk, some files cannot be moved."

    There's a 7-page thread in this forum about the problem. Most found success with the use of iDefrag to hopefully shift the files left over at the end of the drive but I have found no success so far.

    I had a 60gb Bootcamp partition which was no longer booting. I did a /fixmbr through Windows repair and after that it still didn't work. Thinking its best I started over, I wiped the Bootcamp partition through Bootcamp Assistant.

    One odd thing I observed is that I could only make changes to my MBP through my iMac's DU on target disk mode. Meaning anytime I run DU on my MBP, even if it's through recovery mode, the DU wouldn't let me partition the drive giving the error "could not unmount the disk".
     
  4. niksimpsons macrumors member

    niksimpsons

    Joined:
    May 12, 2011
    #4
    Very much agreed with you mrcr3nk!! I was in the same situation some days back. I found one alternate to bootcamp called parallels Desktop. This utility provided me simple interface to install windows7 on my mac mini.
     
  5. mrcr3nk thread starter macrumors newbie

    Joined:
    Nov 21, 2011
    #5
    Seems like thats where I am headed as well. Oh well.
     
  6. athens macrumors member

    athens

    Joined:
    Apr 1, 2004
    Location:
    Vancouver, Canada
    #6
    Easiest arr I should say best solution when this happens is to backup with Time Machine, erase hard drive, restore with Time Machine then run bootcamp. Backup and Restore takes hours depending on how much stuff you have. But its the best method to fully defrag your hard drive including those files that can't be moved.
     
  7. johnhurley macrumors 6502a

    johnhurley

    Joined:
    Aug 29, 2011
    #7
    Did you remove Bootcamp by using the bootcamp assistant to delete the partition or did you try some other way of removing it?

    AFAIK using bootcamp assistant to remove it should be working well.

    My impression ( perhaps incorrect ) is that many people are trying a mix and match approach to setting up and modifying and removing bootcamp.

    The bootcamp manual as short as it is ... seems to be something that many people perhaps could have spent a little more time reading.
     
  8. mrcr3nk thread starter macrumors newbie

    Joined:
    Nov 21, 2011
    #8
    Hi, I have removed Bootcamp using BCA. I definitely did my research before attempting the fixes. Coming here was a last resort. I have even read through all the pages in this discussion:

    http://forums.macrumors.com/showthread.php?t=191729

    My question is, having tried iDefrag, already wiped my mac and restored Time Machine, what other alternatives are there? I even tried CMD+S and -fsck, repairing of file system through target disk mode.

    I guess the best method is to move to Parallels =/
     

Share This Page