Bootcamp off Thunderbolt...

Discussion in 'Windows, Linux & Others on the Mac' started by bkar89, Jul 27, 2012.

  1. bkar89 macrumors regular

    bkar89

    Joined:
    Jul 27, 2012
    Location:
    Norway
    #1
    Hi!

    I want to install Windows on my rMBP, with its 256gb SSD, installing bootcamp on internal is a non option. So i ordered a 4TB WD Thunderbolt Duo, since its a TB to SATA controller.

    i started easy, going trough bootcamp assistant, making that do all the "hard work". The install to the TB drive went fine, it even booted up no problem. So its possible.

    Just, i rather have the 4tb raid0 config for Mac OS. (as far as i know, partitiong a raid0, is not possible?) To solve this, i shucked an "old" SATA drive in there, partitioned it to MBR, EFI sees it at boot. Starts the installer, but when i get to the select install disk in the windows installer, it wont install on that drive. I've tried to format it, delete and create new... neither worked.

    I searched the error code on google (i'm at work, so i cant supply that code atm, might be able to later if its necessary) And it seemed to be a somewhat known error. Some solved it by removing all the other harddrives. on the mac, with pentalobe screws, thats not a simple task.

    I'm going to take a leap of faith here... i'm not the only one who would like this to work? no clutter with partitioning your system drive, run windows off external have been my dream as since 09, when i got my first mbp

    I might try the following:

    * Try to install W8 Consumer Preview
    * Time machine back up my system drive. do the bootcamp way, clone the drive, and copy it to the external with norton ghost

    Does anyone have a sound solotion?
     
  2. murphychris macrumors 6502a

    Joined:
    Mar 19, 2012
    #2
    The problem is that Apple's Windows support uses a CSM-BIOS boot mode, which in turn requires the disk to have an MBR, which in turn has a 2TB disk limit. Not a 2TB partition limit. It's a disk size limit.

    This must be a bug. In every case I've pointed Boot Camp Assistant to a disk larger than 2TB it refuses to resize it. If you know the /dev/diskX number for this external disk issue the following commands and post them:

    Code:
    sudo gpt -r -vv show /dev/diskX
    sudo fdisk /dev/diskX
    If you don't know the disk number, you can find it using
    Code:
    diskutil list
    You should check the forums for the Windows EFI thread. They've had some success getting Window x86_64 to EFI boot on a Mac, instead of using the CSM-BIOS. Windows x86_64 EFI will use GPT only which doesn't have a 2TB disk limitation.

    I've thought of how to get CSM-BIOS mode boot to work with a disk larger than 4TB. It would require both MBR and GPT to be present. The MBR can only define partitions using sectors for the first 2TB so your Windows partition must be less than 2TB on this external disk. And then for sectors beyond 2TB you'd enter those in the GPT.

    If you don't understand this at all, you've got a long road ahead if you want to make this work. It's a lot easier to get a smaller disk. The Windows EFI route will require hacking, and the hybrid MBR + GPT route will require command line usage and knowledge about MBRs and GPTs.

    You might find GPT fdisk useful, a.k.a. gdisk. You may also find a Linux Live CD useful which will have an fdisk that can edit an MBR using sectors (LBAs) instead of Mac OS X's fdisk which only edits MBRs using CHS and is thus useless.

    Do make sure you flag only the Windows partition in the MBR as bootable.

    ----------

    Another option is to use the SSD to boot Windows, with a minimal install. Partition the 4TB disk only as GPT, with a partition for Windows stuff and Mac OS, and then install all of your apps on the 4TB disk.

    CSM-BIOS mode booting Windows limits it to an MBR *boot* disk. It can still use a GPT secondary (non-boot) disk and see more than 2TB.
     
  3. bkar89 thread starter macrumors regular

    bkar89

    Joined:
    Jul 27, 2012
    Location:
    Norway
    #3
    I partitioned the internal drive, with bootcamp, but selected the 4TB disk inside the windows installer... stopped working after i removed the bootcamp partition on the internal drive.

    Thanks for the info tough, i think i've met the wall when it comes to my tech know how on this subject. I'll look into the Windows EFI project, sounds interesting!

    Just to note: I did have another go at bootcamp on the internal drive, and cloned the finished (bootable) windows install with norton ghost, cloned the MBR and initialized it as boot disk. But it didn't work. It stuck at white blinking bar at boot up (this on the smaller 320gb SATA drive, placed inside the mybook thunderbolt case)
     
  4. murphychris macrumors 6502a

    Joined:
    Mar 19, 2012
    #4
    Code:
    sudo gpt -r -vv show disk0
    sudo fdisk /dev/disk0
    Please post results, formatted with code tags: after pasting the results, highlight results, click the # button in the tool bar.
     

Share This Page