Bootcamp on Optibay'ed Macbook Pro 2011 (8,2)

Discussion in 'Windows, Linux & Others on the Mac' started by macfan74318, Jan 3, 2014.

  1. macfan74318 macrumors member

    Joined:
    Aug 9, 2011
    #1
    I need help.

    I picked up a used Macbook Pro Retina (15"), last month, and I gave my old Mac to my Mother, as she needed a computer, and I wanted the Retina Display. After she used it for a week or two, she became frustrated with OS X, and wanted to go back to Windows, which I can understand. So I figured that this would be a simple process.

    So I installed a clean copy of Mavericks on the 2011 Macbook Pro, and fired up Bootcamp. Because this is an Optibay'ed machine I had to use Roxio to trick Bootcamp into thinking there was a disk. After I created the partition, I went to my Retina Mac and wiped an old external HD I had lying around and used that to create the Windows 7 Installer, using the Bootcamp USB Installer, on the retina. After when I tried to get the 2011 Mac to boot it just said it couldn't find the drive. I tried this process twice, with the same result.

    Next I tried to get Boot Camp Assistant on the 2011 Mac to create the USB installer. I removed the previous partition, and I edited the plist, and it worked. The 2011 Mac gave me the option to create the USB installer, and Boot said installer, and as I stated earlier, I did everything from stratch. But I got the same error, the computer wouldn't boot into the external drive, but when I put that drive into the Retina Mac it booted without issues. For reference here is the thread that I used: https://discussions.apple.com/message/23831358#23831358

    After that I tried to use Vmware to Install the OS. I followed the following guide 8na.de/?p=124 and I got the Windows installer to copy the files to the BootCamp partition and I closed VMware when the VM said it was done copying files and about to reboot. When I killed the VM, I shut down the 2011 Mac, and tried to boot into the Windows OS, but I got a corrupted BSD/bootloader error, so I tried to use the USB Installer to boot into the repair, but again it wouldn't boot. I then tried to use the VM to repair the boot loader, but all it does once it finished the repair and I reboot into the partition using the option key is give me a slowly blinking underscore. Oddly enough, if I let the VM continue the install it completes it and it only boots in the VM, and if I try and use the bootcamp boot feature in VMware, it give me the same underscore slowly blinking.

    So now I am very lost, I don't think there is an issue with my partitions, because I when I checked the 2011 Mac, and compared it to the Reitna Mac apart from sizes its seems okay. But I will post it below if it helps. My main goal is to have Windows, for this computer OS X is NOT important, but any version of Windows is required, and I would rather not have to deal with VMware, as my mother is not that tech literate, due to school I won't always be around to help her.

    [​IMG]

    Thank you for any help,
    macfan74318
     
  2. macfan74318 thread starter macrumors member

    Joined:
    Aug 9, 2011
    #2
    Could I just Install via EFI on my 2011 Macbook Pro (8,2)?

    Open to all suggestions.
     
  3. SideStepSociety macrumors 6502

    SideStepSociety

    Joined:
    Feb 12, 2011
    Location:
    Vancouver, BC
    #3
    If you have the optical drive still, it'll be easiest to reinstall that and install Windows to your SSD that way.

    2011 MacBooks will not boot Windows from an external data drive.
     

Share This Page