BootCamp on rMBP

Discussion in 'Windows, Linux & Others on the Mac' started by DannyDrama, Nov 19, 2013.

  1. DannyDrama macrumors regular

    Joined:
    Aug 30, 2009
    #1
    It won't work.

    I'm using an external drive, bootcamp says it's successful. Upon rebooting however, I'm greeted with 'no boot device found'. I've used multiple drives, different USB ports, different ISO, different bloody everything. I've got as far as option + reboot. It sees my drive as 'wininstall' but will not boot from it.

    I read somewhere I NEED an external optical reader but I can't see that being true. I'm not buying one just to install windows anyway.
     
  2. blueshirt31 macrumors newbie

    Joined:
    May 21, 2012
    #2
    Sorry, I am a bit puzzled here. At first I understood that you installed Windows on an external drive which will not work. As far as I know Windows itself will only boot from internal drive, unlike OS X.

    Now, I read that you cannot boot from device. I have this issue if I use USB 3 drive on my MBA. It will not even see USB drive upon boot. If I hook it up via USB 2 adapter it will boot just fine. Likewise, no issues if using any USB 2 flash drive (cheap ones seems to work best). In my case it seems MBA (2012) has a hardware issue with USB ports.

    You said you tried various drives, some could be hit and miss, try borrowing or buying some cheap USB 2 flash drive or connecting your current drive(s) via USB 2 adapter, if you have one lying around and see if that resolves your issue.
     
  3. DannyDrama thread starter macrumors regular

    Joined:
    Aug 30, 2009
    #3
    I'm trying to install win7 using an external hdd. The bootcamp utility is successful in writing the ISO and reboots.

    Like I said, I've tried multiple drives (4), multiple ISOs (5), multiple USB ports (2). I'm using both USB 2.0 and 3.0. Nothing has worked.

    I've reformatted as every format type under the sun. Simply put, it just will not work.
     
  4. blueshirt31, Nov 19, 2013
    Last edited: Nov 19, 2013

    blueshirt31 macrumors newbie

    Joined:
    May 21, 2012
    #4
    HDD? I must admit that I have never tried that myself. It makes sense it will work being either HDD or USB drive (pen-drive). Boot Camp makes whole thing automatic so you do not need to think about partitions, formatting, drivers. It does all that...well, it should. The only thing that I have encountered that booting from USB 3 compatible drive (either HDD or flash drive) can be hit or miss with MBA. However, USB 2 (only) devices seem to working just fine.

    It won't solve your issue, but did you/can you try booting from flash drive on another machine (PC/Mac)? Just to rule out non-bootable issue with drives themselves.

    Another option - instead of creating bootable drive via Boot Camp, try creating one using a Windows machine with this tool: http://www.microsoftstore.com/store/msusa/html/pbPage.Help_Win7_usbdvd_dwnTool

    It is pretty straightforward, choose ISO location, insert a drive and let it do the rest.

    Alternative is to use Remote Disk if you have another computer with DVD drive. http://support.apple.com/kb/HT5287?viewlocale=en_US&locale=en_US

    I realise that you might not have a second computer to try any of these but I cannot think of any way to resolve this besides verifying that created installation disk is indeed bootable (another computer). Trying to re-create disk via Boot Camp or Windows USB tool without manually formatting/creating partitions on destination drive.

    Stupid question, but if you used HDD to do the installation, did you create partition table/partitions manually first? It could be MBR/GPT issue. Use a drive which you can fully erase and use for installation.

    Edit: It would be best if you could provide more details machine model/year, OS version, type of HDD/pen drives you are using... Perhaps someone who has the same model could be of a more assistance. Maybe there is a workaround of which I am not aware of. Apple recently issued EFI updates for 2013 models which could help if you did not apply the updates, for example.
     
  5. DannyDrama thread starter macrumors regular

    Joined:
    Aug 30, 2009
    #5
    I don't have another machine, but perhaps a VM would suffice? I've seen no posts about that. As you say, all I seem to need is a viable MBR/VBR/GPT.

    As for system spec: 15'' rMBP, Early '13, 2.4GHz, 8GB.

    I've tried many drives, flash drives, but the only one I have available now is a 1TB internal drive from my recently deceased desktop. It's worked for Time Machine and every other purpose.
     
  6. blueroom macrumors 603

    blueroom

    Joined:
    Feb 15, 2009
    Location:
    Toronto, Canada
    #6
    I use WMware Fusion for Windows, works like a charm if you're not gaming on Windows.
     
  7. DannyDrama thread starter macrumors regular

    Joined:
    Aug 30, 2009
    #7
    I was thinking of using something like that to make a bootable drive. Not sure if that would work, google is on the case as I type.
     
  8. blueshirt31 macrumors newbie

    Joined:
    May 21, 2012
    #8
    The most painless solution would be to install Windows as a virtual machine in a program of your choice (VMware, Parallels, VirtualBox). It should suffice if you are not a gamer. I know there is a way to turn a Boot Camp install into a VM. I am sure there is a workaround to do the opposite. VM would allow you to try to create install disk from Windows so it does not hurt.

    If you already have data/partitions for other purposes on that disk and are simply using a part of the drive to create bootable disk that could be the issue.

    Did you try booting with ALT/Option with drive plugged in? Does it recognise Windows installation partition? What happens when you try to boot? Any error messages or...? I do not know if in this case something like rEFIt would help: http://refit.sourceforge.net (discontinued) - http://www.rodsbooks.com/refind/ (fork of the project)

    As blue room mentioned VM would be best solution if you can't get installation to work with any HDD/USB drive and can't get a hold of external DVD drive.
     
  9. DannyDrama thread starter macrumors regular

    Joined:
    Aug 30, 2009
    #9
    Well the VM was a fail. I'm not sure what happened but a format via windows failed halfway through and borked my drive. Now looking into reviving it.:rolleyes:
     

Share This Page