Bootcamp on the new MBAs

Discussion in 'MacBook Air' started by Yixian, Jun 13, 2013.

  1. Yixian macrumors 65816

    Joined:
    Jun 2, 2007
    Location:
    Europe
    #1
    Anyone managed it?!

    I'm trying to install Win 7 and oh my GOD this has been the most frustrating Bootcamp attempt in my entire life, and that's saying something.

    I have two ISOs, one of my full Windows installation, the other of a stripped down version. Neither of them are recognised by the Bootcamp Assistant, both of them give "error 254" and "invalid argument" when attempting to restore them to a USB stick. However this happens when trying to restore those ISOs on my old MBA, and my iMac!

    I tried burning them to a DVD and plugging in an external drive, but the drive powers down during the installation process and freezes.

    Restoring to an MS-FAT partition of my SSD also results in "error 254".

    I'm going mad, I can't think of anything else to try.
     
  2. radiohead14 macrumors 6502a

    Joined:
    Nov 6, 2008
    Location:
    nyc
    #2
    just replied to your other thread.. but yea, from what i recall.. it was just gathering the drivers into a usb, plug my external with my ISO copy of Win7, format the partition (don't think I even needed a Fat partition), and then install from external. once set up.. plug the usb stick with the drivers.
     
  3. omgitscro macrumors 6502a

    omgitscro

    Joined:
    Jul 12, 2008
    #3
    Where did you buy Windows 7 from? If you got the official download I don't see why it wouldn't work. I just installed Windows 8 and I didn't run into any errors. Try a legitimate ISO, it may be the case that whatever ISOs you downloaded have problems.
     
  4. Yixian thread starter macrumors 65816

    Joined:
    Jun 2, 2007
    Location:
    Europe
    #4
    One is my own legit ISO, the other is one I made a while back with some utility to strip it down and make it small.

    They both work when booted from DVD, the only problem is that my external DVD drive is USB powered and just turns off during the installation process.

    The error is somewhere else... Something to do with the ISOs I think, because I have tried multiple flash drives.
     
  5. Yixian thread starter macrumors 65816

    Joined:
    Jun 2, 2007
    Location:
    Europe
    #5
    Tried downloading another different ISO, still no luck. Same errors: invalid argument or error -254.

    I can't even find an explanation online as to what these errors even mean.
     
  6. cas85, Jun 13, 2013
    Last edited: Jun 13, 2013

    cas85 macrumors regular

    Joined:
    May 4, 2010
    #6
    I'm gonna try a legit iso of Win 8 tonight I get from school. I'll post back my results.

    Edit: Looks like it worked. I haven't actually installed it yet, but I got to the point when I can which it seems is further than you guys have got to. I'm just not sure if I want to use it as a VM or as a separate partition so I haven't installed yet.
     
  7. truciet macrumors 6502

    Joined:
    Jun 16, 2008
    #7
    Make sure it's a 64 bit ISO. 2013 MBA only supports 64 bit.
     

Share This Page