BootCamp Partition Disappeared

Discussion in 'Windows, Linux & Others on the Mac' started by Aspencrown, Feb 24, 2013.

  1. Aspencrown macrumors newbie

    Feb 24, 2013
    Hello there!

    As the title of the thread suggests, my partition for Windows via Bootcamp has up and vanished...

    I was trying to increase the partition size via Camptune, though the program froze my computer solid and gave me no other option than to force reset. When I did, I found that my Windows partition was no longer found.

    I tried restarting, shutting down, repairing permissions from Utilities, booting from the Recovery HD and repairing permissions and running a Disk Check (came back clean). There is still no sign of the partition and it does not seem to show up when I look at the partition tab when I look at my hard drive.

    I did try to read through a few other threads that are like this, but for the sake of caution since Terminal gave me different results...

    I inputted this via Terminal:
    The results I received are:

    Is this at all the correct way to go about this? I'd appreciate any help!

    Thanks in advance.
  2. justperry macrumors G3


    Aug 10, 2007
    In the core of a black hole.
    There is a line in there which says it all:
    gpt show: disk0: Suspicious MBR at sector 0

    If you add the next line in Disk Utilities plist file it will show you all partitions.

    File to Edit: in your Home Library

    then For type: Boolean : checkmark on (1 or Yes)
  3. Aspencrown thread starter macrumors newbie

    Feb 24, 2013
    Thanks, JustPerry.

    Though, I will be frank, I am rather rubbish with doing Terminal commands so I am not seeing where to do what you instructed...

    Could you break it down a little bit more? Sorry for the request for additional handholding, but I appreciate the help.
  4. Aspencrown, Feb 25, 2013
    Last edited: Feb 25, 2013

    Aspencrown thread starter macrumors newbie

    Feb 24, 2013

    I have looked everywhere to try and do what was suggested to me, but I have no idea how to do it. I cannot locate the Disk Utility PList that was mentioned before, so I cannot change it.


    I did look through Console and found some interesting messages, though. Adding them just in case they might be useful:

  5. murphychris macrumors 6502a

    Mar 19, 2012
    The easiest thing to do is to repartition the drive with a single partition (in Disk Utility, partitions tab, change scheme from Current to 1 Partition; and then restore from OS X backup; re-run Boot Camp Assistant to create the Boot Camp partition and restore from Windows backup.

    The problem with merely fixing what you have, is that it's in an ambiguous state, and therefore there's no single course of action that automated tools will arrive at. Fixing this may not be possible, and attempting to fix this might make the problem worse. So in any case hopefully you have backups.

    It would be interesting to see the output from:

    sudo fdisk /dev/disk0
    And also install gdisk and report the output from:

    sudo gdisk -l /dev/disk0


    This is actually normal for Boot Camped drives. A GPT drive has a Protective MBR, also called a PMBR, which is an MBR with a single partition entry, type EE, that has a start and end sector covering the entire disk. It's meant to indicate to MBR applications that the entire disk is reserved and shouldn't be modified. Type EE is the code to indicate that the disk is a GPT disk, and the GPT should be used instead of the MBR. Boot Camp modifies the MBR to add additional entries, making it no longer a PMBR but a hybrid MBR. The hybrid MBR is non-standard, and because there are two partition maps on one drive, can result in ambiguous descriptive state of the disk. So the gpt utility is merely noting that the MBR is not a PMBR.
  6. Aspencrown thread starter macrumors newbie

    Feb 24, 2013
    Here is what I got...

    Also, in response to your previous comment, did you mean restore my ENTIRE HD?
  7. justperry macrumors G3


    Aug 10, 2007
    In the core of a black hole.
    I just attach mine, because I don't think you have Developer tools installed, you could edit the plist before in an older OS X version with TextEdit just fine but I see it's not so easy anymore.
    You should place this in /Users/****/Library/Preferences (Folder), I would recommend you to keep the old file for a bit, if this file works you then can delete the old one.
    If you don't see your Library which is default on Lion and Mountain Lion you can click on Go-Go To Folder... in the menu bar and paste the above path.
    **** is your User name

    Note: It's zipped, could not attach the bare file.

    Good to know, I did not know this, cheers.

    Attached Files:

  8. murphychris macrumors 6502a

    Mar 19, 2012
    Where are the results from fdisk?

  9. murphychris macrumors 6502a

    Mar 19, 2012
    Also, Disk Utility only shows GPT entries. It won't show you the state of the MBR. Therefore when troubleshooting Boot Camp'd drives, Disk Utility is essentially useless.
  10. Aspencrown thread starter macrumors newbie

    Feb 24, 2013
    That was all that was given to me, sadly...
  11. murphychris macrumors 6502a

    Mar 19, 2012
    You're confused. Please try again:

    sudo fdisk /dev/disk0
  12. justperry macrumors G3


    Aug 10, 2007
    In the core of a black hole.
    What about after I installed Paragon NTFS, it seems to repair without problem.
    BTW, I did not use bootcamp to install W7, I resized it to have 3 partitions and then installed W7 and Linux.

    Edit: I still have to download the W7 drivers though and need bootcamp for that, or I might find them directly on Apple's site.
  13. Aspencrown thread starter macrumors newbie

    Feb 24, 2013
    Fair enough! Here is what I have.

    Disk: /dev/disk0	geometry: 121601/255/63 [1953525168 sectors]
    Signature: 0xAA55
             Starting       Ending
     #: id  cyl  hd sec -  cyl  hd sec [     start -       size]
     1: EE    0   0   2 -   25   6  46 [         1 -     409639] <Unknown ID>
     2: AF   25   6  47 - 1023  51  27 [    409640 - 1754688896] HFS+        
     3: AB 1023  53  54 - 1023  40   8 [1755099136 -    1269536] Darwin Boot 
     4: 00    0   0   0 -    0   0   0 [         0 -          0] unused   
  14. murphychris macrumors 6502a

    Mar 19, 2012
    Unfortunately, the MBR also lacks an entry for a Windows partition.

    If you bought Camptune, I'd be talking to their tech support about this until they give up. I haven't ever used Camptune, but I'd like to believe it creates a log file of everything it's doing, including recording the state of the two partition maps before resize, all of the parameters of the resize, whether the resize was actually completed correctly, and some indication why the MBR and GPT are totally valid and synchronized yet lack a Windows entry. The very last part is interesting because the fact neither the MBR nor the two GPT tables are corrupt, but both also lack the Windows entry that certainly was there before the resize.

    But you don't say how long you waited from the time the resize started and computer become unresponsive to the time you did the reset.

    So your first step is to contact Paragon about this experience and see what assistance they can offer, because your system is in between states and really only they can have an idea what that might be.

    The alternatives: 1.) start over entirely from scratch (blow away OS X and Windows, repartition with 1 single partition in Disk Utility, restore OS X, resize with Boot Camp Assistant, reinstall Windows, restore Windows data); 2.) Go down a rabbit hole trying to find the start of this NTFS volume, which is still on your disk, add the proper partition entries, see if NTFS-3G's ntfsresize utility recognizes a valid NTFS volume, and if it is whether the volume size matches the size of the partition, if not the NTFS volume needs to be resized to match, and then do repairs with Windows' chkdsk /f from the Windows DVD.


    That doesn't enable Disk Utility to display the state of the MBR. The MBR is a partition table. The GPT is a partition table. There should be only one or the other; albeit the convention is if GPT is used, the disk also has an MBR with a "fake" entry that claims all disk sectors are allocated (to partition type ID xEE, the cod for GPT), which I described before.

    But Boot Camp creates a hybrid MBR, which is an MBR whose first entry is xEE, but it also has additional entries (for a total of four possible entries), so in effect the disk has two partition maps. And Disk Utility only shows partition information from the GPT, if present, and ignores the MBR.

    What Paragon is probably adding that lets Disk Utility do some repairs is an fsck for NTFS. But I haven't used Paragon NTFS, so that's speculation on my part.

    You resized what, using what?
  15. Aspencrown thread starter macrumors newbie

    Feb 24, 2013

    1) Wait Time: I was letting Camptune run for about 25 minutes, which made no progress, then when I was trying to close a window in another program it locked up my computer tight. Nothing I clicked, pushed, or did helped it - my mouse eventually stopped functioning.

    2) I contacted Paragon and I am still awaiting a response. I am...not expecting them to be timely at all with this, but we'll see.

    3) I'm most likely going to go ahead and just wipe my hard drive and start from scratch. While it will take a while to do, I feel more comfortable about doing that over "going down a rabbit hole" and doing things I don't fully understand. Plus, I've read your stuff and I find you really knowledgable - and if you are seeming to say that it's looking mighty grim, then them's the breaks.
  16. murphychris macrumors 6502a

    Mar 19, 2012
    Filesystems are designed to resize from the end point, not the start. The HFSJ resize goes pretty quickly because it's resized as designed, from the end point which is moving forward to a lower LBA (shrinking). The NTFS volume on the other hand, has no room to grow because it's already at the end of the disk. So first it has to be relocated. Then it can be resized. And this could take hours.

    I'd say mistake #1 is doing anything at all while running Camptune. I have no idea what their instructions are, but my expectation would be to rebuild the catalog b-tree for the OS X volume before starting, which is an offline rebuild (you can boot in single user mode to do this); and run chkdsk /f to force a full traversal of the NTFS file system, rather than merely trusting the journal. Then reboot, and only run Camptune to resize.

    Mistake #2 is getting impatient, even when it appears frozen. Doing nothing wastes 2-3 hours. But interrupting a file system resize process invariably corrupts the file system being resized.

    Without logs that clearly indicate what was going on at the time it was interrupted (either by crashing, or by being force shut down), there's no way to know the state of the NTFS file system, it would probably take exhaustive work to figure it out. If it was in the middle of moving the file system when the interruption occurred, practically speaking it's toast.

    I'd call them and report back.

    It is grim, but wheter tedious grim or impossibly grim, depends on whether there are Camptune logs and if they show where the interruption occurred.
  17. Aspencrown thread starter macrumors newbie

    Feb 24, 2013
    *Nods* I understand.

    Good news, I heard back from Paragon and they are trying to troubleshoot. Some of the help I am receiving is close to what you have said, but I am posting for the sake of posterity.

    No news on whether or not Camptune has a logging diagnostic, but I did ask the tech again.
  18. murphychris macrumors 6502a

    Mar 19, 2012
    The problem is that the resize was interrupted, and you don't have a 4th partition entry at all for Windows. Resyncing isn't going to fix that. Neither the GPT nor the MBR have a Windows entry.

    If the interruption occurred after resizing HFSJ, during the move of the NTFS file system, but before it was resized, recovery isn't possible with conventional tools. You'd need a serious expert or professional data recovery. In any other case it's much more likely one could find the current NTFS superblocks, and figure out an appropriate partition entry to make in the GPT, then create a new hybrid MBR.

    This is why a log file is needed. Without it, the state is unknown and not so easy to figure out.
  19. tonupi, Mar 2, 2013
    Last edited: Mar 2, 2013

    tonupi macrumors newbie

    Mar 28, 2010
    bootcamp do not start

    Hi all,
    from yesterday i have a problem with my Bootcamp partition,

    doesn't start anymore, i've tried some suggestion i've found here, and nov this is my situation.

    Last login: Sat Mar 2 11:56:51 on console
    MacBook-Pro-di-Simone-old:~ simonegaviglio$ sudo gpt -r show disk0
    gpt show: disk0: Suspicious MBR at sector 0
    start size index contents
    0 1 MBR
    1 1 Pri GPT header
    2 32 Pri GPT table
    34 6
    40 409600 1 GPT part - C12A7328-F81F-11D2-BA4B-00A0C93EC93B
    409640 207031248 2 GPT part - 48465300-0000-11AA-AA11-00306543ECAC
    207440888 1269536 3 GPT part - 426F6F74-0000-11AA-AA11-00306543ECAC
    208710424 1256
    208711680 791502848 4 GPT part - EBD0A0A2-B9E5-4433-87C0-68B6B72699C7
    1000214528 655
    1000215183 32 Sec GPT table
    1000215215 1 Sec GPT header
    MacBook-Pro-di-Simone-old:~ simonegaviglio$ sudo fdisk /dev/disk0
    Disk: /dev/disk0 geometry: 62260/255/63 [1000215216 sectors]
    Signature: 0xAA55
    Starting Ending
    #: id cyl hd sec - cyl hd sec [ start - size]
    1: EE 1023 254 63 - 1023 254 63 [ 1 - 409639] <Unknown ID>
    2: AF 1023 254 63 - 1023 254 63 [ 409640 - 207031248] HFS+
    3: AB 1023 254 63 - 1023 254 63 [ 207440888 - 1269536] Darwin Boot
    *4: 07 1023 254 63 - 1023 254 63 [ 208711680 - 791502848] HPFS/QNX/AUX

    I really hope in a help.

    Thank you in advance.



    i forgot to say that from ML i can read and write on Bootcamp partition.



    after rebooting twice , the bootcamp partition started ,

    so thank you very much, i think refit recovered my corrupt mbr.

    thank again

  20. murphychris macrumors 6502a

    Mar 19, 2012
    The problem isn't related to the MBR or GPT. They're in sync, and the Windows partition in the MBR has the active flag set. So it's something else. I suggest you run Windows Startup Repair.
  21. tonupi macrumors newbie

    Mar 28, 2010
    thank you for the answer,
    the problem with that mac now is solved,

    but i noticed that all my problems maybe are related with paragon ntfs
    or paragon hfs+

    i explain:
    i've 2 mbp17 and 1 mac mini server
    all 3 with ML 10.8.2 and bootcamp Windows 8

    recently i installed paragon ntfs on all ML partition and paragon hfs+ on two win 8 partition , one win 8 on mbp17 uses MacDrive.

    yesterday: two machine did not boot win mac partition and the other (the one with Mac Drive) did not boot Bootcamp partition, but with the help of this thread i solved the problem.

    now i still have to machine that won't boot on mac partition (better to say that they boot with the apple and a loading bar , but after loading the mac switch off) , but from windows i can see and edit files on MacintoshHD.

    Could you suggest me something to try before reinstall ML as suggested by RecoveryHD?

    Thank in advance

  22. justperry macrumors G3


    Aug 10, 2007
    In the core of a black hole.
    Sorry to reply so late, didn't see it or overlooked in my MR Notifications.

    I resized with Disk Utility (Macintosh HD while booted in OS X on Macintosh HD), I then created both a Windows and Linux USB stick and installed the OSes, I have no problem at all booting any of these, but, I do not see Linux in the Boot Manager, I have to click the Windows Disk and then get a sub Menu in the next screen with all of my partitions.

    My output (btw) from fdisk /dev/disk0 is different than others here:

    1: EE 1023 254 63 - 1023 254 63 [ 1 - 409639] <Unknown ID>
    *2: AF 1023 254 63 - 1023 254 63 [ 409640 - 825168120] HFS+
    3: AF 1023 254 63 - 1023 254 63 [ 825577760 - 1269536] HFS+
    4: 07 1023 254 63 - 1023 254 63 [ 826849280 - 97376256] HPFS/QNX/AUX

    #3 is not Darwin as the others
  23. murphychris macrumors 6502a

    Mar 19, 2012
    The problem is Windows 8. It's not explicitly supported by Apple or by Paragon. Windows 8 by default modifies NTFS file systems in such a way that corruption is induced when a non-Windows 8 OS writes to that volume.

    No. Quite honestly I'm not understanding most of what you've written, I think there's some sort of language barrier occurring. And second, I haven't done any testing with Windows 8, nor do I use any of Paragon's software so I'm ill equipped to offer suggestions. You've paid for those products, you should direct inquiries for those products to those companies. Chances are they'll decline support since you're using an unsupported configuration. It's the sort of thing that happens to bleeding edgers.

Share This Page