Bootcamp partition size incorrect

Discussion in 'OS X Mountain Lion (10.8)' started by tarjan, Aug 25, 2012.

  1. tarjan macrumors regular

    Joined:
    Aug 11, 2006
    #1
    So here is my issues, during the upgrade to ML, I was presented with an error saying no installable drives found. Looking at the notes for lion, there was a similar error that just required a small change, a resize for example, to the partition table. Then the installer would see the drive and the world would be happy.

    Worked for me. ML is up and working great.

    Unfortunately my bootcamp isn't. Using partition wizard I can see that it changed the size of my bootcamp partition from 454.29 gb to 200mb. It didn't, however, overwrite anything. There were no additional partitions created in that same block, and using a partition data restore utility from minitool I was able to load the partition up (after 9 hours) and pull out the critical data I needed. All of the files appear to be there.

    The question now is, can I fix it or should i just re-do the install? Just in case I missed something, I would rather fix. The thing is I can't figure out what utility will let me *non-destructively* change the end block of a partition, given that the starting block is correct.

    Anyone know of a utility that can do this? I was about to download and try gparted. Tried the partition fixer utility from minitool and it does not see the partition for one reason or another, even if the partition restore (file recovery) utility by the same company does find the partition and all of the files from it.
     
  2. dusk007 macrumors 68040

    dusk007

    Joined:
    Dec 5, 2009
    #2
    What you need is TestDisk.
    That is the ultimate tool for repairing partition tables.
     
  3. tarjan thread starter macrumors regular

    Joined:
    Aug 11, 2006
    #3
    BINGO! 60 minutes later and the drive is back. Doesn't want to boot, but that's probably a boot record or something simple like that and will fix with win7 disk.

    It was actually on the gparted disk. That is one fantastic group of utilities!
     

Share This Page