Bootcamp USB Sticks and Mojave 10.14.4

Discussion in 'Windows, Linux & Others on the Mac' started by macsforme, Apr 1, 2019.

  1. macsforme macrumors regular

    Joined:
    Mar 16, 2007
    #1
    I’m not sure if this has been discussed already, but I found another issue with the Bootcamp utility in the latest version of Mojave.

    As we know already, the Bootcamp utility has been non-functional on Mojave running on the MacPro5,1, but in the past I’ve been able to run it on another compatible machine, then use the USB stick installer on my Mac Pro to install Windows. That appears to be no longer the case.

    The first issue (under Mojave 10.14.3 and the October 2018 Windows ISO) was an error about not enough space on the USB stick, which seems related to this article here: https://support.apple.com/en-us/HT209351. After updating to Mojave 10.14.4 as the article directs, the Bootcamp utility succeeded in making a USB stick installer. However, the MacPro5,1 appears to be unable to see this USB stick in the boot menu nor in the Startup Disk control panel (other machines can see and boot from it, however).

    From my investigation so far, it appears that the new Bootcamp utility now formats the USB stick installer as ExFAT rather than FAT32, which I believe is not supported for booting on the MacPro5,1. What I discovered when I tried to work around this with Unetbootin, is that the Windows installer file “install.wim” exceeds 4GB in size, which means it exceeds the maximum file size of the FAT32 partition format. So it appears that a Windows installer cannot be put on a FAT32-formatted USB stick anymore.

    There are older versions of Windows with “install.wim” files under the 4GB limit, but I’m not sure how far back you have to go (even the April 2018 version exceeds it, which seems to be the latest version you can download from Microsoft). Regardless of which version of Windows you use, the Bootcamp utility now appears to only use ExFAT when formatting the drive. So it appears that your options now are: 1) use an older windows installer ISO with an older version of Bootcamp on another machine to create the installer, or 2) burn the ISO to a DVD and boot from that. I was not able to find any other workarounds so far.

    Hope this helps someone.
     
  2. bookemdano macrumors 65816

    Joined:
    Jul 29, 2011
    #2
    Burning to DVD is preferable anyway because it guarantees you a CSM/BIOS install rather than UEFI. UEFI mode doesn't behave properly on the cMP--MS puts multiple signing certificates in the cMP's bootrom and it could potentially cause corruption and inability to even power on the machine.

    That said, have you tried using the official Microsoft method to make a Windows USB stick? If you have access to a Mac (or a functional bootcamp install) you can download the Windows 10 Media Creation Utility and use that to make a USB flash drive installer. I believe I used that method with one of last year's builds (1803 maybe?) and it booted in the cMP just fine. In the end though, I reinstalled from a DVD so I could guarantee a CSM install.

    I have no idea if you'd have any better luck using the Microsoft tool rather than bootcamp assistant, but seems like it would be worth a try.

    Edit: Also, don't necessarily rule out that the cMP just doesn't like the particular USB stick you're trying to use (unless you've already tried this with multiple sticks of different makes).
     
  3. macsforme thread starter macrumors regular

    Joined:
    Mar 16, 2007
    #3
    Interesting. So when I use the Windows 10 Media creation tool (under Windows 10 1809), I get a FAT32-formatted USB stick, which is bootable on the MacPro5,1. I looked through the drive for the sources\install.wim file which was causing issues, but there was none, and instead there was a sources\install.esd file which was about 3.5GB in size, which is within the 4GB FAT32 file size limit. I wonder what this tool does differently that allows a USB installer stick to be FAT32-formatted. Regardless, good news for us Mac Pro owners, at least those of us who have access to an existing Windows 10 installation.

    As far as DVD installations guaranteeing a CSM/BIOS versus UEFI install, I think you can actually do either with both. The boot selector seems a little finicky, sometimes showing different options depending on whether the DVD or USB drive were inserted prior to booting, or hot-plugged later, and sometimes I get different results immediately after an NVRAM reset. But for example, this is what I get when I open the boot selector and then insert the DVD (an older version... 1507, I believe) and USB drive:

    IMG_3892.jpg
     
  4. startergo macrumors 6502a

    startergo

    Joined:
    Sep 20, 2018
    #4
    I believe both disks in the bootpicker are from the DVD and the orange EFI from the USB
     
  5. bookemdano macrumors 65816

    Joined:
    Jul 29, 2011
    #5
    Glad I could help. As for the DVD method guaranteeing a CSM install, I was referring to holding the "c" key at boot, which for a Windows DVD will always boot the installer in BIOS mode. Whereas with a USB stick it either won't boot at all or always boots in UEFI mode.
     
  6. macsforme thread starter macrumors regular

    Joined:
    Mar 16, 2007
    #6
    So apparently I have to retract my statement about the Windows installer media creation tool working. Now that I have actually tried installing Windows with that USB stick I made with it, it appears to not be the same full installer. There is no option to select the target disk you want to install to, and then it gives some error about the “unattended” process failing. So at this point, I don’t see any option for MacPro5,1 users except to burn the ISO to a DVD, or else use an older version of the Windows installer ISO.
     

Share This Page

5 April 1, 2019