Bootcamp - Windows 10 on El Capitan public beta

Discussion in 'Windows, Linux & Others on the Mac' started by taptic, Aug 3, 2015.

  1. taptic macrumors 65816

    taptic

    Joined:
    Dec 5, 2012
    Location:
    California
    #1
    So, I've got a new computer running El Capitan public beta and now I'm trying to dual boot Windows 10 with bootcamp. I can get as far as Windows 10 running, but have no drivers working. Bootcamp doesn't take care of this like I'm assuming it's supposed to from the tutorials I've seen (this is the first time I've tried installing windows on a mac). I've tried downloading and running the drivers file manually, but apparently it doesn't support the latest MacBook Pro or something because it says it wasn't designed for this model or something.

    Anyone else tried this yet or have any suggestions? I have contacted Apple support but they were only able to tell me that for an OS X beta I was kind of out in the rain at the moment- especially considering Windows 10 was just officially released.
     
  2. Tamagotchi macrumors 6502

    Tamagotchi

    Joined:
    Jun 13, 2013
    #2
    I used the bootcamp option to "download the latest windows support software from Apple" - put it into a USB and insert the USB into the W10 partition of my mac to install the drivers. <- Did you try this?

    Also, as the video drivers that get installed by default through the bootcamp support software are quite ******, I go to nVidia's website and download the latest version of their drivers for my dedicated GPU.
     
  3. taptic thread starter macrumors 65816

    taptic

    Joined:
    Dec 5, 2012
    Location:
    California
    #3
    That's the weird part. I've seen the screen where you select it to download the support software in tutorials, but it seems to skip it when I do it. Here's what happens:

    1. I open bootcamp
    2. It asks me to select an ISO file, which I do.
    3. It asks me to decide how much space to give the windows partition, which I do.
    4. It then starts a loading screen. Among other things it's loading it, at some point, says it's downloading the necessary windows support software.
    5. It then transfers me to the windows installation process. When complete, my drivers aren't installed though.

    Anyone know where I might find the specific drivers for a rMMP 2015? I'm willing to do this manually, I just can't find any other files than what is on Apple's website, and they aren't compatible with my model apparently...
     
  4. boabmatic macrumors member

    boabmatic

    Joined:
    Oct 13, 2011
    Location:
    scotland
    #4
    I ran the bootcamp drivers install as per Tamagotchi post by I did the download via Yosemite not El Capitan.
    Only got El Capitan installed on an SD card for testing at the moment.

    Note that Windows 10 now auto updates drivers , it installed updated Win 10 Nvidia drivers without prompting.
    I think there is a way to defer them for a bit but couldn't find a way to switch it off.
     
  5. bensimpsy macrumors newbie

    Joined:
    Sep 5, 2013
    #5
    I haven't been able to get this to work at all. I get an error message telling me the partition is not GPT even though it is and I cannot proceed with the installation. Has that happened to any one else?
     
  6. dusk007 macrumors 68040

    dusk007

    Joined:
    Dec 5, 2009
    #6
    That used to be a problem with old bootcamp versions like in pre Windows 8 era. Bootcamp is emulating a BIOS which it really shouldn't because since Windows 8 UEFI is the preferred foundation.
    You could try installing without the bootcamp assistent. Free up enough space in disk utility and then boot the windows media from flash drive or something. When Windows installer boots create the partition. It will do it correctly.
    Or if you are upgrading you might just have to do a fresh install, because your old windows install runs on BIOS.
     

Share This Page