BootCamp - Windows 7 cant complete install - no keyboard/mouse

Discussion in 'Windows, Linux & Others on the Mac' started by hallhotdogma, Jun 28, 2013.

  1. hallhotdogma macrumors newbie

    Joined:
    Jun 28, 2013
    #1
    Hi Guys

    Just got a new Macbook Air - i5/4gb/256gb/OS X 10.8.4. It's my first Mac and I'm in love.

    I would like to boot strap Windows 7 Ultimate but cannot finish the installation as I cannot use the keyboard and mouse. So no boot in safe mode for me as installation has not finished. I tried a USB keyboard but that wouldnt install drivers.

    Has anyone had this and what was your workaround? Tried to find an answer to this one but cant seem to! Your help is appreciated!
     
  2. sloop john b macrumors newbie

    Joined:
    Jun 27, 2013
    #2
    I have the same exact problem and haven't found a solution anywhere yet either. Very frustrating............ please update if anyone finds something on this somewhere. thanks
     
  3. WhackyNinja macrumors 68000

    WhackyNinja

    Joined:
    Jul 6, 2012
    Location:
    Kissimmee, FL
    #3
    Have you tried Windows Support Tools. Its a file you download and burn it on a disc before you Boot Camp Windows 7. I used it and it fixed many of my driver problems (Aero, Keyboard, Wifi etc.)
     
  4. fedecape macrumors 6502

    fedecape

    Joined:
    Oct 23, 2011
    Location:
    Miami, FL
    #4
    I had the same problem.
    I don't know if it was a coincidence or what, but on my first attempt I didn't check the Windows Drivers check box (tickbox?) while I was preparing my computer with the BootCamp assistant.

    I restarted, opened BootCamp again and I checked that box. Restarted, booted with my usbdrive and had no issues at all.

    In fact, during the Windows installation, the screen resolution was now adjusted, meaning that my graphics card was recognized and the driver was installed.
     
  5. gpeden macrumors regular

    Joined:
    Nov 24, 2007
    #5
    Hi,

    Did you read the other threads on this Macbook Air forum? Did you try what Apple support found regarding having the USB stick for the support software on the left USB port (this means to download the support software on this side too) and the superdrive in the right?

    Good luck with this! I must have partitioned and unpartitioned my poor SSD about 8 times trying different things, before I made the call. And then boom! It worked with that one change.

    Glen
     
  6. coolio93 macrumors 6502

    Joined:
    Apr 15, 2013
    Location:
    Houston, TX
    #6
    I had this problem and it took my hours to find a fix. Apparently the problem presents itself because the keyboard/mouse in the new MBA are usb3.0 which require a driver not present in the windows 7 install media.

    Here is what I did:

    First erase any history of trying to install windows.....that means use boot camp or disk utility to delete any windows partitions that you may have created.

    Now restart your laptop

    from here on:

    1)download a windows 7 iso from here:

    http://answers.microsoft.com/en-us/...i-have-a/7d964b05-2be9-4800-bc7f-3ca30356fc3d

    (This is a legit copy of ultimate from the Microsoft website)

    2) start bootcamp and when it asks you what you want to do, check the first two options (create windows 7 install disk and download support media)

    let it work...once it is done then quit bootcamp COMPLETELY.

    3) start bootcamp again and this time select install support media to the same usb drive

    let it work and then quit bootcamp COMPLETELY.

    4) start bootcamp and this time select install windows 7. bootcamp will automatically restart your computer into windows setup. From there continue on like normal.

    you have to let bootcamp restart your computer (you can't close bootcamp and then restart from the menu yourself...you must let bootcamp do the restart)

    your usb drive shouldn't come out of your computer during any of these steps.

    I've tested and this works for me.
     
  7. hallhotdogma thread starter macrumors newbie

    Joined:
    Jun 28, 2013
  8. ilovegoodnugz macrumors regular

    Joined:
    Jun 29, 2010
    #8
    I second this, works absolutely perfect! Got confused where you tell us to download the windows drivers twice but who am I to complain if it works~

    Thanks
     
  9. jangyeejun macrumors newbie

    Joined:
    Aug 28, 2009
    #9
    Thank you so much, it really works, finally, I need to erase the history of installing windows on boot camp before. Apple Inc always leading the way of Technology.

    ^_^I am an Asian, sorry about my poor English.
     
  10. jcrenard macrumors newbie

    Joined:
    Nov 13, 2013
    #10
    A fix for problem on my macbook pro retina


    I have found a fix for this incredibly frustrating problem using Boot Camp Asst. I installed Windows 7 home on my macbook pro retina 15 late 2013 following these steps

    1. Get ISO file somewhere on your computer, doesn't matter where. Have blank USB drive ready, insert into USB port.

    2. Open Boot Camp Assistant, check all 3 boxes -- make boot disk, download software and partition disk. Go through screens until it ends at screen where you can only click quit (You will not make it automatically to the Windows 7 install blue screen just yet.) If you were to reboot your computer (holding down 'alt/option' key) you would get back to blue Windows install screen with no cursor.

    3. Reopen Boot Camp Assistant and this time CHECK THE THIRD BOX ONLY, the one to partition your drive. Be sure to leave the first two unchecked. Choose your partition size (I did 80gb for the bootcamp disk). You'll notice that when Boot Camp is done partitioning the disk it will automatically quit Boot Camp and reboot your computer, which it didn't do the first time.

    4. As computer is automatically rebooting, hold down alt/option key until you see screen where you can choose to boot up with mac HD or your windows USB. Select 'windows' drive by clicking on it or arrow just below.

    5. This time when you go through initializing black screen and then first blue Windows 7 screen, you should have a nice big fat white cursor that works.

    6. Note: If you get to the partition screen and it says you may not install to partition 4 which is named bootcamp, don't exit the installer, look in that window to the right and click on 'advanced'. Next window that pops up there's a 'format' button and it will be formatted correctly.
     
  11. reil macrumors newbie

    Joined:
    Jun 27, 2010
    Location:
    Seattle, WA
    #11
    i just got a rmbp and for me it was this. once i switched to a USB 2.0 drive it worked fine.
     
  12. SFODA macrumors newbie

    Joined:
    Jan 25, 2014
    #12
    jcrenard
    worked like a charm on my 15 MBP with retina. In fact it is the only thing that worked.
    07
     
  13. DreamSTi macrumors member

    Joined:
    Mar 24, 2011
    Location:
    Twin Cities
    #13
    Been fighting this issue all weekend, until I found this post. Thank you, sir! :D
     
  14. saggsy macrumors newbie

    saggsy

    Joined:
    Jun 28, 2004
    Location:
    Australia
    #14
    THIS....

    AND THIS....

    THESE posts are invaluable - both worked for me - coolio93's method is perfect although i used an iso file I created from a Windows 7 Professional install disc. I also came across the problem described in jcrenard's post where you get to the partition screen and is says it cannot install to partition 4 - simply click the 'Advanced Options' button and it'll allow you to format the partition correctly - took about 2 seconds, and then you can install to it from there.

    Thanks heaps guys.

    saggsy
     
  15. jenzjen macrumors 68000

    Joined:
    Aug 20, 2010
    #15
    The MUCH easier solution is to use a usb2 only drive
     
  16. coolio93 macrumors 6502

    Joined:
    Apr 15, 2013
    Location:
    Houston, TX
    #16
    BootCamp - Windows 7 cant complete install - no keyboard/mouse


    A USB 2.0 drive won't fix the problem of the usb3.0 keyboard and trackpad not working. Also, the USB hub is 3.0 and needs drivers to work.
     
  17. jenzjen macrumors 68000

    Joined:
    Aug 20, 2010
    #17
    Yes it will, this same argument was made on the apple forums and was proved incorrect by someone actually trying it out.
     
  18. laserfan macrumors member

    Joined:
    Jul 13, 2012
    #18
    My friend ran into this problem. First, BCA refuses to acknowledge that the Support Software is on his USB stick.

    Secondly, ignoring this problem and going-ahead with the WININSTALL boot, and getting to the Personalization screen, his kb/mouse don't work.

    I will loan him a USB 2.0 stick and am convinced it will work. Funny, the apple kb article only mentions Windows 8...

    http://support.apple.com/kb/TS4589
     
  19. RubberShoes macrumors regular

    Joined:
    Jun 30, 2007
    #19
    Thank you so much. This worked for my 13" Haswell rMBP like a charm and after hours of frustration. Thank you thank you thank you!
     
  20. RockOn23 macrumors newbie

    Joined:
    May 18, 2013
    #20
    I had the same problem; mouse and keyboard not working when starting Windows 7 installation from USB Stick

    - Terminal prompt: diskutil list
    - search for the identifier of the Windows 7 install USB stick, e.g. disk1s1
    - Terminal prompt: sudo /usr/sbin/bless --device /dev/disk1s1 --setBoot --nextonly --legacy
    - restart
    - machine boots into Windows 7 installation with needed drivers
     
  21. M-Six macrumors newbie

    Joined:
    May 1, 2014
    #21
    This worked for me. Originally I had the thumb drive on the right and the Superdrive on the left and got the USB3 issue. I started over and swapped the positions of the drives and it worked like a normal Bootcamp install.

    Thanks for posting that.
     
  22. DmbShn41 macrumors 6502

    Joined:
    Jun 22, 2009
    #22

    I attest to this. After multiple tries of trying to install Win7 on 2013 MBA, this worked perfectly. After digging deeper, Boot Camp specific software preps the Win7 install with support for USB3 from the get go. Also, have to have the USB in the left side port from the beginning.
     
  23. snoo2002 macrumors newbie

    Joined:
    Jul 24, 2014
    #23
    i had the same problem


    i removed the installation CD after the first restart of the installation and all went right


    cheers
     
  24. STEVES49 macrumors newbie

    Joined:
    Nov 20, 2015
    Location:
    Surrey England
    #24
    I don’t know if anyone will still be looking at this post now.

    I’ve tried several times in the last few days to set up a Windows 7 partition on an iMAC (osx 10.8.5).

    I think I’ve tried just about all the suggested fixes listed previously: USB2.0, USB drive in left hand port (although not sure if this was relevant to the iMAC) and the Terminal commands provided by RockOn23. None of these made any difference.

    I also followed Coolio93’ss instructions, although it is not totally clear to me what step 3 should be. His words ‘this time select to install support media to the USB drive confused me, as there is only the option to download. I did the download again, but came up with another error 0xc0000428 about Windows cannot verify the digital signal for AppleSSD.sys. This appeared to be because doing the download again overwrote the specific Bootcamp files (version 5.1.5640) for my iMAC.

    Can anyone shed light on how the third step should be run?

    Also would using a USB2.0 wired keyboard work, or is it the ports themselves that aren’t enabled at all?

    Any help/suggestions greatly appreciated.
     
  25. Showbiz macrumors newbie

    Showbiz

    Joined:
    Dec 3, 2015
    #25
    Ok, a late reply, maybe you have figured it out already but regarding the "Cannot verify the digital signal for AppleSSD.sys, you need to navigate and find the AppleSSD.sys file and DELETE IT. You can do this the easiest way by just searching for it in "All my files", then press "This Mac", on the MAC OS, it might take a while but eventually it will probably pop up.

    Regarding the keyboard and mouse not working am I exactly in the same situation as you. I also have an iMac and a solution to this would be fantastic :)
     

Share This Page