Bootcamp won't boot Windows 7 cd

Discussion in 'MacBook Pro' started by magimat, Mar 16, 2011.

  1. magimat macrumors newbie

    Joined:
    Nov 4, 2010
    #1
    Hi,

    I just replaced my superdrive with a 750Gb hd using OWC data doubler and now I'd like to install windows 7 with bootcamp on a partition of this new hd.

    Since I had to remove my superdrive in order to install second hd, I need to install Windows 7 using an external usb drive. By the way, my external usb drive works just fine for everything else in OSX, but I can't get Windows 7 cd to boot from it.

    I runned the bootcamp utility and created a 150Gb partition on my new hd for bootcamp, then restarted the computer and all I get is a black screen and no windows installation starting.

    From what I read in other threads, I'm not the only one in this situation and it might be due to my external drive, but I'm a little stuck here. I tried holding the OPTION key while booting, which gives me a booting menu with either my SSD osx partition, or my windows 7 cd (it recognized it somehow). I can boot with OSX no problem, but if I select windows 7, it doesnt work.

    I read something about a tool called REFIT, but I'm not sure I want to go this way. (http://refit.sourceforge.net/)

    Anyone else experiences the same problem with a 2011 mbp? Any idea or something?

    Thanks
     
  2. deadwulfe macrumors 6502a

    deadwulfe

    Joined:
    Feb 18, 2010
    #2
  3. GelatinousSlime macrumors newbie

    Joined:
    Mar 19, 2011
    #3
    I can't get the Windows 7 installer to boot either on my new 2011 17 inch BTO. I have not replaced my superdrive (yet), but I have swapped out the original HDD for an SSD. When I use bootcamp assistant, it restarts and just stays on a grey screen for a while and eventually a blinking folder icon shows up and nothing else happens. If I boot holding down the option key, the Windows disc shows up as an option, but when I select it the exact same thing happens, eventually stalls on the grey screen with blinking folder icon. I've tried 3 different Windows discs (Win 7 Ultimate SP1 s64, Win7 Ultimate x32, and Win7 Home Premium x32), all sourced from MSDN and even burned with three different burners in three different machines. :)

    I decided to try the USB route, and have a working bootable Win7 installer on a thumb drive that I used successfully to install on my old desktop PC. I installed rEFIt and the thumb drive shows up as an option, but it fails to boot. I've also tried a WinPE stick and a GParted stick that all work on other machines, but all 3 fail in exactly the same way.

    As a last ditch effort, I'm going to head back in to work today so I can get the official factory pressed Windows 7 DVD mailed from MSDN and try to boot from that just in case my superdrive doesn't like my DVD+R discs. They do show up fine when I insert them while booted up in OS X though.

    This is my first Mac ever, and so far I'm having numerous problems. Definitely doesn't "just work" :) But figuring all this stuff out is half the fun.
     
  4. iMacDragon macrumors 65816

    iMacDragon

    Joined:
    Oct 18, 2008
    Location:
    UK
    #4
    They do seem to be notoriously picky on USB booting for some reason, Can't boot a dos usb stick for memtest either ( though memtest just fails anyway due to compatibility issues with memory map.. )
     
  5. GelatinousSlime macrumors newbie

    Joined:
    Mar 19, 2011
    #5
    Figured mine out thanks to the very next thread I read after posting in this one. My problem was the SSD I had swapped in. It is the Intel X25-M G2, and flashing the latest firmware from Jan 18th 2011 seems to have done the trick. At least the Win7 installer disc started right up finally when booting by holding down the option key and selecting it.

    Unfortunately, it didn't fix my USB booting. The error is different now, but all 3 of my test boot thumbdrives still fail when trying to boot them through rEFIt. Oh well, I was really hoping to be able to install from USB.
     

Share This Page