bootcamp'ed vista, OSX doesn't see drive

freeballer

macrumors newbie
Original poster
Jan 22, 2007
12
0
I just installed leopard and decided to try and use bootcamp to install vista...
Long story short; I partitioned the drive with the 2nd being for Windows, the 4th one being a vfat32 partition to share data, movies, etc...

Vista works fine and rebooted back into OSX, installed macfuse/ntfs-3g, rebooted again but I can't see the partition in disk utils.
I suspect it's something to do with installation or the way the bootcamp partitioned the drive because it won't show up in ubuntu live cd either.
But instead of fudging it up more, or formatting 10x I'd like to ask for some help from someone who may have seen this before.
Can someone put me in the right direction to have this fixed, preferably without loosing data

here's some file outputs just in case it will help:


Last login: Tue Nov 6 14:47:16 on ttys000
MacBook:~ Administator$ diskutil list
/dev/disk0
#: TYPE NAME SIZE IDENTIFIER
0: GUID_partition_scheme *74.5 Gi disk0
1: EFI 200.0 Mi disk0s1
2: Apple_HFS OSX 24.7 Gi disk0s2
3: Microsoft Basic Data SAVED 24.8 Gi disk0s3
/dev/disk1
#: TYPE NAME SIZE IDENTIFIER
0: Snak 5 *10.0 Mi disk1
MacBook:~ Administator$ sudo gpt -r show disk0
Password:
gpt show: disk0: Suspicious MBR at sector 0
start size index contents
0 1 MBR
1 1 Pri GPT header
2 32 Pri GPT table
34 6
40 409600 1 GPT part - C12A7328-F81F-11D2-BA4B-00A0C93EC93B
409640 51838352 2 GPT part - 48465300-0000-11AA-AA11-00306543ECAC
52247992 584
52248576 51951616 3 MBR part 7
104200192 800
104200992 52100456 3 GPT part - EBD0A0A2-B9E5-4433-87C0-68B6B72699C7
156301448 7
156301455 32 Sec GPT table
156301487 1 Sec GPT header
MacBook:~ Administator$ sudo fdisk /dev/rdisk0
Disk: /dev/rdisk0 geometry: 9729/255/63 [156301488 sectors]
Signature: 0xAA55
Starting Ending
#: id cyl hd sec - cyl hd sec [ start - size]
------------------------------------------------------------------------
1: EE 1023 254 63 - 1023 254 63 [ 1 - 409639] <Unknown ID>
2: AF 1023 254 63 - 1023 254 63 [ 409640 - 51838352] HFS+
*3: 07 1023 254 63 - 1023 254 63 [ 52248576 - 51951616] HPFS/QNX/AUX
4: 0B 1023 254 63 - 1023 254 63 [ 104200992 - 52100456] Win95 FAT-32
MacBook:~ Administator$
 

reflex

macrumors 6502a
May 19, 2002
721
0
For what it's worth, I've got more or less the same setup (OSX + Vista + FAT32 partition) and the same issue. Though I live with it, it's not essential to me.
 

freeballer

macrumors newbie
Original poster
Jan 22, 2007
12
0
no, its not essential but it bugs me that it doesn't work, and I can't see any good reason for it (error, etc..) Hopefully someone will post an answer here, I can't see it that nobody found the answer to this one
 

Similar threads

Register on MacRumors! This sidebar will go away, and you'll see fewer ads.