Booting from external Firewire dvd drive

Discussion in 'PowerPC Macs' started by Magmadragoon, Apr 9, 2013.

  1. Magmadragoon macrumors newbie

    Mar 14, 2013
    I just bought a external dvd drive to try to put Mac OS x on my powerbook g4 17 inch. I cannot get the software to boot. I tried command-option-shift-delete and nothing will boot. I do not have any other macs to use target mode or know anyone who does have a mac. Is there any way to boot it in open firmware?
  2. eyoungren macrumors Core


    Aug 31, 2011
    ten-zero-eleven-zero-zero by zero-two
    You can hold down the "C" key when booting to boot from a CD/DVD drive. Don't know if that includes an external though.

    Also, since Macs are not PCs, command-option-shift-delete is not the equivalent to CTRL+ALT+SHIFT+DELETE. Unless you meant you tried booting with the CMD key, then tried it with the OPTN key, then the SHIFT key and lastly with the DELETE key? Is that what you meant?

    If you meant the way I first interpreted this, i.e., you held down CMD+OPTN+SHIFT+DELETE when the Mac was booting, then that won't work. The command to select a boot disk when restarting the Mac is just the OPTN key all by itself.
  3. Magmadragoon thread starter macrumors newbie

    Mar 14, 2013
    When I try to get in the boot selector screen by holding option it freezes.
  4. MisterKeeks macrumors 68000


    Nov 15, 2012
    How long? You have to let it wait for a while first.
  5. Magmadragoon thread starter macrumors newbie

    Mar 14, 2013
    I leave the laptop on the screen for hours nothing happens
  6. RedCroissant, Apr 9, 2013
    Last edited: Apr 9, 2013

    RedCroissant Suspended

    Aug 13, 2011
    There is no way that it is going to work even though it is firewire; I tried it already with an attempted and failed OS X Leopard reinstallation on my iBook G4 with both a firewire dvd drive and a usb drive. On my iMac(before I sold it) it recognized the external no problem and I was able to reinstall Snow Leopard before selling it.

    What is the model of firewire drive that you're using? is it bus-powered or AC powered?

    If you were in the Phoenix area, I would be more than willing to help you. If you know someone with a PC running XP or Vista, you should be able to share their ODD and install it that way via remote installation.

    OR, if you happen to own an old iPod with the firewire cable instead of the USB cable, you could most likely burn the .iso to the iPod and boot from that to reinstall the OS.
  7. Magmadragoon thread starter macrumors newbie

    Mar 14, 2013
    I live in PA. The Dvd Drive is a AC powered drive. I do have a bunch of Windows PCs how would I remote install Mac OS X from those systems?
  8. PowerPCMacMan macrumors 6502a


    Jul 17, 2012
    PowerPC land
    This is the first time I have heard about such a thing.. Before I was able to boot off USB on my PowerPC's, both G5 Quad and PB G4 DLSD 17 inch I was able to clone over using CCC Leopard and it would boot off externals all day long.. Perhaps you might have a drive thats not working right?

    Since PowerPC is known to boot off firewire you shouldn't be having this issue.. Do you have a Leopard install disc? If not.. I can help you further as I have done these things before..

    Send me a private message with a more vivid description of your issue and I can do my best to help you with what you want to do.



    Its funny you say this since last month I used my USB Flash drive to boot up Leopard and I was able to re-install it with no problems.. I alsp tested it on my Mercury on the GO external FW/USB drive and it too had no problems booting and installing OS X.. Perhaps this drive the OP has is not an oxford chipset based external device?

    Not all drives are created equally.

  9. RedCroissant Suspended

    Aug 13, 2011
    I know you can use a flash drive to transfer a clone made using CCC or some other app, but PPC Macs cannot boot from usb(unless you found a way to do it). If you did then I am very curious to know how since I would the ability to use usb whenever my iBook needs to be fixed as opposed to relying on firewire.

    I think the reason it's not booting off the FW is because it's not being recognized as a HDD, and that's what is preventing it.
  10. seveej macrumors 6502a


    Dec 14, 2009
    Helsinki, Finland
  11. Magmadragoon thread starter macrumors newbie

    Mar 14, 2013
    After holding the option key it moves to this screen and gets stuck

Share This Page