Booting from OSX disk - no drives available to install to

Discussion in 'MacBook' started by FranklinBluth22, Sep 16, 2010.

  1. FranklinBluth22 macrumors newbie

    Joined:
    Jan 14, 2010
    #1
    I recently partitioned my Macbook so I could install a version of Linux. Although I got it to run and even switched back to using OSX afterward, the next time I restarted the machine wouldn't boot. I get a blinking folder icon with a question mark. I tried everything on the Apple support page regarding this problem but nothing worked. After repairing the drive it said that everything was ok and it won't allow me to even choose the drive to install OSX to. The HDD, Bootcamp and unnamed partition are all marked with exclamation points and say they are not available to install OSX on.

    I feel like I've exhausted my Google search capabilities on this so before I take it to Apple, does anyone have any advice? I'm also going to try GParted to see if I can remove that unnamed partition. I don't think it's a hardware problem.

    Thanks!
     
  2. spinnerlys Guest

    spinnerlys

    Joined:
    Sep 7, 2008
    Location:
    forlod bygningen
    #2
    What does show up in Disk Utility started from the Restore/Installation Disk under "Partition Scheme" at the bottom of the Disk Utility window?
     
  3. FranklinBluth22 thread starter macrumors newbie

    Joined:
    Jan 14, 2010
    #3
    I actually finally figured it out. I had to erase my entire hard drive and re-partition it as GUID partition table which enabled the OSX installation to the drive. I lost everything but thank goodness I decided to do a time machine backup to my external for the first time ever a few weeks ago...didn't lose anything important.

    Anyway, looks like I'm back in business. Though I'm not gonna be messing around with advanced partition settings until I'm a bit more savvy.
     

Share This Page