Booting Linux From CD in PowerPC 266MHz

Discussion in 'Mac Basics and Help' started by MrMarcos, Oct 27, 2009.

  1. MrMarcos macrumors newbie

    Joined:
    Oct 27, 2009
    #1
    Hi, I have an old PowerPC 266MHz beige tower. I just replaced the original SCSI hard drive with a Maxtor 40GB IDE drive. The maxtor drive came from an old Windows PC.
    Here's what I want to do - Boot from Linux CD (edubuntu 6.XX for Mac) and install it to the Maxtor HDD. I'm assuming that in the process of installing Linux, it will reformat the Maxtor.
    So I don't intend to run Mac OS on this, but rather Edubuntu. The Edubuntu CD was downloaded on a PC, and the ISO file was burned in the same fashion as other variants of Ubuntu that have worked successfully on other PC's.

    Now here's what's happening with my PowerPC. I can't get it to boot from the CD drive. I tried holding down "C", and later I tried "D" when powering up the tower. I never get the CD to boot, but instead I get a grey screen with the mouse in the upper left corner, and a Floppy Disc icon in the center of the screen with a question mark on it. Nothing else happens. I'm stuck at this point.

    Please go easy on me if I've overlooked some basic Mac conventions. I'm brand new to Mac. I'm guessing that the grey screen and Mac-looking icons are coming from something in system ROM since there is no Mac-formatted drive in the tower.

    Can anyone offer help? Thanks!
     
  2. cubist macrumors 68020

    Joined:
    Jul 4, 2002
    Location:
    Muncie, Indiana
    #2
  3. J the Ninja macrumors 68000

    Joined:
    Jul 14, 2008
    #3
    http://en.wikipedia.org/wiki/Old_World_ROM

    Your machine is an "Old World Mac". With the the New World ones, it's not too different from an Intel Mac or a PC, you just need to remember to use a PowerPC distro.

    With the Old Worlds....I really can't help you further. Get to googling "Linux on an old world Mac". Good luck, it's not easy as I understand it.
     
  4. MrMarcos thread starter macrumors newbie

    Joined:
    Oct 27, 2009
    #4
    yep, that link

    Cubist and J, thanks for responding. The Edubuntu link you inserted points to the same version I downloaded.
    Also, I did not install an IDE adapter. The PowerPC 266MHz I have has two IDE ports directly on the board. The SCSI cables were actually going to a PCI SCSI port card. I'm assuming that in BIOS (do old world macs even use a BIOS?) if it doesn't detect SCSI cards or devices (I removed both), then it will search for devices on the IDE cables.
    Is there some kind of floppy based utility that I can download via a windows PC that will run diagnostics on the PowerPC?
    Again I appreciate your assistance and patience, since I'm new to Mac.
    Marcos
     
  5. MrMarcos thread starter macrumors newbie

    Joined:
    Oct 27, 2009
    #5
    possible solution

    J, thanks for recommending the Wiki entry on OWM's. Since this thing has PCI slots, I'm going to guess that I should use the Quik boot loader to get my Linux installed.
    Now to see if I can download that on a windows PC to a floppy that can be read by Mac at boot-up.
    Marcos
     

Share This Page