Booting Macbook from External HD- how to recover files?

Discussion in 'MacBook' started by Skerryman, Feb 17, 2017.

  1. Skerryman macrumors newbie

    Joined:
    Nov 1, 2011
    #1
    Hi folks, hope I'm posting in the right section. Basically, a few months ago my girlfriends MacBook hard drive failed and I couldn't it boot up. When starting the MacBook I was presented with the recovery screen but I wanted to try retrieve some files for her first first (she had no time machine backup).

    I've now managed to install OSX on an external hard drive and can boot my girlfriends Macbook from that. After booting from External HD, when I go into Disk Utility, the Macintosh HD along with the External HD are visible but I can't figure out how to check the content of the Macintosh HD or try to recover files and have no idea what I need to do next.

    Any ideas on how I can view contents of Macintosh HD and copy necessary files is greatly appreciated.
     
  2. keysofanxiety macrumors 604

    keysofanxiety

    Joined:
    Nov 23, 2011
    #2
    Click Finder> Preferences and tick the option for Hard Disks/External disks (to show these items on the desktop). Their Macintosh HD should then be accessible from the desktop.

    If that doesn't work, right-click the Macintosh HD volume in Disk Utility (bottom of the two Macintosh HDs listed) and select 'Mount'. Then enter the user password to unlock it. If they had FileVault enabled then you can't read from Macintosh HD unless you do this.
     
  3. Skerryman thread starter macrumors newbie

    Joined:
    Nov 1, 2011
    #3
    Thanks for that. Tried the preferences route and it only displays the external HD I'm booting from on the desktop.

    Tried mounting from Disk Utility and it says the disk can not be mounted and to try repair the disk. When I try repair the disk it fails and says Disk Utility cannot repair the disk.

    Any other alternatives to try salvage some files or am I out of luck, not too up to date on recovery software or what good.
     
  4. keysofanxiety macrumors 604

    keysofanxiety

    Joined:
    Nov 23, 2011
    #4
    Your best bet would be DiskWarrior, that's incredible for scanning/fixing unrepairable disks. It's not cheap to buy, but there's always an alternative source.
     
  5. Skerryman, Feb 17, 2017
    Last edited: Feb 17, 2017

    Skerryman thread starter macrumors newbie

    Joined:
    Nov 1, 2011
    #5
    Thanks, I picked up DiskWarrior there and booted from the external drive and tried repairing the disk. Scanning highlights a log of issues and I selected replace but when rebuilding the drive it says it encountered an unexpected error 2175, 4901: 7788 when trying to repair overlapped files.

    Seems to have done enough to mount the disk on the desktop which I couldn't do previously and I ran disk utility them and it repaired the disk where it was previously not allowing it to be repaired.

    After all that though there doesn't appear to be much files left on the disk so I'm not sure if I have much hope of recovering any pictures off it. There is a bunch of folders of 'Missing Folders' in a 'Rescued Items' folder but none of them look to contain any picture files or the like.
    --- Post Merged, Feb 17, 2017 ---
    OK so Ive done a bit more digging in the Rescued Items folders by doing a quick search for jpg in spotlight and turns out all her pictures are saved in them somewhere. Just need to figure out which of the 200+ folders contain pictures now and try copy them all onto a hard drive before I wipe her Macbook and reinstall OSX.

    You sir are a legend, thanks for all the help.
     
  6. Skerryman thread starter macrumors newbie

    Joined:
    Nov 1, 2011
    #6
    Back again on this one folks.

    After recovering the files from Disk Recovery I have now reinstalled OSX from the recovery screen and now I have the Macbook restored with Mavericks.

    I figured the first thing I should do is update to OSX Sierra but after I downloaded it and tried to install I get to a screen saying something about 'OSX needs your permission to install a helper tool' and it asks for administrator name and password. The problem is it never accepts the password when I enter it even though it's the very same one I just successfully logged in with.

    Does anyone know how I can solve this. I've tried change password through terminal but it doesn't accept the new password either.

    Also there are a few apps such as Photo that have a weird icon in the dock and give an error code when I try to open them, see picture attached for icons.

    Am I better off to go to disk utility and reformat the HD before reinstalling OSX from the recovery partition altogether?
     

    Attached Files:

  7. DeltaMac macrumors 604

    DeltaMac

    Joined:
    Jul 30, 2003
    Location:
    Delaware
    #7
    I know that the Photos app is too new for Mavericks. When you restored the system to Mavericks, some of the newer apps, such as Photos, are in the Applications folder (and an icon in the dock), but won't run until you update to a system that supports those apps.
    MUCH better idea is to quit the Sierra installer, without trying the install at that time.
    Download DiskMakerX, and use that to create a bootable USB flash drive, which you can then use to boot your G/F/s to the installer, and upgrade that way. That method will also leave you with a way to reinstall Sierra without downloading again, in the event you need to reinstall Sierra, because the last thing that the installer does is to delete the installer from your drive. If you make the USB installer, then the installer remains untouched when finished.
     
  8. Skerryman thread starter macrumors newbie

    Joined:
    Nov 1, 2011
    #8
    Thanks for the help. I managed to create the Sierra disk and install it that way. Applications now are showing fine.

    I am having a problem now however, that, it won't accept my login when I perform any change that requires administrator permission. I'm entering the exact same password I logged in with and I've even changed the password just incase but it refuses to accept the password.

    I'm wondering is there an issue with the permissions after the HD crashed initially and if a format of the disk and clean install would solve the problem.

    I googled the issue and other seem to have similar issue with a Sierra update but I didn't see ay real resolutions offered apart from changing password which I'v done.
     
  9. DeltaMac macrumors 604

    DeltaMac

    Joined:
    Jul 30, 2003
    Location:
    Delaware
    #9
    If you are at the desktop, your normal screen, try this:
    Log out from the Apple menu.
    You will then get your login screen. Log back in. You will need the correct password for that user to do that successfully.
    Is your logged-in account an admin account? Double-check in the Users & Groups pref pane.

    Finally, check that your keyboard is working properly. You can test each individual key from the Keyboard Viewer. You can show THAT on the screen by selecting "Show Input Menu in menu bar" from the Keyboard pref pane/Input Sources.
    With the Keyboard Viewer on screen, you can press and release each key. Test each character in your password.

    A reinstall of Sierra will reset any permissions issue that you might have in the boot system. (I don't think your issue is related to permissions, however.)
     
  10. Skerryman thread starter macrumors newbie

    Joined:
    Nov 1, 2011
    #10
    I think you might be onto something :) I clicked the User I logged in as, which is my GFs account and its saying she is a standard user. Thing is, I have no idea who the administrator account is as this is the only account showing up.

    To change her account to admin I need the admin password to unlock the padlock, arrrrrghhh

    Surely if an admin account was setup it would up on the list along with her standard account? Or am I missing something here. Don't remember ever setting up anyone but her as an admin on the macbook
     
  11. Skerryman thread starter macrumors newbie

    Joined:
    Nov 1, 2011
    #11
    OK, so I did a bit of snooping around and managed to find a page that told me how to add an admin account without having the password for the original account. I copied instructions below incase anyone else stumbles across this thread with the same issue.

    I created a new admin and made my GF original account admin. I still can't figure out what account is the original admin as there isn't an admin account showing up, only GFs original standard account. (I said admin alot there).

    Thanks for all your help though, think I finally have her laptop back up and running again so now I get my own Macbook back to myself again :)

    Instructions are here:
    1. boot computer and hold the "apple" key and the "s" key.

    2. wait for terminal show

    3. release keys

    4. type without the quotes: "/sbin/mount -uaw"

    5. press enter

    6. type without the quotes: "rm /var/db/.applesetupdone

    7. press enter

    8. type without the quotes: "reboot"

    9. press enter


    This will let you create a new admin account when you reboot your computer.
     
  12. DeltaMac macrumors 604

    DeltaMac

    Joined:
    Jul 30, 2003
    Location:
    Delaware
    #12
    I have seen some OS X updates that will, through some random glitch, change the booting account to a standard account. If that happens to be the ONLY account on the Mac, you won't even notice the change, unless you try to log out/log in - or try to install anything that asks for the admin password. And, at that time, there is no admin at all.

    I suspect that the hard drive crash from a few months ago probably created the issue that removed the admin permission from that account. Reinstalling, restoring, doesn't get that back. You have to do the change from an admin account, OR the root/superuser account, which is ALSO not enabled by default. All in all, it's a bit fiddly to change the standard account to an admin account, when no other accounts exist at that time.

    So, you have to create another account (your process was one method that allows you to do that), then log in to that new admin account to change the normally-used account to an admin.

    Log out of the new user, log back in to the normal account.

    Your last step would be to delete the new admin account - although there is nothing wrong with keeping that same new account. It just sits there until you have some need to log in to a different account. It's a good troubleshooting tool to keep available on your Mac.
     

Share This Page