Booting off USB 3.0 thumb drive not supported?

Discussion in 'MacBook Pro' started by iBug2, Aug 4, 2012.

  1. iBug2 macrumors 68040

    Joined:
    Jun 12, 2005
    #1
    I bought a Lexar Triton USB 3.0 thumb drive for my rMBP and tried to boot from it with no luck. The computer basically freezes on the boot and nothing happens. If I boot with option pressed and then plug the thumb drive, same thing happens. The EFI boot screen freezes.
     
  2. axu539 macrumors 6502a

    Joined:
    Dec 31, 2010
    #2
    I have booted a 2011 MBP off of a USB 3.0 drive (using USB 2) before just fine. It could potentially be the rMBP misbehaving, though.
     
  3. iBug2 thread starter macrumors 68040

    Joined:
    Jun 12, 2005
    #3
    Well, I can boot the rMBP using a USB 2.0 drive as well, but I haven't tried if I can boot another USB 2.0 mac using a USB 3.0 drive though, I'll test it.
     
  4. AzN1337c0d3r macrumors 6502

    Joined:
    Sep 13, 2010
    #4
    It appears the rMBP doesn't like certain USB thumb drives for booting. I can reproduce this issue all day long on a Corsair GT USB 3.0 16 GB.

    However, it does seem to work with my Corsair USB3.0 32 GB, so I know it's not the method that I'm using to make the thumb drive.
     
  5. g4cube macrumors 6502a

    Joined:
    Apr 22, 2003
    #5
    Make sure to change the MBR partition scheme and FAT32 format to GPT or Apple partition scheme.

    You can do this with Disk Utility.
     
  6. ColoArtist macrumors regular

    Joined:
    Jul 3, 2012
    Location:
    Denver, CO
    #6
    I built a bootable Mt. Lion drive on an old Transcend 2.0 Flash drive I had around. It worked just fine.

    Thinking a 3.0 drive would be better, I bought a new Transcend 8GB JetFlash700 Super Speed USB 3.0. It works just fine too. :)

    The extra speed of the 3.0 didn't really seem to make much difference. A 2.0 Flash drive is probably more than sufficient even for an installation.

    :apple:
     
  7. mjn298 macrumors regular

    Joined:
    Oct 25, 2011
    Location:
    Palisades, Washington, DC
    #7
    I have gotten the no smoking sign a few times trying to do a clean install, sometimes I randomly don't. Not sure why.
     

Share This Page