Booting os x from *partitioned* external firewire drive?

Discussion in 'MacBook Pro' started by ninjafessor, Oct 25, 2007.

  1. ninjafessor macrumors newbie

    Joined:
    Oct 25, 2007
    #1
    Hi all,
    my internal hard disk (on a 12" powerbook G4 867 mhz running osx tiger 10.4.10) has started acting weird, so I'm preparing for replacing it with a new hard drive.

    I've backed the drive up to an external firewire drive (LaCie portable 80 GB drive "Design by F.A. Porsche") using Carbon Copy Cloner with the option 'make bootable' selected.

    PROBLEM: I can't boot OS X using my clone on the external drive.

    I'VE TRIED:
    - holding down Command-Option-Shift-Delete while booting to bypass the internal drive. (This didn't work: I saw an os 9 icon blinking/alternating with a question mark for a while, and then the computer booted from the internal hard disk.)
    - holding down Option to select the external drive in Startup Manager. (Didn't work either: Startup Manager opened fine, but only showed my internal drive volume. I tried clicking the 'rescan' button, but it couldn't find my external drive.)
    - SELECTING THE EXTERNAL DRIVE under Startup Disk in System Preferences. Note that the external drive volume *did show up* there. So under some conditions at least, the external volume is identified as a bootable volume. (This didn't work either, though: When I shut down the computer and booted up with the external drive connected, it still booted up from the internal drive.)

    POSSIBLE EXPLANATION?
    My external drive is partitioned into three partitions of different formats:
    1. "Mac OS X Extended (Journaled)"
    2. "Mac OS X Extended (Journaled)"
    3. "MS-DOS File System (FAT32)"

    The bootable volume is the first partition with the os x format.

    Could my problem be caused by this partition of my external drive?

    Either way, what to do?? I hope some of you savvy people out there can help me out.

    Cheers,
    Philip
     
  2. yellow Moderator emeritus

    yellow

    Joined:
    Oct 21, 2003
    Location:
    Portland, OR
    #2
    1) Hold down Option to select bootable devices.

    2) Try SuperDuper! instead. Never had it fail to make a bootable copy for me.
     
  3. fistful macrumors 6502a

    fistful

    Joined:
    Mar 29, 2004
    Location:
    Socan
    #3
    PPC Macs cannot boot off of external usb drives as far as I know. Firewire only. Once you replace your internal HDD you can restore it with the bootable clone.

    edit: I assumed the external was usb but I looked up the drive and it seems to have firewire. If you were using usb try the firewire.
     
  4. dacreativeguy macrumors 68000

    Joined:
    Jan 27, 2007
    #4
    He is using a Firewire drive. Try SuperDuper. Works every time.
     
  5. fistful macrumors 6502a

    fistful

    Joined:
    Mar 29, 2004
    Location:
    Socan
    #5
    Yeah, forget my previous post. I seemed to have looked over the mention of firewire. It's early for me, not quite functional yet.
     
  6. Queso macrumors G4

    Joined:
    Mar 4, 2006
    #6
    Exact same machine here. Use SuperDuper!. That has worked countless times for me.
     
  7. brepublican macrumors 6502a

    brepublican

    Joined:
    Jul 22, 2005
    Location:
    NY
    #7
    I had the same exact problem. And reading this thread was about as helpful as... well, let's just say it wasnt helpful and leave it at that.

    Anyway, as I said, same exact problem. The solution is to make sure that when you're partitioning you HDD, make sure to get into "Options". You'll find that the defualt scheme is "Master Boot Record". This is your problem. Partitioning with MBR makes the external unbootable, atleast to PPC macs. If you keep partitioning with MBR, you can use SuperDuper and what not til the cows come home and you wont be able to get a bootable backup still. So you should instead uncheck this and pick "Apple Partition Map". Once you're done, use SuperDuper! or whatever to backup, reboot and hold down... etc. Viola!

    Let me know if this sorted you out :)
     
  8. dacreativeguy macrumors 68000

    Joined:
    Jan 27, 2007
    #8
    It could be your external drive. Some drives don't have the correct chipset. Oxford is the one I hear most, but others work as well. I would think that Lacie would work since they market towards Macs but you never know.

    I use SuperDuper and never have any troubles.
     

Share This Page