Booting up often does not complete fully and hangs on network?

Discussion in 'Mac OS X Lion (10.7)' started by AndyOvine, Jul 24, 2011.

  1. AndyOvine macrumors newbie

    Joined:
    Jul 24, 2011
    #1
    Since upgrading to Lion, I have noticed that when I boot up sometimes the finder menu bar at the top of the screen does not have all the icons on the right side and I do not have any network access.

    I get the search icon and when I move the mouse over it, the mouse pointer changes to the spinning icon. I also get my Dropbox icon but that does not seem to have a problem.

    If I go to my System Preferences and go into Networks the window hangs and nothing responds within it.

    Any advice?

    I have a Macbook from late last year, installed Parallels, Drop Box, Chrome, OOVOO and Pixelmator. I have the latest patches applied for Dropbox and Parallels.

    I'm away from home at the moment connecting in on a wifi hotspot, but I couldn't get past this problem (normally a reboot will work) and I started the Mac holding the Shift key which has let me get into networking.

    Any help or advice is greatly appreciated. I'm a relatively new Mac user but not a PC novice.
     
  2. AndyOvine thread starter macrumors newbie

    Joined:
    Jul 24, 2011
    #2
    I've tried removing dropbox and I still get the odd behaviour with the finder menu bar. It shows only the magnifying glass and is missing the user name I'm logged in with, the time, volume icon, network icon and so on.

    Is there a way to determine where OSX Lion is stalling when it boots and leaves the system in this state?
     
  3. AndyOvine thread starter macrumors newbie

    Joined:
    Jul 24, 2011
    #3
    Really scratching my head on this problem...any help anyone?

    To get my Mac working today, when I shutdown I had to untick the open windows checkbox on the shutdown dialog although I have done that before without success.:(
     
  4. AndyOvine thread starter macrumors newbie

    Joined:
    Jul 24, 2011
    #4
    Spotlight

    Some progress I think, I have found a thread that describes the problem I am having here: https://discussions.apple.com/message/6954995?messageID=6954995#6954995?messageID=6954995

    It describes a spotlight issue with a corrupt font caches. Spotlight is the only icon on the finder menubar and moving the mouse over it shows the spinning mouse pointer and it does not respond.

    The suggestion in the thread is to use FontNuke but unfortunately this is not supported for Lion yet. Is there any other way to sort this issue out?
     
  5. AndyOvine thread starter macrumors newbie

    Joined:
    Jul 24, 2011
    #5
    Sadly didn't get any help from here, but I did eventually find a solution that seems to have done the trick. For benefit of others if they find they are hit by this annoying problem open the terminal window and type these commands in:

    atsutil databases -removeUser
    atsutil server -shutdown
    atsutil server -ping

    If you have more than one user account, run the first command with sudo atsutil ...
     
  6. bjgreenberg macrumors newbie

    Joined:
    Jul 30, 2011
    #6
    Having the exact same problem.

    I'm having the same exact problem.

    After upgrading to Lion, I boot up and most of my icons don't appear on the left side of the top menu bar and when I hover over spotlight, I get the spinning pinwheel and there's no network access. The preferences open up fine but when I click on network, it hangs.

    The only way I can get around it is to reboot while holding down the shift key.

    I tried your fix with the atsutil but it did not fix it for me.

    Any thoughts, anyone?

    Brian
     
  7. nickguy macrumors newbie

    Joined:
    Jul 5, 2012
    #7
    Same issue here...

    When I reboot into single user it seems to fix the problem in that I can reboot multiple times without the issue recurring. It seems like something I am running is corrupting the fonts if that is what is going on. I suspect Outlook because I hate it. Again it only occurs when the machine has been in use for a while running programs. Firefox/Safari/Msoft office.
     

Share This Page