Bootloader on replaced iPhone.

Discussion in 'iPhone' started by shvartsies, Jun 3, 2009.

  1. shvartsies macrumors regular

    Joined:
    Apr 2, 2008
    Location:
    New Jersey, USA
    #1
    Hi, I have a little choice to make.
    I want to sell my white iPhone 3G on eBay, unlocked. I used fuzzyband downgrader to downgrade my phone to 2.28.0, since my bootloader was 5.08.

    Now, I have a very bad light leak on the left side of the phone, and cracks all around in the plastic housing. I'd really like to replace the phone with a new one before I go to sell it.

    Here's what I'm scared of. I'm scared that the replacement phone will NOT have bootloader 5.08 and I won't be able to downgrade.

    Any suggestions?
     
  2. The General macrumors 601

    Joined:
    Jul 7, 2006
    #2
    Newer phones come with 2.2.1 and bootloader 5.09. Both of mine had 5.09. I wouldn't get a replacement. Unlockability is worth more than no light leaks.
     
  3. shvartsies thread starter macrumors regular

    Joined:
    Apr 2, 2008
    Location:
    New Jersey, USA
    #3
    If I get a new one, I'm still going to unlocking it, as long as it has the 5.09 bootloader. Thanks for your insight and quick response.
     
  4. The General macrumors 601

    Joined:
    Jul 7, 2006
    #4
    It will come with 5.09 or 6.02 and baseband 2.30. Fuzzyband does NOT work with bootloader 5.09 or 6.02, and yellowsnow does NOT work with 2.30. There is no way to unlock a new one.

    That is the situation I am in.
     
  5. shvartsies thread starter macrumors regular

    Joined:
    Apr 2, 2008
    Location:
    New Jersey, USA
    #5
    Correct me if I'm wrong, but the replacement phones apple hands out are refurbished. correct? So its just a matter of SHEER luck.

    I am using a replacement right now, which I received about two months ago. It has the 5.08 bootloader. I would say the chances of me getting two of these rare beauties is slim to none.

    What would you do if you were in my position? Take a chance and get a replacement or sell this one as it is and probably make considerably less money (light leak, case cracks, and few scuffs on casing.)
     
  6. The General macrumors 601

    Joined:
    Jul 7, 2006
    #6
    I am using a replacement that I got in October 2008. It has bootloader 5.09. I also have a replacement that I got a few days ago. It has bootloader 5.09.

    I really doubt you'll get one with 5.08. So if I were in your position, I'd just forget about the light leak and sell the thing unlocked.
     

Share This Page