Bootloader Problems: rEFInd

Discussion in 'OS X Yosemite (10.10)' started by vercetti7, Jun 2, 2014.

  1. vercetti7 macrumors newbie

    Joined:
    Jun 2, 2014
    #1
    Anyone able to successfully install a bootloader with Yosemite? I'm unable to install rEFInd and now am unable to access my other partitions.

    Any feedback would be much appreciated. Thanks.
     
  2. Weck macrumors newbie

    Joined:
    Jun 8, 2014
    #2
    I currently have Yosemite on an external hard drive and it's working fine with rEFInd
     
  3. Focuslined macrumors newbie

    Joined:
    Nov 2, 2013
    #3
    Hello,

    I also installed the POS OSX 10.10 on the SSD (default) on the macbook pro.


    rEFInd is NOT working.

    I AM GOING INSANE.

    HAD ENOUGH WITH THIS MAC.














    But by god, I can't wait to get rid of this piece of **** OSX...


    Linux soon ! thank ****ing god.
     
  4. Focuslined, Jul 1, 2014
    Last edited: Jul 1, 2014

    Focuslined macrumors newbie

    Joined:
    Nov 2, 2013
    #4
    Please HELP. rEFInd not working OS X 10.10

    EDit:
    Hello,

    Does anyone please know how to get rEFInd working on OSX 10.10 ? .

    The problem:
    - rEFInd does NOT show up on boot screen.


    What I have tried:
    - Uninstalled rEFInd,Installed it.


    General:
    So what I did was uninstall rEFInd (all traces of it), then shut down OSX.
    I opened this GREAT PIECE OF WORK OSX 10.10 straight up again, loged in and installed rEFInd.

    I then shutdown OSX 10.10 opened it STRAIGHT BACK UP, Ok then guess what? I installed the rEFInd by using the terminal, got the default message that it was installed.

    I then shutdown MAC OSX.

    I then turn on that button,

    RESULT ::: ==>> There is no rEFInd or anything, it just boots as normal. There's no trace of rEFInd or anything. Just booting as normal into MAC
    .


    Please help, how to fix this?... .



    What about a SSD, and install rEFInd to the SSD and launch that from pressing alt on startup then the botter show?


    tthankkk you!!
     
  5. UncleSchnitty macrumors 6502a

    UncleSchnitty

    Joined:
    Oct 26, 2007
    #5
    May I ask why you need it? I have installed Ubuntu, Windows and other versions of OSX on my system and other boot loaders were helpful years ago but since I have just held down option at boot or changed the startup disk. Im asking because Im curious not to discourage your use of it, I just may not understand the benefit.
     
  6. dmccloud macrumors 6502a

    dmccloud

    Joined:
    Sep 7, 2009
    Location:
    Anchorage, AK
    #6
    Have you contacted the developers of rEFInd? They would be your best point of contact, since it's their responsibility to update the app for Yosemite.
     
  7. dmccloud macrumors 6502a

    dmccloud

    Joined:
    Sep 7, 2009
    Location:
    Anchorage, AK
    #7
    Why are you blaming Apple for the rEFInd developer's problem? Apple isn't responsible for getting third-party apps to work with a new version of OS X. It's a developer preview, you should expect some things not to be working at this time. That doesn't make 10.10 a "POS", but it does indicate that your expectations may have been unrealistic.
     
  8. p3ntyne macrumors 6502

    p3ntyne

    Joined:
    Jan 10, 2014
    Location:
    Sydney, Australia
    #8
    Well, there is no reason to be surprised that certain software doesn't work on the developer preview. You will most likely just have to live with it until the devs figure it out.

    If I understand correctly, you are trying to install REFInd to a separate drive to the boot drive. I guess, theoretically, that it will work but i'm not sure. And anyway, doesn't the boot option menu do the same thing as rEFInd?
     
  9. Manic Harmonic macrumors 6502

    Joined:
    Dec 4, 2011
    #9
  10. madsci954 macrumors 68030

    Joined:
    Oct 14, 2011
    Location:
    Ohio
    #10
    Check his post history, and it will be clear :rolleyes:
     
  11. aldrinjtauro macrumors regular

    Joined:
    Jul 3, 2014
    Location:
    Birmingham, AL
    #11
    I installed Yosemite on my Air when it first came out. I made a new partition so I could dual-boot. I noticed that Yosemite's installer automatically makes a logical volume when installed on a blank partition. REFInd can't boot logical volumes, I don't think. To see your other partitions, you'll have to go to Preferences and use Startup Disk to boot back into Mavericks (or whatever). There's a way to use the CoreStorage Terminal utility to convert the Yosemite partition to a primary partition, but I can't give you details.
     
  12. anubis72 macrumors regular

    anubis72

    Joined:
    Jan 18, 2004
    #12
    Uh, Yosemite is in BETA, so why do you think it should operate like a GM version? OSX isn't the problem, it's people who don't understand that installing Beta versions of an OS on their primary drive is not a good idea unless you're prepared to deal with issues. You obviously didn't think it through.

    Speaking of things not working out of the box, good luck with Linux... ;)
     
  13. agbockus, Jul 29, 2014
    Last edited: Jul 29, 2014

    agbockus macrumors newbie

    Joined:
    Jul 29, 2014
    Location:
    Texas
    #13
    Just curious if anyone has been able to figure this out, or if anyone knows how to make a drive show up correctly in Startup Manager.

    I'm also on the Yosemite 10.10 Beta (D4 I believe?) on a mid-2011 MacBook Pro 13".
    I have 2 drives in my computer (replaced the CD drive with another 60GB SSD).

    I've been trying to install elementaryOS to the extra 60GB SSD for about 3 days now and I can't get it to boot - it installs and runs fine during the install, but it just doesn't show up in Startup Manager at all - only the Macintosh HD and the EFI Boot (My elementaryOS installation flash drive) show up. So I THINK it's working, but I can't boot it to find out at all.

    Any help or pointers would be appreciated! Thanks!

    EDIT: I got rEFInd installed finally - I had to install it with the "./install.sh --esp" option and also had to rename the folder from "refind" to "boot" and the file inside from "refind_x64.efi" to "bootx64.efi". From there I had to use
    HOWEVER - it does not show any bootloaders at all. I had to restart and hold option, there I can boot my Macintosh HD and it works fine, but rEFInd doesn't recognize either my Mac bootloader nor my elementaryOS bootloader. :/
     
  14. anubis72 macrumors regular

    anubis72

    Joined:
    Jan 18, 2004
    #14
    I gave up and started using SuperGrub2Disk. I'm booting to an external USB HDD and SG2D is on a separate USB thumb drive. You have to hold down option at boot and the USB drive comes up as " Windows" but at least I'm able to boot into something else. SG2D is basically like GRUB on Linux which searches for other OSes and allows you to boot the OS of your choice. It's a decent workaround for the time being...

    Find SG2D here:
    http://www.supergrubdisk.org/super-grub2-disk/
     
  15. agbockus macrumors newbie

    Joined:
    Jul 29, 2014
    Location:
    Texas
    #15
    I've used SuperGrubDisk before! How funny, I use it to fix Grub when I installed Windows with Ubuntu.

    So basically, using that creates a "boot key" of sorts. Interesting.

    I reinstalled elementaryOS because I deleted the bootloader (doh) and so then it now boots into grub2 and doesn't do anything - it just drops to a shell and doesn't boot anything. So overall, that boot key idea sounds a lot easier. Haha
     
  16. anubis72 macrumors regular

    anubis72

    Joined:
    Jan 18, 2004
    #16
    Dual booting elementaryOS and Mac OS X? How do you like it? I gave it a whirl some time ago and liked it, but I keep going back to Ubuntu.
     
  17. agbockus macrumors newbie

    Joined:
    Jul 29, 2014
    Location:
    Texas
    #17
    Sorry for the novel...

    I like it a lot! Though, I got tired of the old Luna version, since it's based on 12.04 - So I'm running a daily build of Freya that someone has been building via a dedicated build machine on Reddit.

    It runs REALLY well for a beta. Seems void of a lot of "features", but being linux, you can (have to) always add those in yourself. The animations are VERY smooth and overall it seems very snappy. I love it to be honest with you.

    SIDE NOTE: I got rEFInd to show the partitions I need to boot! The uncommented portions of my refind.conf are:

    Code:
    timeout 20
    scan_driver_dirs EFI/boot/drivers
    scan_delay 1
    dont_scan_files shim.efi,MokManager.efi
    
    menuentry Linux {
    	icon EFI/refind/icons/os_linux.png
    	volume KERNELS
    	loader bzImage-3.3.0-rc7
    	initrd initrd-3.3.0.img
    	options "ro root=UUID=5f96cafa-e0a7-4057-b18f-fa709db5b837"
    	disabled
    }
    
    menuentry Ubuntu {
    	loader /EFI/ubuntu/grubx64.efi
    	icon /EFI/refined/icons/os_linux.png
    	disabled
    }
    
    menuentry "ELILO" {
    	loader \EFI\elilo\elilo.efi
    	disabled
    }
    
    menuentry "Windows 7" {
    	loader \EFI\Microsoft\Boot\bootmgfw.efi
    	disabled
    }
    
    menuentry "Windows via shell script" {
    	icon \EFI\refind\icons\os_win.png
    	loader \EFI\tools\shell.efi
    	options "fs0:\EFI\tools\launch_windows.nsh"
    	disabled
    }
    
    menuentry "Mac OS X" {
    	icon \EFI\boot\icons\os_mac.png
    	volume "Macintosh HD"
    	loader \System\Library\CoreServices\boot.efi
    }
    Remember: I had to rename the "refind" folder to "boot" and the "refind_x64.efi" to "bootx64.efi" after installing it with the "--esp" option.

    I also had to copy the driver_x64 folder into the /efi/boot/ folder -- renaming it to just "drivers" and that's why it's listed for the scan_drivers_dirs option

    To access that partition to tweak things (the names of the folder/file), I used the following commands:
    Code:
    mkdir /Volumes/esp
    followed by:
    Code:
    sudo mount -t msdos /dev/disk0s1 /Volumes/esp
    This mounts the partition so you can just edit it and copy the driver folder into it using finder.

    The only downside is that it shows me literally every boot option here - so 2 linux partitions, 2 mac partitions (one for the recovery hd I think? So could opt to not scan that with another conf option) and then another for something else, I can't remember. Anyway, I hope this helps you! I've been working on this for 3 days straight and checked out the top 10 links on like 15 different searches I've done for this.

    If you have any questions, please ask, I'm not sure how clear I was through this.

    I'm just happy to have a Mac OS X 10.10 Beta and elementaryOS dual-boot finally working!
     
  18. anubis72 macrumors regular

    anubis72

    Joined:
    Jan 18, 2004
    #18
    Well done and thanks for sharing the fruits of your labor!
     
  19. broduderson macrumors newbie

    Joined:
    Aug 4, 2014
    #19
    I was running Arch on another partition and I followed your instructions and refind is working. Unfortunately, everytime I boot grubx64.efi or the custom menuentry I had before, it gives me an error about not recognizing the filesystem. I made sure the ext4 driver was loaded and even tried re-installing grub and I'm still receiving errors. Any ideas?
     
  20. diorahman macrumors newbie

    Joined:
    Sep 15, 2014
    #20
    Where is the driver_x64 folder?

    Thanks

     
  21. anubis72 macrumors regular

    anubis72

    Joined:
    Jan 18, 2004
    #21
    It's located in the refind-bin-0.8.x/refind folder (which is located wherever you downloaded and unzipped the archive to).
     
  22. jsonified macrumors newbie

    Joined:
    Sep 17, 2014
    #22
    Explanation of what breaks refind

    When Yosemite is installed (upgrade or fresh) OSX converts the target HFS+ partition from a primary partition into a logical partition.

    refind doesn't support these nested logical partitions, and can neither find nested volume to display it in the refind menu, nor later on load boot.efi as it cannot walk the partition.

    You can install refind to the FAT-based EFI partition, and bless it, which will enable refind to detect and use other non-OSX operating systems, but you *will* lose OSX login from refind as a direct consequence of this partition alteration.

    You can always boot back to OSX by holding down <alt> during boot phase, and selecting your OSX hardware from the ugly menu.

    Other than that, wait for a fix from the refind author, or backup & restore the HFS+ Apple_CoreStorage volume as a plain HFS+ volume, and see how you get on.
     

Share This Page