Bootmgr Missing! Help?!

Discussion in 'Mac Pro' started by t0rr3s, Jun 15, 2012.

  1. t0rr3s macrumors 6502

    t0rr3s

    Joined:
    Dec 23, 2010
    #1
    Something buggered up after my recent mac pro 1,1 upgrade to 10.7.4 from 10.6.8 which prevents me from booting my Win7 system. The Windows7 64bit is on its own hd and after getting the bootmgr missing msg I proceded to boot from my windows disc to repair.

    Now I managed to get to the system repair screen, although my windows system is not listed. It prompts me to load drivers (so as to enable my hd to be seen) but I can't figure which driver to boot and from whereI tried the ESB2 to no avail (extracted from bootcamp)

    In OSX, hd controller is stated to be Intel ESB2 AHCI. Can anyone help?
     
  2. Buffsteria macrumors regular

    Buffsteria

    Joined:
    Jun 9, 2012
    #2
    Go step by step.
    Put in Win7 disk, boot into recovery console
    Type DISKPART (enter).
    Type LIST DISK (enter).
    Choose the disk that contains your WinRE partition. If it is disk zero, you type SELECT DISK 0.
    Type LIST PARTITION.
    Now select your Windows disk – the one you want to boot from. If it is partition 2, you’ll type SELECT PARTITION 2.
    Again examine details with DETAIL PARTITION.
    Once you’re sure, mark it active with the command ACTIVE.
    Type EXIT to get out of Diskpart. You’re back at the commandline.
    You need to be sure there are system files on the new bootloader drive. if that drive is C:, you will put them there with this command: BCDBOOT c:\windows /s C: (you can use BCDBOOT /? to learn the other options available.)
    Now reboot the machine.

    It's how I got Windows 7 to dual boot in my Hackintosh. For a long time I couldn't get it to boot, the Windows NTFS thing appeared on the Chimera bootloader and if I selected it I got "bootmgr is missing". The above solved all my problems.
     
  3. t0rr3s thread starter macrumors 6502

    t0rr3s

    Joined:
    Dec 23, 2010
    #3
    thanks for the reply mate. it didn't totally fix it but i learnt a lot from the whole process although i had to nuke that disk and reinstall my windows system. cheers! :)
     
  4. chrisyking macrumors newbie

    Joined:
    Sep 8, 2013
    #4

    I'm having the same problem. Bios can see windows boot manager which works fine, but Cameleon can't see it. I can't make the partition active as it says you can't make efi partitions active for some reason. The above doesn't help me i'm afraid.
     

Share This Page