Borderlands, not able to host (GameRanger)

Discussion in 'Mac and PC Games' started by padré, Feb 2, 2011.

  1. padré macrumors regular

    Joined:
    Aug 7, 2006
    #1
    Me and some friends recently downloaded Borderlands (via The App Store). The game's singleplayer part is working perfectly, however we kinda bought the game to play it co-op.
    All of us downloaded the gameranger client to host our own lobbies. However None of us where able to do so (I was able to host a game twice, but after that we all expierenced the same problem).

    Here is a simple explanation of what happens:

    1. We open GameRanger
    2. One of us starts to host a lobby
    3. The rest of us joins the lobby
    4. The host clicks start
    5. The game boots
    6. We get to the main menu (the same one you get when playing singleplayer)
    7. There a load screen, and thats where it stops, it just keeps on loading and loading, it doesn't go past the loading screen.

    we are forced to force quite the game and to force quite GameRanger (it won't respond).

    We tried to look online, which seems to tell us to forward ports, however none of us seem to have a clue on how to do this + the once that do know something on this topic don't seem to find where to do so?

    Thanks in advance,

    (edit: I've been able to get rid of the problem by forwarding my port and enabling the upnp of my modem, this worked for me, but not for the others)

    -Brun
     
  2. ActionableMango macrumors 604

    ActionableMango

    Joined:
    Sep 21, 2010
    #2
    A router or software firewall is interfering with hosting. Anyone who wants to host needs to figure out how to do proper port forwarding. There are no step-by-step instructions for this because it's different for each router or software firewall.

    If someone has a router that doesn't support port forwarding (or they can't figure out how to do it), they'll have to disable their firewall temporarily while they are hosting.
     
  3. IanAtFeral macrumors member

    IanAtFeral

    Joined:
    Sep 15, 2009
    #3
    Hey Brun, this is exactly the kind of clear and well-written explanation of the problem that our support team love to receive. :D Details on how to contact them are in the 'Support' tab of the options window that pops up when you run the app. I think you're definitely on the right track though… this sounds like an issue with GameRanger and your friends' router setups.

    – Ian
     
  4. padré thread starter macrumors regular

    Joined:
    Aug 7, 2006
    #4
    Re:

    @ActionableMango: Thanks for the advice, I managed to forward my port which worked for a times, then suddenly it decided not to work anymore... :p kinda anoying

    @IanAtFeral: Thanks for looking in to this topic Ian, my friends and I have send an email + a (generated) report to your support service yesterday. Haven't heard back from them though, I hope I will soon :)

    -Brun
     
  5. IanAtFeral macrumors member

    IanAtFeral

    Joined:
    Sep 15, 2009
    #5
    Nice one. You'll definitely hear back :)
     
  6. padré thread starter macrumors regular

    Joined:
    Aug 7, 2006
    #6
    Still no reply from feral (Sorry if I sound inpatient)
    Other people seem to have this problem too:

    http://www.gameranger.com/forum/?t=4728#25012

    Tried the forwarding with the ports, but no success or at least no lasting succes, managed to get a hosted game working, but not for long + couldn't recreate the success...

    -Brun
     
  7. padré thread starter macrumors regular

    Joined:
    Aug 7, 2006
    #7
    New Mail

    I've send them an mail with our new progress and what we've managed to do so far:

    Hi (again),

    I've contacted you a few days earlier regarding a problem with not being able to host a game (or join for that matter) using GameRanger. After browsing your support pages and the support pages provided by GameRanger I (and my friends) came to the conclusion that we needed to forward our ports, we tried to do so and failed, I managed to use that method and succeed but only once... This however didn't seem to work for the others and doesn't seem to work for me anymore, I wasn't able to host again even though the ports are still activated...

    Just wanted to give you guys a heads up that the problem might be deeper than just a "forward ports" solution. All of my friends have this problem so it starting to look more like a pattern right? I really hope you guys can help us with solving this, we really bought this game for the co-op part and after trying everything. We're a bit let down for not being able to enjoy this wonderful game together...

    I've included another "Report" maybe something has changed since the last one...

    Here is a step by step of how I forward the ports (I've included an image to make things more clear, I highlighted the ports in question with a red tint):

    Lan Servers (open ports).png

    1) I enter my router
    2) I go to my LAN servers (the place where I can "open ports")
    3) I make 2 new entries, one of them is a TCP protocol and of them a UDP protocol (hoping that one of these will be the right one)
    4) The Public start ports, public end ports and the LAN start port are put too 16000
    5) We've read somewhere (on GameRanger) to put the UPD's Local IP Address on 192.168.1.4, I did the same for the TCP's ip address. Both of them didn't work, however I managed to make it work once by putting the TCP's ip address to 192.168.1.3 (this might have something to do with the fact that my ip address is dynamical and not static...)

    Once again, thanks in advance,

    -Brun


    Edit: I've got a response, but its not really helping:

    Dear Customer,

    We have has a few people who have experienced similar issues, and most have found that the solution lies in all players forwarding their ports. I cannot offer specific advice for each player, as each router behaves differently. Please look online for further information about each router and let me know if you are still experiencing problems after all players have forwarded ports.

    Best Regards,

    Gerard McAuley
    Feral Interactive Support
     
  8. edddeduck macrumors 68020

    edddeduck

    Joined:
    Mar 26, 2004
    #8
    Firstly please give us enough time to look into the bug before complaining on the forums! Less than 24 hours as you said yourself could be seen as impatient ;)

    The problem as Gerard said in the email is with how all your routers support port forwarding using UPNP and also how they all play together so your machine being correctly setup does not mean you will be able to play if the other players have an issue. Borderlands is more strict than most (even on the PC) so port forwarding issues can happen more frequently.

    Unfortunately there are a few million different routers in the world and billions of router and Mac combinations so we cannot just offer a 1,2,3 step by step guide to solve a port forwarding issue as every single one is different.

    We are trying to collate data and see if we can find something constant among all people with problems that we can then investigate or even better a find some instructions that will work for most users. To summarise the internet is a huge pile of routers and machines and it is impossible to write a simple solution for everyone however we are working on it!

    Edwin

    p.s. It is now 7pm on Friday so any emails you send likely will not be answered till Monday.
     
  9. padré thread starter macrumors regular

    Joined:
    Aug 7, 2006
    #9
    @edddeduck

    Thanks for your response, my apologies if I came across as an impatient person, english isn't my main language. Its great to hear that you guys are looking in to this.

    I'll keep you up to date if I manage to get it working again and I'm sure you will do the same.

    Enjoy the weekend!

    :apple:
     
  10. ActionableMango macrumors 604

    ActionableMango

    Joined:
    Sep 21, 2010
    #10
    If you're still having problems, I'd try having the host disable his router's firewall and his computer's firewall completely. This isn't a good long-term solution, but it helps troubleshoot.
     
  11. padré thread starter macrumors regular

    Joined:
    Aug 7, 2006
    #11
    @ActionableMango:

    We tried to do both of them, but without success.

    Will keep you posted...
     
  12. Miel macrumors newbie

    Joined:
    May 12, 2011
    #12
    Good to hear other having the same issue.

    My situation is exactly as the one described here, and im also still working on a solution.

    Any update?

    Kind Regards, Miel
     
  13. edddeduck macrumors 68020

    edddeduck

    Joined:
    Mar 26, 2004
    #13
    There should be an update to help solve this issue coming soon, we have been speaking to GameRanger about this and we have a potential solution we just need to test it and make it live.

    The problem is related to users with the German censored version of the game the worldwide standard version does not appear to be effected.

    Edwin
     

Share This Page