Bose QC3 Heaphones broken already?

Discussion in 'Buying Tips and Advice' started by Echthros, Apr 9, 2011.

  1. Echthros macrumors member

    Joined:
    Apr 18, 2010
    #1
    My uncle gave me a new set of Bose QC3 headphones about a week ago. However, only after charging the battery for the first time, the left side-- the left headphone doesn't seem to be working. I've tried using it with my iPhone as well as several of my computers, but only to no avail.

    It seems as though if I play with the actual connection between the headphone and the attachment wire is when music can be heard. However, the input, it seems like, must be pushed in [the headphones] a certain way in order for music to be played. And whenever I let go, it goes back to being unable to emit any sort of sound.

    The right side works, however, regardless of the situation. Any advice on what I should do? I mean, I've only had these headphones for a week, and they're broken already?
     
  2. xlii macrumors 68000

    xlii

    Joined:
    Sep 19, 2006
    Location:
    Millis, Massachusetts
    #2
    If they are brand new... return them. If not, you could go on the Bose website to see if they offer repair services. From your description it sounds like a loose connection somewhere. The weakest point is generally where the wire enters the headphone.

    Edit: since they are new, return them... tell your Uncle because he has either the sales slip or his credit card info. You did nothing wrong... they sound defective from the get go.
     

Share This Page