Both Paralles and Boot Camp searching for something

Discussion in 'MacBook Pro' started by DBmac08, Aug 20, 2008.

  1. DBmac08 macrumors newbie

    Joined:
    Aug 10, 2008
    #1
    Hello
    I have both a Paralles virtual file and a separate XP Pro sp2 partition on Boot camp. I use the Boot camp side only to play games and the Paralles for a couple of other programs. Recently While in boot camp playing Call of Duty 4 the touchpad would lock up for a few seconds and I'd hear a beep in the background like I just added a new piece of hardware. A few seconds later it would beep again. After a little while it would happen again. Each time the touchpad and keyboard would freeze but only for a few seconds. After this happens, the touchpad will be less responsive afterwards.
    When I'm on the Mac side everything seems to run fine but when I open the paralles windows it works and nothing locks up but this pharse will pop up,

    "You are trying to connect USB HID device to the virtual machine. The device connected to the virtual machine will be inaccessible in Mac OS X until it is disconnected from the virtual machine or until the virtual machine is stopped or suspended. If you connect your primary keyboard or mouse to the virtual machine, it will be impossible to use them in Mac OS X.

    Do you want to connect this USB HID device to the virtual machine?"


    If I say "yes" to that, the keyboard will become unusable on the Mac side. Up until recently All these versions were running fine. I should also mention that I don't have to be playing a game on Boot camp for the problem to occur. Also I don't know if its always been this way but the internal DVD drive shows up on Boot camp as an external option.
    Thanks for reading this.
     
  2. TEG macrumors 604

    TEG

    Joined:
    Jan 21, 2002
    Location:
    Langley, Washington
    #2
    It sounds like the internal USB bus or host is loose or having difficulties. OS X doen't let you know, because it doen't care when you add or remove USB devices, except drives. You wouldn't by chance have a USB device connected to one of your USB ports and overloading the internal bus?

    I'd call Apple or see a Genius to diagnose for sure.

    TEG
     
  3. DBmac08 thread starter macrumors newbie

    Joined:
    Aug 10, 2008
    #3
    No, nothing is connected externally when this occurs. It do use a external hard drive and have a blackberry that i connect to the laptop at times but only on the Mac side.
     
  4. DBmac08 thread starter macrumors newbie

    Joined:
    Aug 10, 2008
    #4
    I used the tech tool deluxe and ran the tests everything passes including the UBS test. I ran that a few times. So not sure what else to try. Is there something on the windows side that may give me some insight?
     
  5. ChristopherL134 macrumors newbie

    Joined:
    Aug 20, 2008
    #5
    I'm suffering from something similar in XP pro via BootCamp: needed to print on an old parallel port hp1100 and plugged in an old Belkin USB hub (type 1 usb) with parallel+serial+mouse ports and installed the driver - although afterwards I followed the Belkin XP uninstall instructions - all my usb ports act as 1s and the isight no longer works in windows. First of all: boot camp repair - several times: no joy. Tried uninstalling usb drivers etc in hardware manager so that windows could rediscover the hardware - managed to disable the keyboard and touchpad & its button! - Fortunately the power button instigated what appeared to be an orderly shutdown and I got the keyboard back on a reboot and from there a little toing and frowing in the device manager with changing the mouse driver from the two options given got the touch pad and then its mouse button back. I am not inclined to experiment further just yet but suspect that I will end up doing a complete re-install of Windows.

    You may have installed drivers for a usb type 1 hub device at some point - even without knowing it (Windows discovering new devices and installing drivers on its own) and and run into the same or similar problem.

    Knowing how a healthy set of usb hub drivers in a MacBook Pro (in my case 17inch high def, 2.6GHz, 200Mb) should look would enable both of us to force the use of the driver that one specifies. As I understand the situation there are several internal usb buses of which one is a type 1 and serves keyboard and touchpad whilst the isight internal camera is on a type 2 bus and thus in my case is now inaccessible to Windows.

    Probably all the type 2 usb host controllers and usb root hubs should use the Orange Ware Corporation drivers ousb2hub.sys+ousbehci.sys and ousb2hub.sys respectively - this is in the Windows installation.

    If you look at which drivers the usb host controllers are using and they are simply usbhub.sys, usbport.sys, usbuhci.sys and usbui.dll from MicroSoft then that may be the problem.

    If you are brave enough to experiment with forcing Windows to use the drivers that you specify, please post the results of your endeavors.
     
  6. DBmac08 thread starter macrumors newbie

    Joined:
    Aug 10, 2008
    #6
    Thanks I'll give that A look. I have called Applecare and have a box on the way but I would rather figure this out with out sending it out.
     

Share This Page