Bought a Late 06 17" 1.83GHz C2D with 2GB RAM and 160GB HD

Discussion in 'iMac' started by Shift Option K, Feb 7, 2014.

  1. Shift Option K macrumors regular

    Shift Option K

    Nov 26, 2013
    Now that I have an actual home, I decided to get another Mac, and my first Intel Mac was purchased. Like the title, it's a Late 2006 17", 1.83GHz Intel Core 2 Duo, 160GB HDD and 2GB RAM. Currently, it's on Leopard but I'm upgrading to Lion once I can find Snow Leopard DVD and Lion USB on Craigslist. Now here's a question. What iTunes to sync my iPhone 4S on the latest iOS 7 version, and does that version work on Lion? I'm pretty sure Mavericks can;t install on this iMac.
  2. Intell macrumors P6


    Jan 24, 2010
    For iOS 7, you need at least iTunes 11. iTunes 11 requires Snow Leopard or newer.
  3. peglegjack macrumors 6502


    Jul 30, 2011
    Brooklyn, NY
    You may want to keep it on Snow Leopard for now until iTunes or the browser you use becomes outdated.

Share This Page