Brand new 2011 MBP, graphic card fried?

Discussion in 'MacBook Pro' started by MacMarf, Aug 13, 2011.

  1. MacMarf macrumors member

    Joined:
    Apr 5, 2010
    #1
    Got my 2011 15" 2.2 i7 MBP last month, the one with the 1GB graphics, everything went fine, but 10 minutes ago it seemed like my graphics card was messed up. Colors got milky, gradients didn't flow like they should, and most scary the top left corner turned black, and had green and red squares with pixels in it. Took a screenshot and rebooted, the screenshot doesn't show anything and rebooting fixed it, but I am a bit worried now. What could've caused this problem?
     
  2. VeganHipster macrumors regular

    Joined:
    Jun 18, 2011
    #2
    It may have just been the game. People are reporting various problems with games like The Witcher II.

    What game were you playing?
     
  3. w00t951 macrumors 68000

    w00t951

    Joined:
    Jan 6, 2009
    Location:
    Pittsburgh, PA
    #3
    1) What driver version
    2) What game
    3) OC or no?
    4) Go to Reliability Monitor, and check what the BCCode of your crash is. If it's 117, no worries. If it's anything else, it may be a hardware issue.

    I am afflicted by a similar bug. Thankfully, my bug is due to running on 11.8 Catalyst Beta drivers. Any game's graphics will randomly freeze, but the sound will still be real-time. I just wait a couple seconds, and the display unfreezes with the "display driver crashed" notification.
     
  4. jamezr macrumors G4

    jamezr

    Joined:
    Aug 7, 2011
    Location:
    US
    #4
    What OS are you running? Did your new MBP come with Lion? Did you upgrade to Lion afterwards? I have been hearing a lot of problems with games running under Lion......just wondering. Did you install Windows? Are you running the game in Windows? If so make sure you have all the latest drivers for the video card...... If all else fails either call Apple or stop by an Apple store and let them diagnose the issue for you....
     
  5. MacMarf thread starter macrumors member

    Joined:
    Apr 5, 2010
    #5
    Hey, thanks for all your help everyone. I was not running any games (not on windows either), was just using Adobe Fireworks Cs5, Twitter for mac and safari. Os X 10.6.8 has been installed when I got it and it hasn't been upgraded. Really strange. Especially when I took a screenshot, if I view the screenshot now, everything is normal.

    I can not find the mentioned reliability monitor, searched my HD, but it seems not to be there. Where is it located?


    It also seemed like the text had anti-aliasing off, and had grey edges. That and what was in the main post is all I can remember.
     

Share This Page