Brand-New Headphones Don't Work on iMac

Discussion in 'iMac' started by iMacJunkie, Nov 25, 2011.

  1. iMacJunkie macrumors regular

    Joined:
    Aug 7, 2011
    #1
    I have a pair of brand-new Sennheiser HD202 headphones I just opened (link below).

    http://www.amazon.com/Sennheiser-HD...5BP9/ref=sr_1_2?ie=UTF8&qid=1322211163&sr=8-2

    They won't work on my iMac. The other Sennheiser headphones I had worked before but no longer do no matter what I try.

    The only headphones I have that works fine every time are a pair of JVC flip headphones (where the ear pieces rotate inward when you put them on), but the cable is far too short and I need a longer cable (hence my switching over to the Sennheisers)

    Why won't my Sennheiser headphones work?
     
  2. bpaluzzi macrumors 6502a

    bpaluzzi

    Joined:
    Sep 2, 2010
    Location:
    London
    #2
    What do you mean by "not work" -- no sound? quiet sound? distorted sound?

    Do they work on other sound sources?
     
  3. johnhw macrumors 6502

    Joined:
    Jun 16, 2009
    #3
    Are you sure it's the iMac? Try plugging in the Headphones to another device. Could be the headphones.
     
  4. iMacJunkie thread starter macrumors regular

    Joined:
    Aug 7, 2011
    #4
    Not work as in - they are totally dead. Zero sound. No switching output sources from speaker to headphone as they're plugged in in settings either. But, my JVC headphones work fine and it always automatically switches to headphones in the settings > sound panel and sound plays fine through them. Both Sennheiser headphones are totally dead when hooked up to my iMac though. Haven't tried them on other sources yet.
     

Share This Page