Brand new Mac Pro running slow

Discussion in 'Mac Pro' started by indiochano, Mar 27, 2011.

  1. indiochano macrumors regular

    Joined:
    Jun 7, 2008
    #1
    Ok so I got a brand new quad core 3.2 GHz Mac Pro.

    It's equipped with 3gbs of ram (got 12gb coming soon from OWC) and a radeon 5870

    Standard HD running at factory settings.

    The weird thing is that for the most part, things run fairly smoothly but sometimes it lags... I use a mac pro at work and it's a slower and older model yet it runs faster than this machine...

    Any ideas or tools that might diagnose the problem?

    Thanks!
     
  2. Blue Velvet Moderator emeritus

    Joined:
    Jul 4, 2004
    #2
    Wait until you get more RAM in it, which you say is on the way, before taking a second look at the problem.

    You haven't said what apps you're running, but only 3Gb of RAM when you've got Safari, a heap of Creative Suite apps and iTunes open is enough to generate large swap files which can bog the machine down... and running anything more demanding can lead to insufferable beach-balling at times.

    In energy saver (system preferences) set it up for best performance and not putting the hard disk to sleep, just in case.
     
  3. kellen macrumors 68020

    kellen

    Joined:
    Aug 11, 2006
    Location:
    Seattle, WA
    #3
    I agree with above. Check your page in/outs to see if you are instantly paging out.

    How full is the HD? What apps are you using? How much ram is on your work machine?
     
  4. indiochano thread starter macrumors regular

    Joined:
    Jun 7, 2008
    #4
    Thanks guys,
    i'll let you guys know how it goes.

    Hopefully it's the ram! :)
     
  5. indiochano thread starter macrumors regular

    Joined:
    Jun 7, 2008
    #5
    Definitely the memory.

    Installed 12gb, now this **** flies like there's no tomorrow.

    It's time to get some work done with this beast.

    Thanks guys!
     

Share This Page