Brand New Macbook, Not Working Properly?

Discussion in 'MacBook' started by ipodtouchy333, Oct 25, 2008.

  1. ipodtouchy333 macrumors 65816

    Joined:
    Nov 15, 2007
    Location:
    US
    #1
    Well I just got my first mac which is the 2.4 macbook. I find using safari and firefox to be quite slow. Another thing is that when I go to watch trailers in iTunes and any HD trailers on apple.com they don't play, a black box just appears and sometimes it will even get as far as loading just a little bit and then stopping. Is this normal for a brand new $1600 computer?
     
  2. synth3tik macrumors 68040

    synth3tik

    Joined:
    Oct 11, 2006
    Location:
    Minneapolis, MN
    #2
    sounds more like network setup/problems then anything else. I would check that. Also if your using Wi Fi check the network using ethernet, just to eliminate the airport card in troubleshooting.
     
  3. nubee macrumors member

    Joined:
    Oct 25, 2008
    #3
    Are you talking about the programs themselves, or the internet connection? Because it might just be a coincidence that your internet is having issues.
     
  4. SpEnCeR132 macrumors newbie

    Joined:
    Aug 12, 2008
    #4
    check your internet and if that doesnt work then take it to the apple store, they will either fix it or replace it with a brand new one
     
  5. James17 macrumors 6502

    Joined:
    Dec 13, 2007
    #5
    I think it may be a problem with your internet. Is your internet fast enough to load HD trailers quickly? Mine would do as you describe, go so far then stop to re-buffer as it's a lot of data.
     
  6. dr. shdw macrumors 6502a

    Joined:
    Aug 27, 2008

Share This Page