Brand New Penryn Macbook Pro will not Restart - Please Help

Discussion in 'MacBook Pro' started by pforan, Mar 10, 2008.

  1. pforan macrumors newbie

    Joined:
    Mar 10, 2008
    Location:
    Ithaca, NY
    #1
    Can someone tell me what's going on with my brand new MBP?

    I am a recent switcher from PC to Mac who is REALLY trying to love my new MBP. It's a 15" 2.4ghz, 250GB, 2GB RAM, Leopard 10.5.2. In every respect, it's an awesome machine, except for the incredibly frustrating fact that in the two days I've had it I've had to hard restart TWICE. It just will not restart without major problems. Two days ago, I received the machine, did nothing more than boot it up, set up a network connection (super easy), play with some of the installed programs (which I love!), and transfer a couple gigabytes of photos (all JPEG files) from my old PC. Everything worked perfectly; I couldn't have been happier with my new machine. Then I decided to do the "hardware test" recommended in the manual by booting up while holding down the "D" key. I closed ("quit") all my open programs, and clicked Apple > Restart. The dock, icons, and cursor disappeared, leaving only the desktop image, and it sat like that, with the little gear spinning over the desktop, for 40 MINUTES. For the first ten minutes I thought maybe it was running some sort of software update as it was the first time I restarted, but it just hung and hung. I got on the phone with Apple support, and they had me hold down power to force it off, boot up in safe mode, delete two sub-folders from the "System" folder (I can't remember where they were, but one was called "Cache"). Then I rebooted and everything was working fine. For two days I've been transferring files from my PC via an ethernet cable (probably 20GB, no problems), and I installed a bunch of programs like Word 2008 for Mac, Photoshop CS3 & Firefox, plus several little utilities like ClamXav & Adium. All installations went smoothly, and all the programs worked flawlessly (I couldn't believe how fast Photoshop ran!). After all of this, I figured I should restart, so, same deal. I quit all programs, hit Apple > Restart, and the SAME THING AS BEFORE! I get just the desktop image with gear spinning, and it WILL NOT restart. Waited 25 minutes this time before forcing the machine off. Apple Support is closed right now, and I can't remember the folders I was told to delete before and I'm not about to start sorting through the System files on my own. So I booted up normally, which seemed to work fine, but now some things are running REALLY slow, especially (for some reason) Firefox and Safari. The internet had performed flawlessly (SO much faster than my PC laptop), and I have a full airport signal, but since the last restart it takes 30 seconds or so just to open Google's page, and a full minute to open something like NYTimes.com. Firefox and Safari are equally slow. I feel like I'm on dial-up. This is a brand new issue, as my internet (on any browser) was zipping along without a hiccup for the last two days, and it's still working fine on my old laptop. WHAT IS GOING ON? I was so smitten with my MBP for the first day, but these problems are ridiculous. My 7 year old HP piece of junk laptop never had problems like this.

    Could someone please tell me what's going on with my MBP? I would greatly appreciate any help or advice. I should also note that I ordered it 8 days ago, have had it for 3 days, and I live about 2hrs from the nearest Apple Store, so "taking it in to the shop" is out of the question. Is this a reason to return, or is there some simple fix? I'm just really confused about how a brand new powerful & expensive machine could be malfunctioning so badly after so little use... Again, I'm grateful for any help.
     
  2. richard.mac macrumors 603

    richard.mac

    Joined:
    Feb 2, 2007
    Location:
    51.50024, -0.12662
    #2
    Leopard shuts down significanly slower than Tiger and i assume it will get better as it matures just like Tiger did. you just have to give it some time. in the event that it hangs while restarting again force shutdown and boot into Install DVD 1 by holding C on startup and repair permissions and repair your disk using Disk Utility in the Utilities menu.

    then delete the cache folder in the System Library, main Library and your home Library while in safe boot and then try running Onyx's automation feature in a normal boot. it will ask you to restart and hopefully it will.

    keep in mind that your boot times will be slower when clearing the caches. if this fixes your restart problem booting a few more times will defrag the newly created boot caches and boot times will return to normal.
     
  3. garethlewis2 macrumors 6502

    Joined:
    Dec 6, 2006
    #3
    I'm sorry to hear that this is happening to you. No this is not normal. If OS X (Leopard) needs to install updates or perform maintenance when it shuts down, it will inform you. This only takes a few minutes. That fact that your machine is sitting there for 25-40 minutes means there is a rogue process that OS X is waiting to exit before shutting down. I hate to say it, but I would recommend you do a completely clean install and restore the machine with the discs that came with it. If this does not fix the issue, then maybe you can ask for a boxed copy of Leopard rather than install discs. It might be a bit much to convince Apple support that you have a hardware issue, if it only exists when you try to restart.
     
  4. pforan thread starter macrumors newbie

    Joined:
    Mar 10, 2008
    Location:
    Ithaca, NY
    #4
    Still unsure what caused crashes

    Rich and Gareth, thanks for your responses!

    To Rich: it's hard for me to believe that this is part of a routine process for OSX. I'm not exaggerating in the slightest when I say it hung there with the gear spinning for 40 minutes. And it wasn't even done after 40 min, that's just when I forced a shutdown.

    I spent about 30 min with Apple Support yesterday; they had me do exactly what Rich outlined above in his first paragraph, repairing permissions and repairing the disc. During the permissions process, the utility seemed to find 5 or 6 files that it isolated as somehow out of place. I tried to get the Apple tech to explain what these files were, how they had been misplaced/corrupted, or why they were causing such havoc, but she either didn't feel like or wasn't able to explain. I think she was reading everything from a script. When I repaired the disk, it gave me the green message that the disk was okay, and the next reboot went off flawlessly. Does this mean I should be in the clear now?

    My main question is still: what caused this to happen? Was it something I did when I was installing programs or transferring files from my PC? Or was it caused by some internal OSX flaw that had nothing to do with me? When I asked the tech this, she replied that it was probably the OS itself, but had no answer for what might have caused it. Her only response was, "These things sometimes happen." Well, that's obvious, since it happened to me, but I want to know why, and more importantly, how to prevent it from happening again.

    Also, are there any stress tests I can use to "put it through it's paces" to make sure it's not going to crash, hang, or otherwise explode, say, the day after my 15 day return window closes? If it's restricted to those two freezes, I'll let it go, but if this type of misbehavior continues, it'll (sadly) be on a truck back to Cupertino.

    Thanks again for all of your help! It's very much appreciated.
     
  5. pforan thread starter macrumors newbie

    Joined:
    Mar 10, 2008
    Location:
    Ithaca, NY
    #5
    Now iMovie is crashing. What's going on?

    So, to add to my previous post, I've been trying out some different programs, I captured some video from my non-HD video camera and was editing it in iMovie. Actually, I hadn't "edited" anything yet, just dragged a clip to the project window and was playing it, when the whole program crashed. It just up and vanished with an "iMovie quit unexpectedly" error message. I'm posting the first part of the error log that was generated below. I was not doing anything that would "stress" the processor, just playing a 1min clip in the player window. Also, looking at the "Activity Monitor," I see that I have 20MB of "swap" memory used. Isn't swap only used when there isn't enough RAM to run your applications? How would running a simple task in iMovie use more than 2GB of RAM? Please guys, I am dangerously close to returning this laptop, which I really want to keep. But 2 perpetual freezes and 1 program crash during routine use in the first 3 days is not what I was expecting from Apple.

    Can anyone tell me what's going on? Should I return/exchange?

    _________________
    Here's the initial info from the error log:

    Process: iMovie [168]
    Path: /Applications/iMovie.app/Contents/MacOS/iMovie
    Identifier: com.apple.iMovie7
    Version: 7.1.1 (529)
    Build Info: iMovieApp-5290000~2
    Code Type: X86 (Native)
    Parent Process: launchd [74]

    Date/Time: 2008-03-11 20:39:14.774 -0400
    OS Version: Mac OS X 10.5.2 (9C2028)
    Report Version: 6

    Exception Type: EXC_BAD_ACCESS (SIGBUS)
    Exception Codes: KERN_PROTECTION_FAILURE at 0x0000000000000000
    Crashed Thread: 0
     
  6. rezonat0r macrumors 6502

    Joined:
    Nov 2, 2007
    #6
    Did you ever run the hardware test? I too would recommend doing a clean install of OS X.

    If problems persist after that, you have bad memory or a defective motherboard (logic board).
     
  7. pforan thread starter macrumors newbie

    Joined:
    Mar 10, 2008
    Location:
    Ithaca, NY
    #7
    I did run the hardware test, and everything checked out fine. This MBP is brand new, with a factory install of OSX 10.5.2 -- isn't that a "fresh install"? If I reinstall, will that make it work any better? I've spent the better part of three days transferring 20,000 files and installing a couple dozen programs and would rather not wipe all of that out unless it's necessary.

    Since I'm new to Mac, I'm wondering if the error log generated when iMovie crashed (see above) is abnormal, or something to be expected sometimes. I.E., does it signify a larger problem with the OS or not?

    Also, if I had bad RAM or a bad logic board, wouldn't that register in the hardware test?
     
  8. mephisto12 macrumors newbie

    Joined:
    May 24, 2008
    #8
    Same problem

    Hi there, I have exactly the same notebook and the same problem... my macbook pro (Penryn 2.4 200GB GF 8600 256) just won't restart. The little gear is just spinning and spinning over the desktop and it won't restart/power off. I hope that it's not a hardware issue because I live in serbia and i waited 1 month for it....
    I't soooo frustrating.

    Any help would be appreciated
     
  9. klaxamazoo macrumors 6502

    Joined:
    Sep 8, 2006
    #9
    My guess would be a bad logic board. I've seen this happen on a number of newer computers lately and I think it is tied to the new lead-free solders that they have to use. The solders melt at 230-240 degrees instead of 180 degrees. this puts a lot of strain on the components and manufacturers are still trying to work the bugs out.

    In my experience there is nothing you can do to fix it and you are better off demanding a new computer. If you let apple repair do it's thing this is the order of operations:
    1) Reinstall the OS
    - doesn't work for a hardware failure
    2) put in a new hard drive
    - the hard drive isn't the problem
    3) new logic board or RAM
    - by then you are really pissed off and want nothing to do with Apple

    I've seen this happen to both myself, girlfriend and sister. Since you have had your computer less than a month you are better off trying to get a new computer.

    I don't know if it is specifically an apple problem or an industry problem because I haven't talked with anyone who has bought a non-apple computer in awhile.
     
  10. jpmcburney macrumors newbie

    Joined:
    Jun 17, 2004
    #10
    Throw away apple hardware cd

    I have never had success with the apple hardware checking bs. Why did you run that cd in first place? You should insert 10.5 install disc, and restart with c key held down, run permission repair. Restart. Leave computer on all time so UNIX can clean up your disc overnight(s).

    Your computer may take a few days (actually they happen after midnight) to clean up the mess that apple hardware check may have caused when your patience cancelled the test before it was complete.

    Those long shut down / restart issues are common to fresh installs of OS or major changes to OS HD. Or when some thing has been stopped in the middle of processing - like hardware checking, permission repair, or keychain first aid.

    Make sure you have more than 10% free hd space or above is mute.
     
  11. alphaod macrumors Core

    alphaod

    Joined:
    Feb 9, 2008
    Location:
    NYC
    #11
    Your computer uses swap because it's already set aside on the computer; it's like it has to; it probably swapped some bit here and there and it builds up; nothing to worry about.

    The error you get seems like a memory protection, with the "No Execute" (http://en.wikipedia.org/wiki/NX_bit) to protect you RAM. It's possible your install is buggy or something; I know I've solved problems like this with program reinstalls and computer restarts.

    Since you have so many issues compounding one another, my advice is to go and exchange for a new machine (You can actually get a 100% refund on the replacement machine if you desire). Getting a new machine hopefully won't have issues like this; note the order you install programs and stuff, that way in-case you run to problems like this and it's specific program, you can back track.
     
  12. docal97 macrumors 6502a

    docal97

    Joined:
    Jun 28, 2006
    Location:
    Southampton
    #12
    Wirelessly posted (Mozilla/5.0 (iPhone; U; CPU like Mac OS X; en) AppleWebKit/420.1 (KHTML, like Gecko) Version/3.0 Mobile/4A102 Safari/419.3)

    you should never have any of these problems. It needs to be brought to a store for an evaluation or sent back to apple. There is obviosly something seriously wrong.
     
  13. jpmcburney macrumors newbie

    Joined:
    Jun 17, 2004
    #13
    last post shows some real thought....

    Wirelessly posted (Mozilla/5.0 (iPhone; U; CPU like Mac OS X; en) AppleWebKit/420.1 (KHTML, like Gecko) Version/3.0 Mobile/4A102 Safari/419.3)

    you should never have any of these problems. It needs to be brought to a store for an evaluation or sent back to apple. There is obviosly something seriously wrong.


    Never? Plato and his ideals.

    Brought is past tense, not that it is making me tense or anything.

    Something seriously obvioUsly wrong.

    Yes, it may be that guy too cool to think.

    Me and my robe.
     

Share This Page