Bricked iPhone 4? Fixable? Help?!?!?!

Discussion in 'Jailbreaks and iOS Hacks' started by ltlftc, Mar 30, 2012.

  1. ltlftc, Mar 30, 2012
    Last edited: Mar 30, 2012

    ltlftc macrumors newbie

    Joined:
    Mar 30, 2012
    #1
    Hello to the macrumors community! I have been reading these forums for almost 2 years now but have never had the need to post. (you guys are so thorough when you post).

    I really need help with an iPhone 4 I got from a friend.
    I got this iPhone 4 with iOS version 4.3.5 with baseband 4.10.01. I used it for about a week as an iTouch. I recently decided I would unlock it to use it with my carrier. It is a telus mobility locked phone and I am using rogers. I picked up a gevey ultra so I could use the furiousmod process and not have to dial 112,

    I decided I would look into ways to downgrade the iPhone to 4.3.3 in order to have an untethered jailbreak and to use furiousmod (4.3.5 is not listed under supported, but I think this is because the jailbreak was released after the specs were written). Since I did not have lots of experience with SHSH blobs (no downgrading since iPod touch 1G) I was reading on the internet for a couple of days to find a way to downgrade. I found a guide which let me downgrade without the blobs.

    This guide got me to the point where I was able to sucessfully downgrade, but the iPhone would be stuck in recovery mode. Using the recovery fix in the different utilities did not work. I tried TU, reds0w, and the separate exe to kick the device out of recovery.

    I was unsuccessful, but I read some people "just booting tethered" to get into their phones. I got it to work, for a while. I powered up, used it for about an hour, but then the iPhone needed to be restarted after it installed a cydia app. It restarted and I had to boot tethered. This time, the screen went blank after a while, on its own. I plugged it into iTunes and it makes the sound when it charges and iTunes even tries to sync it.

    Now, I am unable to boot tethered to get my screen back so all I have is an iPhone 4 that works with iTunes, is able to output audio and vibrations, but will not display anything on the screen. I tried a restore again. But now I cannot even see the connect to iTunes logo. I cannot get anything to display on the screen

    Does gevey ultra work on jailbroken 5.1 with preserved baseband? If so option 2 below is fine

    Can someone help me do one of the following (they are in preferred order):
    1. Stay on the downgraded 4.3.3 with my same baseband with the screen working
    2. Upgrade to 5.1 preserve baseband.
    3. GET MY SCREEN BACK IN ANY OTHER WAY WITHOUT UPDATING THE BASEBAND BUT ALSO BEING ABLE TO US GEVEY ULTRA and/or FURIOUSMOD
     
  2. dhlizard macrumors G4

    dhlizard

    Joined:
    Mar 16, 2009
    Location:
    The Jailbreak Community
    #2
    You should also know that jailbreaking with jailbreakme on 4.3.3 prevents using a Gevey sim
    You can jailbreak 4.3.3 with Redsn0w and be OK

    Go to iClarified.com for a tutorial for going to 5.1 and preserving baseband
    I am not sure if FuriousMod works with 5.1, it was designed for 5.0.1
     
  3. ltlftc thread starter macrumors newbie

    Joined:
    Mar 30, 2012
    #3
    Thanks for the reply!
    I am not sure you understood the problem. My screen is not displaying anything and I would like to maintain the baseband at 4.10.01. I need my screen and iPhone back :(

    Anyone have any ideas or do I have a nice new paperweight?
     
  4. ltlftc thread starter macrumors newbie

    Joined:
    Mar 30, 2012
    #4
    Win win win

    CELEBRATE GOOD TIMES CMON :D:D:D

    Sorry for double post, but this will be easier is anyone want the solution.
    I fixed it while keeping the baseband.

    Ok, first I used redsn0w to make a custom ipsw so I can upgrade to ios 5.1 without upgrading baseband. That fixed it!!! My iPhone is functional again... I think I am going to the rogers store to buy a sim, but I think I will have to head over to the unlocking forums to ask if my gevey will work with ios 5.1 and furiousmod.
     
  5. taaong macrumors newbie

    Joined:
    Mar 3, 2008
    #5
    New to this. I need help also. I think I'm in the same boat as you were. This is my second time going through all this. I have no idea what I did the last time to bring my phone back to life. Like the original person who posted, I tried to update to iOS 5. I read what you did to bring your phone back, I need to do the exact same. Can you please help me. Btw, you may need to break it down for me like yu were explaining this to some noob, cause basically what I am -__-

    I want my iPhone back, this blackberry is NOT happening.

    HELP!!! Plz.
     

Share This Page