brightness buttons no longer work

Discussion in 'Mac Basics and Help' started by Spacecrawler, May 29, 2007.

  1. Spacecrawler macrumors newbie

    Spacecrawler

    Joined:
    May 19, 2007
    #1
    My F1 and F2 brightness buttons have stopped working. I have no idea how this happened and cannot figure out how to fix it. I am using a PowerBook G4, OSX 10.4.9. Any help appreciated.

    Sean
     
  2. Gee macrumors 65816

    Joined:
    Feb 27, 2004
    Location:
    London, UK
    #2
    Do the others still work (volume for instance)? Have you got a second monitor connected? Have you tried restarting?
     
  3. Spacecrawler thread starter macrumors newbie

    Spacecrawler

    Joined:
    May 19, 2007
    #3
    Yes, other buttons seem to work. This problem has been ongoing for several months. You press the buttons (dim and bright) and nothing happens.
     
  4. Spacecrawler thread starter macrumors newbie

    Spacecrawler

    Joined:
    May 19, 2007
    #4
    Posted this question in the powerbook forum after I posted it here as I thought this one was posted in the wrong forum, got some conversation going that may have helped but it seems that someone deleted the thread because it was a duplicate of this one (I wished you deleted this one).

    Anyway- someone in the other forum suggested some troubleshooting steps (PRAM, etc) that might help. Being that the other thread is now gone, can someone here shed somelight on what that poster was referring to?
    Also, he suggested that the display driver might be messed up. Is it possible to download this driver again?

    Thanks.
     
  5. iBookG4user macrumors 604

    iBookG4user

    Joined:
    Jun 27, 2006
    Location:
    Seattle, WA
    #5
    Here's how you reset the pram. Do the buttons work at all? Have you tried using another user account to see if the issue is still present?
     
  6. Spacecrawler thread starter macrumors newbie

    Spacecrawler

    Joined:
    May 19, 2007
    #6
    Thanks for the info.
    I reset the pram, but no change.
    All other F buttons seem to work, and have always worked fine. Just the dimmer/brightness buttons, F1 and F 2 do not work and I have no Brightness control in my Displays preferences.
    I am the only user on this computer.
     
  7. Mitthrawnuruodo Moderator emeritus

    Mitthrawnuruodo

    Joined:
    Mar 10, 2004
    Location:
    Bergen, Norway
    #7
    Make another account. Nice to have for just these kinds of troubleshooting occasions... helps to narrow down the culprit...
     
  8. rreichard macrumors newbie

    Joined:
    Jun 5, 2007
    #8
    I've had this exact same problem for close to a year. Powerbook G4 12" 10.3.9. Periodically I search for an answer but have never found one. I've tried the PRAM thing, the PMU thing, another user and more. All to no avail. I've seen a lot of similar questions but never seen an answer. Luckily my brightness is at a level that isn't too bad to work with. Others I've read about weren't so lucky. I haven't given up yet... Somebody has got to have an answer. Unfortunately it's not me
     
  9. epochblue macrumors 68000

    epochblue

    Joined:
    Aug 12, 2005
    Location:
    Nashville, TN
    #9
    I know this may sound ridiculous, but you don't have programs installed that might usurp those buttons do you?

    I know it's probably not likely, but I didn't notice that anyone had mentioned the possibility yet...
     

Share This Page