Brightness control in Windows 7

Discussion in 'Windows, Linux & Others on the Mac' started by daisun, Sep 22, 2009.

  1. daisun macrumors newbie

    Joined:
    Feb 16, 2009
    #1
    Hey guys, I've installed Windows 7 64bit on my Unibody Macbook. Everything runs fine, well if you can call the dodgy trackpad drivers 'fine.' But, thats besides the point, my problem is that the last two bars of the brightness control (pressing F1) does absolutely nothing.

    In OSX having no bars in the brightness level means the backlight is off but this is not possible in Windows 7 (64bit or 32bit, I tried both). The actual brightness remains at the same level as if it was at two bars when you've decreased the brightness level to one or zero bars.

    The brightness decreases from full brightness as you reduce the number of bars but stops at the last two. I hope people will understand what I'm saying, anyone else have this problem?
     
  2. EOC macrumors newbie

    Joined:
    Aug 14, 2009
    #2
    You may want to reinstall the bootcamp drivers. That shouldn't be a problem.
     
  3. daisun thread starter macrumors newbie

    Joined:
    Feb 16, 2009
    #3
    Just tried reinstalling bootcamp. The problem is still here. I guess it isn't that big of a issue. So only I have this problem? bummer. I did a clean install of Windows 7 twice and both time it had the same problem. Guess I'll just have to live with it. :(
     
  4. Stridder44 macrumors 68040

    Stridder44

    Joined:
    Mar 24, 2003
    Location:
    California
    #4

    This has been a problem since Boot Camp 2.0 came into existence. Doesn't matter which OS (7, Vista, XP) it can happen in any of them. I can only assume it's a software bug. Apple's really the one to blame for their crap drivers.
     
  5. daisun thread starter macrumors newbie

    Joined:
    Feb 16, 2009
    #5
    In case anyone is experiencing the same problem I've fixed it! Just goto nvidia's website and download the latest driver for 9400M. All brightness bars work as they should now! :cool:
     
  6. kate-willbury macrumors 6502a

    Joined:
    Feb 14, 2009
    #6
    honestly! the trackpad drivers are absolutely atrocious. i turned on the touch tap option in bootcamp and thought i'd jump for joy. but dear lord the thing is so ridiculously buggy and awkward to actually use in win7. complete fail of a driver on apples part.
     
  7. salmonofdoubt macrumors newbie

    Joined:
    Dec 7, 2009
    #7
    Lucky you have a nvidia card. I'm on a 2007 MacPro with the ATI X1900. Is anyone aware of a similar fix? Unfortunately, the boot camp control panel does not have a brightness tab. I'm also using the old, clear plastic 23" cinema display, which doesn't have physical controls.
     
  8. Stridder44 macrumors 68040

    Stridder44

    Joined:
    Mar 24, 2003
    Location:
    California
    #8
    Hm, not quite. I also have an Nvidia card and still have this issue (yes, using the latest driver of course).
     
  9. salmonofdoubt macrumors newbie

    Joined:
    Dec 7, 2009
    #9
    So you're using an apple cinema display with the ADC->DVI converter? I found a fix after some extensive searching which fixed mine:

    In OSX, set the brightness the way you want it and shut down. Unplug the USB from the converter box and start windows, it should be bright. Sadly this means you'll lose those usb ports on your monitor, but for me it's totally worth it.
     

Share This Page