Brightness Control not working on iMac12,2

Discussion in 'Windows, Linux & Others on the Mac' started by unionaire, Jan 20, 2012.

  1. unionaire, Jan 20, 2012
    Last edited: Jan 20, 2012

    unionaire macrumors newbie

    Joined:
    Jan 19, 2012
    #1
    Hi all, I just got an iMac12,2 (27inch 813) yesterday and the 64 bit installed fine under bootcamp mode (BIOS emulation), but no brightness control.

    Searched the forum a bit, and a lot of people under windows 7 x64 has the same problem whereas windows 7 32bit works fine. So I went back to the windows 7 32bit, but again, the brightness control does not work under Windows 7.

    It's not an issue of power because it's an iMac, it's just that the screen is too bright that hurts my eyes, so I really need to take care of this.

    Some say it's the videocard driver problem, but I was unable to find a driver for this, the Video card is ATI 6770M.

    Okay it's the Apple Driver problem. Uninstalled the ATI driver from bootcamp package and the brightness control works like a charm, except now I am without a proper video driver that would allow me to run at least at the system's native resolution.

    So please someone help find get the ATI standard driver to install because the other methods I learned does not work on my latest 6770M video card.

    Thanks in advance!
     
  2. unionaire thread starter macrumors newbie

    Joined:
    Jan 19, 2012
    #2
    Problem solved (partially)

    There's 361 viewings of this post and seems like no one has an answer.

    Fortunately I was lucky enough to find a temporary solution for this.

    I've heard people with Nvidia cards has the same problem, but to my specific problem, I am running the following Radeon driver:
    Radeon driver 8.812.0.0 dated Jan 04, 2011 (seriously Apple needs to update this).

    The problem happens to Windows 7 x86 and x64 SP1 (not sure if it it causing problem for non-SP1 OS).

    To solve this problem, the easiest way would be to uninstall the driver, and manually install again from the bootcamp driver package.

    An easy way to remove the driver by using Driver Sweeper:
    http://phyxion.net/item/driver-sweeper.html

    After removed the Ati (now AMD) driver completely, restart the computer and you will find that your brightness works again, and now navigate to the bootcamp driver folder (doesn't matter if it is 4.0 or 3.2 because the driver version for both Bootcamp packages is the same). Double click to install the driver normally and restart, and your brightness control works again.

    P.S. Some said that the Bootcamp designated boot function will cause this problem, I have yet to test this myself but if this happens to be the case for you, you know what to do.:cool:
     

Share This Page