Brightness problem in bootcamp! please help!

Discussion in 'Windows, Linux & Others on the Mac' started by yoshisx, Feb 23, 2009.

  1. yoshisx macrumors newbie

    Joined:
    Feb 23, 2009
    #1
    Hi guys, I have recently bought a new macbook pro early 2008 and have installed bootcamp on it to play games.

    I have noticed that with the stock nvidia drivers that came with the bootcamp cd, I was able to set my screen brightness at a pre-determined level once and for all without adjustment.

    However, with that stock drivers, I have gotten a few BSOD while playing DotA, so I have updated my drivers to the latest nvidia beta laptop drivers, that made the brightness issue pop up.

    Now whenever I switch on my mbp, I would have to go and set the brightness of my screen to my desired level EVERY SINGLE TIME, if not it would be turned back to maximum contrast every time I opened a single window. Now this pisses me off a lot as I game a lot.

    Any of you guys have the solution to my problem?

    I would greatly appreciate all of your inputs!
     
  2. yoshisx thread starter macrumors newbie

    Joined:
    Feb 23, 2009
  3. alphaod macrumors Core

    alphaod

    Joined:
    Feb 9, 2008
    Location:
    NYC
    #3
    Does any of the games you play have a setting to change the brightness as well?

    Also I don't think you can adjust contrast, only brightness unless this an external monitor we're talking about.
     
  4. yoshisx thread starter macrumors newbie

    Joined:
    Feb 23, 2009
    #4
    I am playing dota most of the time, the setting inside is not related to the brightness issue that I am having outside, it just frustrates me that every single time I boot to my windows partition, I have to reset the brightness, if not it would be at maximum.

    I am running the latest nvidia laptop drivers on my early 2008 mbp..

    this is driving me crazy lol :mad:
     
  5. xyglyx macrumors newbie

    Joined:
    Oct 13, 2009
    #5
    Are you using Windows 7? I had the same problem where I had made adjustments to the Nvidia desktop color settings, but when I rebooted, Windows 7 would revert to its default color settings. I solved the problem by disabling Windows display calibration. Here's how you do that:

    1. Run colorcpl.exe to open the Color Management window.
    2. Click the Advanced tab.
    3. Click the "Change system defaults" button at the bottom.
    4. Click the Advanced tab again.
    5. Uncheck the "Use Windows display calibration" checkbox.
    6. Close both windows.
    Now you can adjust your Nvidia desktop color settings again and they will stick the next time you reboot.
     

Share This Page