Become a MacRumors Supporter for $25/year with no ads, private forums, and more!
  • Did you order new AirTags? We've opened a dedicated AirTags forum.

TheLondoner

macrumors newbie
Original poster
May 24, 2011
15
0
sdf
I spent 3 years trying to get my computer to stop AmericaniZing everything. It nearly drove me crazy, but today I found a way to get it to UK English and thought I'd share it with everyone to save you the suffering! This works for my MacbookPro on OS X Leopard. Should work for everyone with this OS in the least. :)

Do the following:

1) Go to TextEdit->Spelling & Grammar -> Show Spelling and Grammar - > Scroll to British English in the option at the bottom. Then close it!

You can check it in MS Word and mail and it should be fine.

2) Go to System Preferences -> International->Language tab (should be on this by default) ->Edit List-> Tick the British English option -> Click OK. Then move British English to the top of the list on the left and remove the normal "English" option to be safe.

It will prompt you to log out and in again.

You are done!

Congratulations on converting to PROPER English, not this American crap with 'color' and 'americanize' and 'realize' and all the other crap spellings they have over the pond that drive us Brits ape ****, haha!

If anyone has any tips on how to add a 'British English Dictionary' instead of the default 'American Dictionary' in the application folder, please share your tips here.

Original source of tips: https://forums.macrumors.com/threads/569225/
 
Last edited:

sim667

macrumors 65816
Dec 7, 2010
1,375
2,884
I spent 3 years trying to get my computer to stop AmericaniZing everything. It nearly drove me crazy, but today I found a way to get it to UK English and thought I'd share it with everything to save you the suffering! This works for MacbookPro on OS X. Should work for everyone with this OS in the least. :)

Do the following:

1) Go to TextEdit->Spelling & Grammar -> Show Spelling and Grammar - > Scroll to British English in the option at the bottom. Then close it!

You can check it in MS Word and mail and it should be fine.

2) Go to System Preferences -> International->Language tab (should be on this by default) ->Edit List-> Tick the British English option -> Click OK. Then move British English to the top of the list on the left and remove the normal "English" option to be safe.

It will prompt you to log out and in again.

You are done!

Congratulations on passing converting to PROPER English, not this American crap with 'color' and 'americanize' and realize and all the other crap spellings they have over the pond that drive us Brits ape ****, haha!

If anyone has any tips on how to add a 'British English Dictionary' instead of the default 'American Dictionary' in the application folder, please share your tips here.

Original source of tips: https://forums.macrumors.com/threads/569225/

You've been able to do that for ages and ages, its hardly a closely guarded secret ;)
 
Comment

TheLondoner

macrumors newbie
Original poster
May 24, 2011
15
0
sdf
You've been able to do that for ages and ages, its hardly a closely guarded secret ;)

Maybe but before today i've never been able to find it (took 3 years!) :D. Hopefully with one more thread on it - less people will have to suffer with american spellings :).
 
Comment

TheSoutherner

macrumors newbie
Aug 17, 2011
1
0
British UK English dictionary on Mac OS Leopard

Thanks to you Londoner I will never again be bothered by American English corrections when I fraternise, visualise, vocalise and so on.

Perhaps you can help with an unrelated problem.

When Thunderbird is included as a login item (System Preferences/Accounts/login items) it ignores the 'Hide' command and so opens the message window even though it should remain active but unopened in the Dock.

It is a small problem but like American English and irritant no less.
 
Comment

les24preludes

macrumors member
Feb 6, 2011
99
4
I'm just updating this thread. I have the same problem - can't get spellcheck in UK English. I checked UK English as default language and relaunched word, also highlighted the text and applied UK English. No dice.

I suspect I don't have the UK English dictionary loaded. How can I check this and if needed download it?

Andy
 
Comment
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.