Broke my installer =(

Discussion in 'iPod touch Hacks' started by cjd82187, Feb 21, 2008.

  1. cjd82187 macrumors member

    Joined:
    Oct 19, 2007
    #1
    Ok, Here's my situation:
    I have 16GB touch, 1.1.3 Dev Team Jailbreak. Was working great, have summerbord, terminal, VoIP and other things all working great. Just started learning Python in class today so I figured I would install Python on the touch.

    It started to download and I got the You are running out of space message, but it continued to Download. Once, it finished downloading, installer crashed. Now, at this point, I am not positive that installer still worked (It opened up and refreshed sources, but I didnt try to install/delete anything)

    Since I wanted Python, I made a symlink for Applications and moved to /private/var/Applications. I did it while SSH to the touch from my Mac and everything was fine. Then I tried installer and whenever I tried to install/uninstall anything it gave a "Main Script Execution Error". I thought this was maybe because the symlink, so I removed the link and put everything back to /Applications.

    Now that everything is back in applications, I still have the same problem. I made sure permissions were 755 for all of Installer.app and its contents too.
    I even replaced Installer.app with a different one and still no luck.

    My questions are:
    1) Where did the Python installation file (its 5.6MB i think) go on my touch so I can delete it

    2) Is there a file somewhere that tells Installer that my diskspace is used up and it should not install anything else,

    and 3) if there is a file telling installer that my disk is full, will it throw that Main Execution Script Failure as a way of saying it does not want to install anything?
     
  2. cjd82187 thread starter macrumors member

    Joined:
    Oct 19, 2007
    #2
    Ok, well I did a lot of deleting and reinstalling of installer from instructions on the iPodtouchfans website, but still having no luck. I did find out that Python actually did install, I assumed it was going to give me a ported version of IDLE, but it just installed it so I can run it through terminal which is cool.

    Anyone know if having Python breaks installer in 1.1.3?
     

Share This Page