Broken Drag & Drop in Finder

Discussion in 'Mac OS X Lion (10.7)' started by RexLeo, Jul 20, 2011.

  1. RexLeo, Jul 20, 2011
    Last edited: Jul 20, 2011

    RexLeo macrumors newbie

    Joined:
    Jul 20, 2011
    Location:
    Stuttgart, Germany
    #1
    I select files, click and hold the touchpad to move them to another folder, then I release the touchpad button and the files keep sticking to the mouse pointer. Usually I have to force quit Finder to get rid of the sticky items and this also breaks some keyboard functionality and I can no longer enter any text using the keyboard (play/pause button still works for iTunes and I can adjust volume and brightness). Then I have to reboot for things to get back to normal. This is really annoying. Finder without drag & drop is pretty much useless.
    Anyone has this problem?

    Someone recorded the problem and posted it on youtube:
    http://www.youtube.com/watch?v=vFeIuwxm8tE

    EDIT: Just tried it again. It's not only within the Finder App but also concerns the Desktop, Mail etc.


    MacBookPro5,1
    Intel Core 2 Duo 2,53 GHz
     
  2. tidalwav1 macrumors newbie

    Joined:
    Aug 7, 2010
    #2
    I came here to post this exact same incredibly annoying issue that showed up after installing Lion.

    Also happens when trying to remove things from the Dock...the Dock icons just stick to the cursor.

    Have to do a 'killall Finder' in Terminal to 'unstick' icons from the cursor.

    I tried deleting com.apple.finder.plist, com.apple.systemuiserver.plist, com.apple.loginwindow.plist, and com.apple.driver.AppleBluetoothMultitouch.trackpad.plist and then restarting, none of this had any effect.

    I noticed that while icons are stuck to the cursor, CPU usage spikes. The processes that seem to increase in CPU usage while the icons are stuck are finder, systemuiserver, helpd, hiutil.

    I'm using iStat Menus and TotalFinder, but this software hasn't caused the same issue on two other Lion machines.

    Anybody have any ideas? This makes the computer more or less unusable.

    MacBook Pro 5,3.
     
  3. rmwebs macrumors 68040

    Joined:
    Apr 6, 2007
    #3
    I experienced a similar problem when uploading a screenshot in another thread.

    I pressed attach, which popped open a finder window as you would expect. I went to drag the image from my desktop into the window, and it didn't recognise it at all.
     
  4. Starfyre macrumors 68030

    Starfyre

    Joined:
    Nov 7, 2010
    #4
    I had the same problem too! It was annoying.... I just burned Lion to DVD, formatted HD, and did a clean install. Got rid of the problems.
     
  5. tidalwav1 macrumors newbie

    Joined:
    Aug 7, 2010
    #5
    I haven't quite resorted to re-installing yet.

    I noticed that when the problem occurs, locking the screen with CTRL-SHIFT-EJECT, then waking and authenticating makes Finder behave normally again.

    Rather than reinstalling will just try creating a new user account first.
     
  6. eike macrumors newbie

    Joined:
    Jul 21, 2011
    #6
    Kernel-Extensions

    Try to delete/move some old Kernel-Extensions.
    I had the same issues, it turned out Displaypad was the reason.

    There are two files under /System/Library/Extensions :
    DisplayPadDriver.kext
    DisplayPadFrameBuffer.kext

    Delete them!
     
  7. tidalwav1 macrumors newbie

    Joined:
    Aug 7, 2010
    #7
    I ended up re-installing before seeing this post. :p

    Creating a new user account didn't solve anything, which would make sense if the root cause was old kernel extensions.

    After Googling for "Lion DisaplyPadDriver.kext", I found this extremely helpful and relevant thread:

    https://discussions.apple.com/thread/3191768?start=0&tstart=0

    The root cause in my case was almost certainly an old DisplayLink (external video card) driver that I had installed for an external USB video card.

    I wish I had known all of this before re-installing. :p
     
  8. RexLeo thread starter macrumors newbie

    Joined:
    Jul 20, 2011
    Location:
    Stuttgart, Germany
    #8
    Cool. Thank you so much for this hint. I wasn't able to find any DisplayPad drivers. However, the iScreen app was causing the trouble. I downloaded the uninstall script and after rebooting I can drag n drop again :)
     

Share This Page