Broken drive & corrupted Time Machine Backup

Discussion in 'macOS' started by richardb, Feb 6, 2010.

  1. richardb macrumors newbie

    Joined:
    Nov 24, 2007
    #1
    Hi all, I am having some problems with my MacBook Pro, a rather veteran 2.33GHz Core 2 Duo model running 10.6. Well, sort of, if I may explain.

    I've replaced the internal hard drive on this previously, but that drive appears to have died. I've tried taking it out and installing it in an external drive case, but It doesn't respond when plugged in, and Disk Utility and Disk Warrior don't detect it. So the drive seems to be beyond repair.

    No problem, I thought: I use a NAS as a TimeMachine backup drive. However, when I tried recovering this (after installing a new hard drive), it told me that there were no backups on this volume. If I look in the volume itself, I can see a folder called backups.backupdb, and within this is a folder called richardb's Computer. Within this is a file called 2010-01-03-085237.inProgress, which I assume is the backup file.


    Does the inProgress suffix mean that the computer was being backed up when the drive died?

    Is there any way I can recover this backup?
     
  2. cxc macrumors member

    Joined:
    Nov 30, 2007
    Location:
    Cologne, Germany
    #2
    Hi,

    can you show package contents?
     
  3. r0k macrumors 68040

    r0k

    Joined:
    Mar 3, 2008
    Location:
    Detroit
    #3
    Corrupted destination volume is all too common for Time Machine backups. It happens most often when backing up over the network, especially wireless. An inprogress file may mean something. More often it's just a nuisance. Try opening the sparsebundle with disk utility and repair it. Hopefully it will succeed. Another option is to show package contents and copy the files out that are able to be copied. I know that the last time I called Apple about a corrupted sparsebundle, after spending hours meddling with an attempted repair in disk utility, they suggested I delete it and start over if I was tired of waiting.
     
  4. satcomer macrumors 603

    satcomer

    Joined:
    Feb 19, 2008
    Location:
    The Finger Lakes Region
    #4
    I found if (when you have the Time Machine disk mounted) you launch /Applications/Utilities/Disk Utility and 'Repair Permissions' on the Time machine portion of that drive usually fixes problems.
     

Share This Page