Broken MacBook?

Discussion in 'MacBook' started by supradave, Feb 15, 2009.

  1. supradave macrumors newbie

    Joined:
    Feb 15, 2009
    #1
    I recently upgraded to 2GB and an WD Scorpio (Blue label) 320GB hard drive. It worked for a few days and now has a very hard time booting. Most of the time, it will give me the message that I need to hold down the button and power off and power back on. I do and sometimes it works. It works fine until I shut the lid or it goes into sleep mode on its own. A few days after making this upgrade though, my kids knocked it on the floor from the bed, about desk height.

    I have tried booting from the CD/DVD and get the same results.

    Any ideas on what the problem could be other than it being broken?

    Thanks,
    Dave
     
  2. PeterQC macrumors 6502a

    PeterQC

    Joined:
    Jun 30, 2008
    #2
    My opinion is that it's broken. Sorry, but the fall could have compromised your HDD, and it's why your getting these Kernel Panics, IMO.
     
  3. NewMacbookPlz macrumors 68040

    NewMacbookPlz

    Joined:
    Sep 28, 2008
    #3
    It'd be might coincidental if the fall didn't have anything to do with the disk failure. I'd bet that the disk is shot due to the fall. If you want to check the idea, re-install your original HDD, (assuming it didn't die, and was just replaced for more room) and see what happens.
     
  4. MattyK macrumors 6502a

    MattyK

    #4
    Your computer isn't broken, Your hard drives critical files are corrupted.
    The error message your receiving should look something like this, yes?

    [​IMG]

    If so, that means a kernel extension, an important file if the right one is missing; is missing. If you can boot from the retail disc at all, I would repair permissions AND if necessary repair the disk.

    If that doesn't work, send it into apple and see if they can do a fix, or even replace the HD.
     
  5. nufanec macrumors regular

    Joined:
    Sep 10, 2005
    #5
    Actually a Kernel Panic means that the system has has a fatal error it can't recover from - this can be either software or hardware in origin. Since the OP has already tried booting from the install disk and gets the same error, it is safe to say that the issue is hardware, not software.

    There are a couple of simple things you can try. I have found that when performing RAM upgrades, many people are hesitant to insert the RAM modules with enough pressure to seat them correctly. The machine may work fine like this but if it has a bump or drop like in your case, the RAM modules can come loose/not make a good contact causing the memory not to be recognised or produce errors such as a Kernel Panic. Try removing the RAM sticks and re-seating them. Make sure they are fully inserted - you should feel them pop into place when correctly installed. If it does the same after that, then try using the original memory that came with the computer.

    At the same time you can try re-seating the hard drive or, again, reinstalling the original drive.

    By doing this you can pretty much rule out the RAM and the hard drive being the issue. If it still does the same thing at this point, then the drop may have caused damage to some of the other internal components. At this point, a trip to an Apple store would be your best bet.
     
  6. RedTomato macrumors 68040

    RedTomato

    Joined:
    Mar 4, 2005
    Location:
    .. London ..
    #6
    Agree re RAM. RAM can be the cause all sorts of strange errors. Try removing one RAM stick at a time, and seeing if it runs fine. (Or reinstalling the original RAM)

    But its highly likely the fall affected it. Especially if it was running an application with the screen open.

    BTW shouldn't the HD have detected a fall and parked itself - I thought that was what the motion sensor was for?
     
  7. MattyK macrumors 6502a

    MattyK

    #7
    May be true, but the last time I had a kernel panic one of my kernels were missing..
     
  8. aluminumapple macrumors regular

    Joined:
    Jan 7, 2009
    #8
    at your own risk or if you feel that there is one missing repair it or do a zero all reset wipe and re install everything.
     
  9. supradave thread starter macrumors newbie

    Joined:
    Feb 15, 2009
    #9
    A little more information

    I took out the new stuff and put in the old and got the same results.

    I seem to be able to boot from the cd/dvd now, but now when I try to boot directly from the drive, it fails much faster. Before, it would chime and sit at the white screen without the apple logo for 30 seconds, then the apple logo would appear, sit for a few more seconds and vomit. Now, it chimes and goes right to the logo and crashes.

    When booted from the installation media or the Leopard media, I have run the Verify Disk from the Disk Utility and all seems happy. I then go and Quit the Installation session from the Apple menu and it reboots fine.

    Once it boots, everything is fine, except when it goes to sleep, or the lid shuts. I'm not saying there's not some damage somewhere, but it operates normally once it's running and not sleeping. Also, when it comes back out of sleep mode, the mouse moves briefly, then stops responding.

    Is there any way to get to the EFI prompt? If there is, perhaps I can see what's going on through the EFI. (I have experience with EFI on HP servers, so not something I'm afraid of).

    Thanks,
    Dave

    I'm going to have to take it in most likely.
     
  10. Stachelsk macrumors regular

    Joined:
    Dec 17, 2008
    #10
    Press Apple + V on startup to enable verbose mode on boot.
     
  11. supradave thread starter macrumors newbie

    Joined:
    Feb 15, 2009
    #11
    Resolved (Solved)

    It appears that it was the permissions. I went through the list and there were only a couple files that were not under /Applications/Address.book or similar. But whatever it was has been resolved.

    Thanks for all the suggestions.
    Dave
     

Share This Page