Broken Mighty Mouse... huh?

Discussion in 'Mac Accessories' started by Crash1234, Jan 21, 2009.

  1. Crash1234 macrumors regular

    Joined:
    Oct 22, 2008
    #1
    I'm using the bluetooth mighty mouse with my mbp and all of a sudden, like literally five minutes ago, the thing just stopped working. The mouse still works in that I can move the mouse around the screen with it, but clicing is not registered/recognized, nor is scrolling of any kind, or things like opening the dash board or expose. I'm kind of confused. Has anyone heard of anthing like this where the mouse can still be used to move around the screen but cannot click or do any other functions? I tried removing it from the blue tooth menu or whatever that's called and then setting it up again, but still no dice. Is there any way to fix this? Is this a problem with the mouse or is there something funky wrong with my computer or blue tooth?
     
  2. GGJstudios macrumors Westmere

    GGJstudios

    Joined:
    May 16, 2008
    #2
    Did you check the batteries? The buttons go first when a battery is dying.
     
  3. Macman756 macrumors 6502a

    Macman756

    Joined:
    Sep 24, 2008
    Location:
    Atlanta, GA
    #3
    Wow, Mine went dead today too. Same thing, the cursor moves but no mouse clicking. It happens alot to me, what I do is turn off the mouse, grab my USB mouse, hit Restart, the as soon as it Chimes, turn on the mouse. When it starts up, all is well. Try that, But I doubt Batteries, it will bug the crap outta you when the are even close to low.
     

Share This Page