Browse TimeMachine backup from mavericks on Catalina

avatarbe

macrumors newbie
Original poster
May 27, 2009
25
1
Hi,

Today, I finally upgraded my system to Catalina. I was on Mavericks before, and just didn't need to upgrade until now.
Off-course I did a full TM backup first, and then did a complete clean install.

Now I want to browse my TM backup, to see if there are any files i need to restore, but I don't know how i have to do this.
The backup is on a synology NAS. If I select the same disk in TimeMachine, I would expect to be able to go back in time, but i can't. Also with the migration assistant, i'm not able to see the backup.
Choosing 'Browse other backup disks' in timemachine is not working.

Anyone who knows how to browse the backup and select some files to restore? I'm not really interested in keeping the backup history, i just want some files from my latest backup.

Thanks for all the help!

Ben
 

bhtwo

macrumors 6502a
Dec 31, 2012
890
534
Oxford UK
Hmm... that's odd

I can browse all my Yosemite backups just fine... they're on an external which shows in finder.
 

gilby101

macrumors regular
Mar 17, 2010
230
90
Tasmania
The backup is on a synology NAS
With a NAS, TM backups are stored inside a sparse bundle disk image. Different to a directly attached disk.

There are reports of the Catalina upgrade making changes to the sparse bundle on the first backup with Catalina. So I am not too surprised you are having problems.

The solution is to make sure that Catalina makes its first backup to a new sparse bundle. A bit late now. :mad:

But: Try mounting the sparse bundle in Finder. Have a look what is inside - you may be able to rescue what you want.
 

avatarbe

macrumors newbie
Original poster
May 27, 2009
25
1
I don't think Catalina did change the bundle, as I didn't enable TM yet.
I tried to mount the sparse bundle in Finder, but then I get a warning 'No mountable file system'.

I did try again to copy over everything with the Migration Assistant, and for some reason now this works. It will take 20 hours to copy over everything, so I think I will try this on my laptop.
I will post back with the result.
 

AppleSmack

macrumors regular
Jun 30, 2010
148
45
I don't think Catalina did change the bundle, as I didn't enable TM yet.
I tried to mount the sparse bundle in Finder, but then I get a warning 'No mountable file system'.

I did try again to copy over everything with the Migration Assistant, and for some reason now this works. It will take 20 hours to copy over everything, so I think I will try this on my laptop.
I will post back with the result.
Did it work?