Browser fonts distorted, messed up in all web browsers.

Discussion in 'macOS' started by Schizm00, Aug 5, 2008.

  1. Schizm00 macrumors newbie

    Joined:
    Jun 11, 2008
    #1
    Last night for no good reason, I suddenly noticed fonts on CERTAIN websites were distorted.

    For instance, I have attached 2 pictures. The strange fonts show up on:

    Google Searches
    Ask Jeeves
    Yahoo
    Msnbc
    Foxnews

    It does this in both Firefox and Safari.

    I am using a Macbook running OSX 10.5.4 and Firefox 3.0.1

    I have reinstalled Firefox and same thing happens. Again, no matter, as it does the same thing in Safari.

    Any help?

    P.S. The @ symbol doesn't show up sometimes, and it also seems that and bold text is not affected, and looks normal.
     

    Attached Files:

  2. clevin macrumors G3

    clevin

    Joined:
    Aug 6, 2006
    #2
    did you install any fonts lately? or office 2008?

    they might be the problem, i dont remember solution tho, do some search maybe..
     
  3. Schizm00 thread starter macrumors newbie

    Joined:
    Jun 11, 2008
    #3
    Yes.

    Yes I did install a ton of fonts yesterday. Dammit. Like 1600 of them too.

    Son ofa b................
     
  4. qwik3r macrumors newbie

    Joined:
    Jul 13, 2008
    #4
    Did you resolve this? The same thing happened to me, I installed like 3,000 fonts I can't figure whats doing it. This ish doesn't occur on windows, wtf. Please let me know what you did to fix it.
     
  5. ivnds macrumors 6502

    ivnds

    Joined:
    Aug 6, 2006
    #5
    I've had this issue too, after installing some fonts, firefox and safari started displaying all pages in a rockish prehistoric font. Searched around, and read that you can check the Web fonts section in fontbook, look for any weird fonts, in case the font was there, remove it from that group and reboot.

    That didn't work for me, but it's worked for others. I had to reinstall leopard to get rid of it. Hope this helps in your case.
     
  6. Schizm00 thread starter macrumors newbie

    Joined:
    Jun 11, 2008
    #6
    I figured it out.

    I did figure it out. After installing all of those fonts, for some strange reason, CERTAIN fonts overtook default fonts in the browsers. No idea why. So here is what I did:

    (This example is for Firefox, but the process should pertain to all browsers)

    Look at the font in question, and on your Mac, go to Applications>Font Book

    On the left should be some font types like "Fixed Width" or "Fun", etc....

    I went through those and found the ones that were messed up. I can't remember the names though, wish could. I think one was like called Metallica or something.

    When you locate the font, delete ALL INSTANCES OF THIS FONT FROM YOUR MAC. Go to Spotlight to double check too after doing so.

    If you did this right, refresh your browser and you should not see any font at all where there used to be. Don't panic, just reinstall Firefox and it will replace the default font.
     
  7. yoshinatsu macrumors member

    Joined:
    Oct 17, 2007
    Location:
    Downtown Jigoku
    #7
    Phew... Thank goodness I found your thread...
    For me, it was the Metallica one. Occured after installing some thousands of fonts XD
    Thank you very much for your help!
     
  8. sharkethic86 macrumors newbie

    Joined:
    Sep 9, 2009
    #8
    i'm having font issues after last night's update as well but i have not installed any new fonts lately. no matter what browser i use, the fonts look like my attached picture.
     

    Attached Files:

  9. calderone macrumors 68040

    calderone

    Joined:
    Aug 28, 2009
    Location:
    Seattle
    #9
    While you may not have installed fonts, something else that you installed may have installed fonts.

    The default font for many browsers is Times. You may have a font in your home folder conflicting (~/Library/Fonts).

    Also, considering checking the preferences for your browsers:

    Safari: Preferences > Appearance tab
    Firefox: Preferences > Content tab
     
  10. sharkethic86 macrumors newbie

    Joined:
    Sep 9, 2009
    #10
    the only thing that was installed was a system update. i checked my default settings in safari and even switched it off of times and then back to it, didn't change anything. even did a full reset of safari. i'll try looking through the library but i can't seem to figure it out so far
     
  11. sharkethic86 macrumors newbie

    Joined:
    Sep 9, 2009
    #11
    ok well i fixed it.. for some reason after the system update all my fonts from ~/Library/Fonts were moved to a folder in Library called 'Fonts Disabled' so i just copied and pasted them back in and problem was resolved.
     
  12. galstaph macrumors 6502a

    galstaph

    Joined:
    Jul 24, 2002
    Location:
    The Great White North Eh
    #12
    just had this issue as well... appears arial was replaced with an off font
     
  13. jabrenna macrumors newbie

    Joined:
    Apr 21, 2015
    #13
    Open Sans Condensed

    Thanks for the advice - fortunately I only installed one font before I noticed the problem and could remember the name: 'Open Sans Condensed'.
    I went to Font Book and deleted all versions by using 'Reveal in Finder' and sending them to trash. Created this account just so I could post this reply, hope it is of benefit to someone...
     

Share This Page