Browsers & Downloads suddenly grind to a halt!

squonk2

macrumors newbie
Original poster
Dec 5, 2014
10
0
Hi:

I'm an infrequent user of the forums. I appreciate any guidance.

I have a Macbook Pro 11,2 running Sierra OSX 10.12.6. SSD hard drive installed by OWC with 16GB RAM. I purchased the machine used from OWC in February and have had NO issues. All has ben performing beautifully. However, late last week everything has ground to a halt. Browsers (Firefox and Safari) take 30sec to 1 minute or more to load a simple webpage. Download of 49MB took more than 10 mins. Home network appears fine as other Macs and devices in the house have no such issues. Took me 20 minutes to download Etrecheck from the App Store. Most other functions on the computer seem to be ok, or at least nothing as noticeable.

I ran Malwarebytes and came up clean.

Here's the Etrecheck report:

EtreCheck version: 5.2 (5029)

Report generated: 2019-06-18 09:33:58

Download EtreCheck from https://etrecheck.com

Runtime: 1:25

Performance: Excellent

Sandbox: Enabled

Full drive access: Disabled


Problem: Computer is too slow

Description:

browsers, downloads are all very slow


Major Issues: None


Minor Issues:

These issues do not need immediate attention but they may indicate future problems or opportunities for improvement.


Unsigned files - There are unsigned software files installed. They appear to be legitimate but should be reviewed.

32-bit Apps - This machine has 32-bits apps will not work after macOS 10.14 “Mojave”.

Limited drive access - More information may be available with Full Drive Access.


Hardware Information:

MacBook Pro (Retina, 15-inch, Mid 2014)

MacBook Pro Model: MacBookPro11,2

1 2.2 GHz Intel Core i7 (i7-4770HQ) CPU: 4-core

16 GB RAM - Not upgradeable

BANK 0/DIMM0 - 8 GB DDR3 1600 ok

BANK 1/DIMM0 - 8 GB DDR3 1600 ok

Battery: Health = Normal - Cycle count = 184


Video Information:

Intel Iris Pro - VRAM: 1536 MB

Color LCD 2880 x 1800


Drives:

disk0 - APPLE SSD SM1024G 1.00 TB (Solid State - TRIM: Yes)

Internal PCI 5.0 GT/s x4 Serial ATA

disk0s1 - EFI (MS-DOS FAT32) [EFI] 210 MB

disk0s2 - Macintosh HD (Journaled HFS+) 999.56 GB (350.96 GB used)

disk0s3 - Recovery HD (Journaled HFS+) [Recovery] 650 MB


Mounted Volumes:

disk0s2 - Macintosh HD 999.56 GB (648.34 GB free)

Journaled HFS+

Mount point: /


Network:

Interface fw0: Thunderbolt FireWire

Interface en4: iPhone

Interface en0: Wi-Fi

802.11 a/b/g/n/ac

Interface en3: Bluetooth PAN

Interface bridge0: Thunderbolt Bridge


System Software:

macOS Sierra 10.12.6 (16G1815)

Time since boot: Less than an hour


Notifications:

Notifications not available without Full Drive Access.


Security:

Gatekeeper: Enabled

System Integrity Protection: Enabled


Antivirus apps: MalwareBytes


Unsigned Files:

Launchd: ~/Library/LaunchAgents/com.apple.MobileMeSyncClientAgent.plist

Executable: /System/Library/PrivateFrameworks/DotMacSyncManager.framework/Resources/mobilemesyncclient --sync --periodic

Details: Exact match found in the whitelist - probably OK


Launchd: ~/Library/LaunchAgents/com.apple.SafariBookmarksSyncer.plist

Executable: /Applications/Safari.app/Contents/SafariSyncClient.app/Contents/MacOS/SafariSyncClient --sync com.apple.Safari --entitynames com.apple.bookmarks.Bookmark,com.apple.bookmarks.Folder

Details: Exact match found in the whitelist - probably OK


Launchd: ~/Library/LaunchAgents/com.adobe.ARM.***.plist

Executable: /Applications/Adobe Reader 9/Adobe Reader.app/Contents/MacOS/Updater/Adobe Reader Updater Helper.app/Contents/MacOS/Adobe Reader Updater Helper

Details: Close match found in the whitelist - probably OK


32-bit Applications:

53 32-bit apps


Kernel Extensions:

/Applications/Toast 10 Titanium/Toast Titanium.app

RoxioBluRaySupport.kext (1.1.6)

TDIXController.kext (2.0)


/Applications/Webroot SecureAnywhere.app

SecureAnywhere_signed.kext (Webroot Software, Inc., 8.0.7 - SDK 10.9)


/System/Library/Extensions

WD1394HPDriver.kext (1.0.7)

WDUSBHPDriver.kext (1.0.5)


Startup Items:

Qmaster Path: /Library/StartupItems/Qmaster


System Launch Agents:

[Not Loaded] 14 Apple tasks

[Loaded] 174 Apple tasks

[Running] 98 Apple tasks


System Launch Daemons:

[Not Loaded] 42 Apple tasks

[Loaded] 179 Apple tasks

[Running] 97 Apple tasks

[Other] 2 Apple tasks


Launch Agents:

[Running] com.malwarebytes.mbam.frontend.agent.plist (Malwarebytes Corporation - installed 2019-05-10)

[Not Loaded] com.teamviewer.teamviewer.plist (TeamViewer GmbH - installed 2019-01-15)

[Not Loaded] com.teamviewer.teamviewer_desktop.plist (TeamViewer GmbH - installed 2019-01-15)


Launch Daemons:

[Loaded] com.adobe.fpsaud.plist (Adobe Systems, Inc. - installed 2019-05-26)

[Running] com.malwarebytes.mbam.rtprotection.daemon.plist (Malwarebytes Corporation - installed 2019-06-18)

[Running] com.malwarebytes.mbam.settings.daemon.plist (Malwarebytes Corporation - installed 2019-05-10)

[Loaded] com.teamviewer.Helper.plist (TeamViewer GmbH - installed 2019-01-15)

[Not Loaded] com.teamviewer.teamviewer_service.plist (TeamViewer GmbH - installed 2019-01-15)


User Launch Agents:

[Loaded] com.adobe.ARM.***.plist (? 0 - installed 2009-11-15)

[Loaded] com.apple.MobileMeSyncClientAgent.plist (? 0 - installed 2013-08-25)

[Loaded] com.apple.SafariBookmarksSyncer.plist (? 0 - installed 2008-12-19)


Internet Plug-ins:

Flip4Mac WMV Plugin: 2.4.4.2 (? - installed 2013-01-11)

FlashPlayer-10.6: 32.0.0.207 (Adobe Systems, Inc. - installed 2019-06-11)

Flash Player: 32.0.0.207 (Adobe Systems, Inc. - installed 2019-06-11)

AdobePDFViewer: 9.5.5 (? - installed 2013-06-12)

o1dbrowserplugin: 5.38.6.0 (? - installed 2018-04-07)

OfficeLiveBrowserPlugin: 12.3.6 (? - installed 2013-04-26)

googletalkbrowserplugin: 5.38.6.0 (? - installed 2014-10-28)

Silverlight: 4.0.51204.0 (? - installed 2011-04-25)

iPhotoPhotocast: 7.0 (Apple - installed 2015-05-04)


Audio Plug-ins:

AppleTimeSyncAudioClock: 1.0 (Apple - installed 2019-02-08)

iSightAudio: 7.7.3 (Apple - installed 2019-02-08)

AppleAVBAudio: 506.1 (Apple - installed 2019-02-08)

DVCPROHDAudio: 1.3 (? - installed 2007-04-20)

ProIOAudio: 1.3.1 (? - installed 2004-09-16)

BluetoothAudioPlugIn: 5.0.5 (Apple - installed 2019-02-08)

AirPlay: 2.0 (Apple - installed 2019-02-08)


3rd Party Preference Panes:

Flash Player (installed 2019-05-26)

Flip4Mac WMV (installed 2012-05-15)


Time Machine:

Time Machine information not available without Full Drive Access.


Performance:

System Load: 1.22 (1 min ago) 1.30 (5 min ago) 1.32 (15 min ago)

Nominal I/O speed: 1.91 MB/s

File system: 16.89 seconds

Write speed: 1433 MB/s

Read speed: 1548 MB/s


CPU Usage Snapshot:

Type Overall

System 1 %

User 3 %

Idle 96 %


Top Processes Snapshot by CPU:

Process (count) CPU (Source - Location)

EtreCheck 23.75 % (App Store)

Other processes 9.55 % (?)

Dock 0.03 % (Apple)

SafariBookmarksSyncAgent 0.03 % (Apple)

trustd 0.03 % (Apple)


Top Processes Snapshot by Memory:

Process (count) RAM usage (Source - Location)

EtreCheck 418 MB (App Store)

Dock 120 MB (Apple)

Finder 93 MB (Apple)

photoanalysisd 92 MB (Apple)

CalendarAgent 75 MB (Apple)


Top Processes Snapshot by Network Use:

Process Input / Output (Source - Location)

mDNSResponder 588 KB / 22 KB (Apple)

apsd 43 KB / 38 KB (Apple)

netbiosd 6 KB / 2 KB (Apple)

ntpd-wrapper 384 B / 528 B (Apple)

SystemUIServer 776 B / 32 B (Apple)


Virtual Memory Information:

Physical RAM: 16 GB


Free RAM: 7.17 GB

Used RAM: 4.46 GB

Cached files: 4.37 GB


Available RAM: 11.54 GB

Swap Used: 0 B


Software Installs (past 30 days):

Install Date Name (Version)

2019-06-11 Adobe Flash Player

2019-06-18 Malwarebytes for Mac

2019-06-18 EtreCheck (5.2)


Diagnostics Information (past 7 days):

Directory /Library/Logs/DiagnosticReports is not accessible.

Enable Full Drive Access to see more information.


End of report



I pulled my Time Machine backup drive off the computer as soon as I realized that there was a serious problem, not wanting to possibly corrupt a back up in case I'd been the victim of something malicious. My website visits are pretty harmless (I think). News, etc. Amazon. I'm fearful of something running in the background collecting data, but I certainly don't know how it might have gotten on my machine. I don't even use other wireless networks (except inside corporate client environments). I was on one last week when I noticed things start to slow down.

Truly sorry for the long explanation, but I don't know what to do. I'm not using any cloud backups or anything that might cause an obvious slow down. But, the time it takes to load the simplest of webpages tells me something is seriously wrong.

Thanks for any help you can offer!!
 

Howard2k

macrumors 68030
Mar 10, 2016
2,589
1,846
Have you tried running a speed test? (from google, search for "Speed Test")
 

treekram

macrumors 68000
Nov 9, 2015
1,849
401
Honolulu HI
You have a lot of 3rd-party kernel extensions and background programs. You should try running in Safe Mode and see if that makes a difference. If it does, one or more of these are likely causing the problem. The report says you're running Sierra and it may be that if you've upgraded or added any of these recently, they might not work well with Sierra.
https://support.apple.com/en-us/HT201262

I also noticed you have startup items for MobileMe, which Apple put to rest some time ago. You may benefit from going over the various startup items listed and removing those that you don't use.
 

duervo

macrumors 68020
Feb 5, 2011
2,307
1,032
Looks like you restored the system from an old Time Machine backup. You have some pretty old WD drivers in there. Update them, or uninstall if you don’t use the drive(a) anymore (I suspect it’s probably what you use as your Time Machine drive, but I could be wrong.)

http://downloads.wdc.com/wdapp/WD_Security_Standalone_Installer_Mac_2_1_1_61.zip

If you have an external drive attached, and it’s having an issues, it can slow your whole system down when it tries to access it for reading or writing data.

Also, you installed Adobe Flash Player on 11-JUN-2019. About a week ago, shortly before you started experiencing these issues. I’d uninstall that too.

While you’re doing that, go over all the other stuff you have installed and verify if you still need it. If you still need it, update it to a release that supports macOS 10.12 (lots of stuff from 2008-2013 on there.) if you don’t need it, or can’t get an update to support 10.12, then uninstall it.
 

squonk2

macrumors newbie
Original poster
Dec 5, 2014
10
0
Thank you ALL! I'm grateful for your expertise. Here's what I've done since reading your responses:

1) Speed Test - I performed this first on my wife's iMac running Sierra because we're both wireless on our same Comcast internet. Her speed was 32.76 Mbps Download 5.91Mbps Upload. Mine on the same network was 0.46 Mbps Download and 0.60Mbps Upload. YIKES!!

2) Uninstalled Flash Player. I've heard unreliable things about Flash Player, but had to install it last week to purchase baseball tickets from MLB Team's website. It is now uninstalled.

3) Booted in Safe Mode (Thanks! Never done that). All booted fine, but same browser hang ups. Ran a Speed Test and results were 1.04 Mbps Download and 1.07 Mbps Upload.

4) Rebooted in Normal Mode - All booted normally. Ran a Speed Test and results were 0.18 Mbps Download and 1.45 Mbps Upload. UGH!

5) I primarily use Firefox and when this started happening a new version was available. So, I upgraded to 67.0.2 hoping it would fix the issue. It has not. I'm having the same slowness issues with Safari 12.0.3.

6) You are correct that My Time Machine backs up to an external WD hard drive. It has been disconnected throughout this process as I didn't want anything harmful to find its way to the back up. There have been no external drives connected since last week.

7) I purchased this MacBook Pro used from OWC. It was fresh with a new copy of Sierra and I set it up as mine from a Time Machine backup from my old 2011 MacBook Pro, which was transferred over from my old 2008 MacBook Pro. That's probably why there's some old stuff in there (like anything related to Mobile Me).

So, The Flash Player is the only thing that I can think of that's been newly introduced around the time things started slowing down. It's now gone and I'm still having the same issues. I'd be happy to delete anything that's unnecessary, but am unsure how to do that (especially with anything like a "kernel extension"). I apologize for my lack of knowledge.

Any links or guidance are greatly appreciated. Again, thanks so much for your time!
 

Howard2k

macrumors 68030
Mar 10, 2016
2,589
1,846
Thanks, they both look ok. Well, you know, crap, but ok, all things considered. :). Certainly I wouldn't expect to see the sort of degradation you're seeing.

You could spend a bunch of time trouble shooting this, wifi problems can be tricky, but I would consider two courses of action:

1- Buy a replacement router. Preferably one that support 5GHz. Configure your 5GHz and 2.4GHz networks separately, and try it just on a 5GHz connection.

2- Backup, wipe, and from a non-restored clean OS, see if the Macbook still shows the same issues.

I'd probably start with option 2, though option 1 might be more fun.

If you want to troubleshoot, in no particular order you could:
* ensure that all USB devices (including USB hubs) are disconnected for all awake computers that are nearby,
* reboot the router and MacBook Pro, backup router, hard reset router, and reconfigure your router (don't restore),
* create a guest account, reboot, login as guest without logging into your primary account, and see if it's still poor.
* take your Macbook Pro to another network (maybe there is a coffee shop nearby) and see how it runs with speedtest.
 
  • Like
Reactions: duervo

chabig

macrumors 603
Sep 6, 2002
5,905
3,146
Aside from Flash Player, you have a lot of obsolete software running on that machine--53 32-bit apps!

Notable plug-ins that are obsolete:
Flip4Mac
Silverlight

Additionally, many of the other plug-ins are just plain old. Look at their install dates. 2008?

You might benefit from backing up all of your data and doing a clean install. Then on a case by case basis, install the applications that you really use and that are up to date.
 
  • Like
Reactions: duervo

squonk2

macrumors newbie
Original poster
Dec 5, 2014
10
0
Thank you all for the suggestions!

Just a few more questions from a less knowledgeable person... :)

How are you assessing what software is old? In my Applications? I don't know how 53 are obsolete when there are only 59 Applications in my Applications folder? You're referring to background applications of some sort? How do I asses what I can delete of my plug-ins? I deleted Flip4Mac and Silverlight (I think). I'm sure there are old things that just got transferred from the Time Machine backups of the older MBP's and I'd be happy to delete them, I'm fearful of deleting something that might be important to operation. Sorry to be a bit dim on this particular issue.

I know how to do a clean install, but the OS was preloaded when I bought the machine. So, I don't have a copy. Is there somewhere that I may download a legit version of OSX Sierra? The last time I asked Apple Support for a copy of an older OS, they got pretty terse and uncooperative.

The browsers are still running slow. I'm eager to try your suggestions. Thanks again for your guidance. You've all been really helpful!
 

New_Mac_Smell

macrumors 68000
Oct 17, 2016
1,914
1,491
Shanghai
Buy a new router is probably the best way. You're connected on N which is quite old at this stage. Could be any number of thins with the router, the connection protocol, the channel congestion, MTU etc. Honestly, just try use a newer decent router. There shouldn't be anything wrong with the actual laptop and I fear you'll spend days trying to solve this one.
 

duervo

macrumors 68020
Feb 5, 2011
2,307
1,032
Connect your MacBook Pro to your wife’s iMac with a USB-C-to-A cable, and start the iMac in target disk mode. Then, power on your MacBook Pro and hold down the option key. You should see the iMac’s drive as a boot selection. Boot from it, and test the WiFi.

When you’re done, shut down the MacBook Pro first, and then power off the iMac by pressing the power button until it turns off.

You can read more about Target Disk Mode here, as I haven’t covered it all: https://support.apple.com/en-us/HT201462