browsers not loading pages.

Discussion in 'Mac mini' started by steve knight, Feb 8, 2018.

  1. steve knight macrumors 68030

    steve knight

    Joined:
    Jan 28, 2009
    #1
    Newest mac mini this started happening with the new os I think. but on all my browsers safari, firefox, and chrome. certain sites will not load at all or really slowly. facebook will not always reload on safari but may do better on the other two. but the worst is google search. it may fail on all the browsers even chrome. on chrome you will get a error but reloading usually works. like I tried to connect to swappa and none of the browsers would do it at all chrome finally did slowly. I have cleaned the cache and that helped for a few days.
    Mac mini (Late 2014)
    2.6 GHz Intel Core i5
    8 GB 1600 MHz DDR3
     
  2. steve knight thread starter macrumors 68030

    steve knight

    Joined:
    Jan 28, 2009
    #2
    I thought about it but it is random and way too many sites. I can use my phone and iti s fine. google is never slow. but sometimes I can't search on any browser on my computer.
     
  3. treekram macrumors 68000

    Joined:
    Nov 9, 2015
    Location:
    Honolulu HI
    #3
  4. steve knight thread starter macrumors 68030

    steve knight

    Joined:
    Jan 28, 2009
    #4
    I will give that a shot. when it started in safari I started using firefox again. then it started happening there. and chrome.
     
  5. steve knight thread starter macrumors 68030

    steve knight

    Joined:
    Jan 28, 2009
    #5
    well tried safe mode and putting firefox in safe mode after rebooting but nope still had loading issues. I only tried google but the browser jsut sits there not really loading. it may do it after several minutes or it may not.
     

Share This Page

4 February 8, 2018